Bug Hunting Session
Bug 88386 - Spelling checker fails when language changed from English to Spanish
Summary: Spelling checker fails when language changed from English to Spanish
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.7.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-14 02:52 UTC by Bob Furber
Modified: 2015-02-02 05:42 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of spelling checker dialogs with no text language selected (102.94 KB, image/jpeg)
2015-01-14 02:52 UTC, Bob Furber
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Furber 2015-01-14 02:52:31 UTC
Created attachment 112193 [details]
screenshot of spelling checker dialogs with no text language selected

Problem description: Spelling checker fails when language changed from English (UK) to Spanish (Mexico)

Steps to reproduce:
1. Default setting for LibreOffice English (UK)
2. Write a document in Spanish. It is full of [English] spelling errors
3. Tools → Language for all text → Spanish (Mexico)

Current behavior:
4. spelling errors are not marked
5. Tools → Spelling and Grammar
6. attached "Spelling" dialog pops up with no text language selected
7. LibreOffice 4.2.7.2 dialog pops up over the "Spelling" dialog: "Continue checking at the beginning of document?"
8. regardless of whether I click Yes or No, both dialogs close, preventing me from setting "Text language"

Expected behavior:
4. the dictionary would be swapped from English (UK) to Spanish (Mexico)
5. misspelled words in Spanish would be marked
6. r-clicking on marked words would pop up a list of candidate replacement words
Comment 1 Urmas 2015-01-30 07:30:26 UTC
Do you have a Spanish spellchecker installed?
Comment 2 Buovjaga 2015-01-31 11:27:13 UTC
Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information.
Comment 3 Bob Furber 2015-01-31 20:55:23 UTC
How do I determine if I have a Spanish spellchecker installed?
Comment 4 Buovjaga 2015-02-01 11:12:31 UTC
(In reply to Bob Furber from comment #3)
> How do I determine if I have a Spanish spellchecker installed?

If you type into a terminal
locate hunspell
what does it say?
Comment 5 Bob Furber 2015-02-01 18:45:56 UTC
It looks like this is not a bug after al, but a missing dictionary. Forgive the false alarm. It seems to be a usability issue instead.

robert@abc:~$ locate hunspell
/usr/include/scribus/plugins/tools/hunspellcheck
/usr/include/scribus/plugins/tools/hunspellcheck/hunspelldialog.h
/usr/include/scribus/plugins/tools/hunspellcheck/hunspelldict.h
/usr/include/scribus/plugins/tools/hunspellcheck/hunspellplugin.h
/usr/include/scribus/plugins/tools/hunspellcheck/hunspellpluginimpl.h
/usr/include/scribus/plugins/tools/hunspellcheck/hunspellpluginstructs.h
/usr/lib/scribus/plugins/libhunspellplugin.so
/usr/lib/x86_64-linux-gnu/libhunspell-1.3.so.0
/usr/lib/x86_64-linux-gnu/libhunspell-1.3.so.0.0.0
/usr/sbin/update-dictcommon-hunspell
/usr/share/hunspell
/usr/share/doc/hunspell-en-us
/usr/share/doc/libhunspell-1.3-0
/usr/share/doc/hunspell-en-us/README.txt
/usr/share/doc/hunspell-en-us/changelog.Debian.gz
/usr/share/doc/hunspell-en-us/copyright
/usr/share/doc/libhunspell-1.3-0/changelog.Debian.gz
/usr/share/doc/libhunspell-1.3-0/copyright
/usr/share/hunspell/en_AU.aff
/usr/share/hunspell/en_AU.dic
/usr/share/hunspell/en_GB.aff
/usr/share/hunspell/en_GB.dic
/usr/share/hunspell/en_US.aff
/usr/share/hunspell/en_US.dic
/usr/share/hunspell/en_ZA.aff
/usr/share/hunspell/en_ZA.dic
/usr/share/locale-langpack/en_AU/LC_MESSAGES/hunspell.mo
/usr/share/locale-langpack/en_GB/LC_MESSAGES/hunspell.mo
/usr/share/man/man8/update-dictcommon-hunspell.8.gz
/var/cache/dictionaries-common/hunspell.db
/var/lib/dictionaries-common/hunspell
/var/lib/dictionaries-common/hunspell/myspell-en-au
/var/lib/dpkg/info/hunspell-en-us.list
/var/lib/dpkg/info/hunspell-en-us.md5sums
/var/lib/dpkg/info/libhunspell-1.3-0:amd64.list
/var/lib/dpkg/info/libhunspell-1.3-0:amd64.md5sums
/var/lib/dpkg/info/libhunspell-1.3-0:amd64.postinst
/var/lib/dpkg/info/libhunspell-1.3-0:amd64.postrm
/var/lib/dpkg/info/libhunspell-1.3-0:amd64.shlibs
robert@abc:~$