Download it now!
Bug 88388 - CALC is not exporting ODS graphs to XLS, XLT and UOS correctly
Summary: CALC is not exporting ODS graphs to XLS, XLT and UOS correctly
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: UOF
  Show dependency treegraph
 
Reported: 2015-01-14 05:38 UTC by Carlos Roberto
Modified: 2019-09-19 12:46 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Table 1 with graphs (36.48 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-01-14 05:38 UTC, Carlos Roberto
Details
Screenshot how I see. (277.10 KB, image/png)
2015-01-14 21:27 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carlos Roberto 2015-01-14 05:38:23 UTC
Created attachment 112197 [details]
Table 1 with graphs

How to reproduce:

1- Open attachment Table 1.ods
2- You can see graphs normally.
3- Save as Table 2.xls with LibreOffice 4.2.8
4- Open Table 2.xls in LibreOffice 4.2.8 or Microsoft Office 2010.
5- Graphs are broken.

LibreOffice should export graphs correctly.
Comment 1 raal 2015-01-14 06:44:52 UTC
I can confirm with LO 4.3.5, win7
Comment 2 m.a.riosv 2015-01-14 21:27:36 UTC
Created attachment 112252 [details]
Screenshot how I see.

I can't reproduce with 4.2.8.

Attached screenshot with both ods and xlsx.

Chart has the data table embedded in the chart.

Maybe resetting the user profile can help.
https://wiki.documentfoundation.org/UserProfile#Default_location or http://ask.libreoffice.org/en/question/903/where-are-the-libreoffice-data-profile-files/
Comment 3 Yogesh Bharate 2015-04-20 10:36:36 UTC
I checked this issue on latest Ubuntu build.
Issue cannot reproduce.


Build ID:
Version: 5.0.0.0.alpha1+
Build ID: d68cf40b7a16e20e99c15d310b24c91c2ca89ef6
Locale: en_IN
Comment 4 Carlos Roberto 2016-01-09 01:58:47 UTC
I still reproduce on two computers, one with Windows 7 32-bits and another Windows 10 64-bits.

After saving file as .xls (97-2003) please close Libreoffice 5.0.4.2 and open again with file exported.

No longer happen saving file as .xlsx (2007-2013).
Comment 5 testjava 2016-01-16 18:36:32 UTC
Confirmed with :
Version: 5.0.3.2
Build ID: e5f16313668ac592c1bfb310f4390624e3dbfb75
Locale: it-IT (de_DE)

Windows XP 32 bit
Comment 6 Carlos Roberto 2016-01-17 00:00:31 UTC
Reproducible saving as .XLT and .UOS formats also.
Comment 7 thoskk 2016-02-14 16:29:46 UTC
V. 5.0.4.2, Win7 64-Bit
The result of saving in .uos format will produce empty document when re-opened with LibreOffice and OpenOffice.
Comment 8 Carlos Roberto 2016-04-16 13:59:52 UTC
Set version to "inherited from OOo", reproducible with:

BrOffice 3.3.4 
OOO330m19 (Build:401)
tag libreoffice-3.3.4.1
Comment 9 QA Administrators 2018-09-16 02:48:54 UTC Comment hidden (obsolete)
Comment 10 Carlos Roberto 2018-09-16 06:33:23 UTC
It still happens on XLS, XLT and UOS.

Version: 6.1.1.2 (x64)
Build ID: 5d19a1bfa650b796764388cd8b33a5af1f5baa1b
CPU threads: 4; OS: Windows 10.0; UI render: default; 
Locale: pt-BR (pt_BR); Calc: group threaded
Comment 11 QA Administrators 2019-09-17 02:47:50 UTC Comment hidden (obsolete)
Comment 12 Carlos Roberto 2019-09-19 12:46:19 UTC
Still persist.

Versão: 6.3.1.2 (x64)
ID de compilação: b79626edf0065ac373bd1df5c28bd630b4424273
Threads da CPU:4; SO:Windows 10.0; Realizador da interface: GL; VCL: win; 
Local: pt-BR (pt_BR); Idioma de IU: pt-BR
Calc: CL