Bug Hunting Session
Bug 88403 - FILESAVE: XLSX - Changed page break information not being saved
Summary: FILESAVE: XLSX - Changed page break information not being saved
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xlsx
Depends on:
Blocks: XLSX Calc-Page-Break
  Show dependency treegraph
 
Reported: 2015-01-14 14:31 UTC by liuyong
Modified: 2018-07-16 11:27 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
detailed information about bug (90.86 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2015-01-14 14:31 UTC, liuyong
Details
detailed information about bug (79.53 KB, application/pdf)
2015-01-14 14:42 UTC, liuyong
Details
Resulting XLSX file saved on test step 5 (5.20 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2017-06-03 19:26 UTC, Johnny_M
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuyong 2015-01-14 14:31:38 UTC
Created attachment 112218 [details]
detailed information about bug

Problem description: 

Steps to reproduce:
1. create a test.xlsx file.
2. set the test.xlsx file page break information.
3. save the test.xlsx file
4. open the last saved test.xlsx file,we will find the page break information can not saved.
★about more detailed information,please see the attachment

Current behavior:
 can not save the xlsx file page break information.

Expected behavior:
 we hope to save the xlsx files page break information.
Comment 1 liuyong 2015-01-14 14:37:48 UTC Comment hidden (obsolete)
Comment 2 liuyong 2015-01-14 14:42:44 UTC
Created attachment 112219 [details]
detailed information about bug
Comment 3 liuyong 2015-01-14 14:56:28 UTC Comment hidden (obsolete)
Comment 4 liuyong 2015-01-14 14:57:48 UTC Comment hidden (obsolete)
Comment 5 Robinson Tryon (qubit) 2015-03-05 20:40:09 UTC Comment hidden (obsolete)
Comment 6 Robinson Tryon (qubit) 2015-03-05 20:41:05 UTC Comment hidden (obsolete)
Comment 7 Joel Madero 2015-03-06 03:49:10 UTC
hi Liuyong -

The instructions as provided are not clear. Please clarify the steps. 

1. create a test.xlsx file.
- what does this mean? An empty file?

2. set the test.xlsx file page break information.
-please explain what this means, give explicit steps on how to do it.

setting to NEEDINFO - once you provide clearer instructions please set to UNCONFIRMED thanks!
Comment 8 Flow__ 2015-03-18 15:44:32 UTC
This bug is really annoying for us. We use a lot of multi-page excel sheets and every time we save one as xlxs (open office XML) all page breaks are gone.

To clarify the steps:

1. create a test.xlsx file.
- what does this mean? An empty file?

2. set the test.xlsx file page break information.
-please explain what this means, give explicit steps on how to do it.



It means:

1. Choose new file
2. Set page break information (choose view - page break information, and set it so that you have a couple of pages instead of 1)
3. Save this file as test.xlsx
4. Now close the file, and open it again

You will see the page breaks have disappeared.

For this reason we are forced to use the excel 97 file format if we send files to other people, and save files as .ods for ourselves, meaning we have almost every file twice.

I hope this can be fixed. Thanks!
Comment 9 Joel Madero 2015-03-18 16:20:27 UTC
Unconfirmed is appropriate status not REOPENED. Also removing CRITICAL - this is saved for our most serious crashers. This is a normal bug that prevents high quality work - that's it.

As for it being really annoying - I'm not sure who "us" is (when you say this is really annoying for "us") if it's a company or business, I suggest considering getting support with a third party support company.

http://www.documentfoundation.org/certification/developers/

Otherwise - it'll be a wait game until a volunteer decides to fix it.
Comment 10 liuyong 2015-03-19 06:03:48 UTC
my english is not good, please forgive me.
thank you,resovled my problem.
Comment 11 Flow__ 2015-03-19 06:58:01 UTC
liuyong, may I ask how you resolved this problem?
Comment 12 Timur 2015-03-19 12:02:44 UTC
Changed from Fixed to WorksForMe. 
Strange bug, I also reproduced it at first and not the next time, so I cannot confirm it.
Comment 13 liuyong 2015-03-24 01:16:52 UTC
(In reply to Flow__ from comment #11)
> liuyong, may I ask how you resolved this problem?

>For this reason we are forced to use the excel 97 file format if we send files >to other people, and save files as .ods for ourselves, meaning we have almost >every file twice.

following you 【Comment 8】 replied, i use the excel 97 file format to replace xlsx file format.
Comment 14 panjunyong 2016-10-21 04:48:44 UTC
We have the same issue with recent Libreoffice 5.2.

1. Open a .xlsx created by MS Excel and all page break lost.
2. Open a Libreoffice created .xlsx using MS Excel, page break lost too.

I just googled and found someone else have the same issue:

https://ask.libreoffice.org/en/question/36586/lost-page-breaks-on-xlsx-file/
Comment 15 Buovjaga 2016-10-21 16:46:41 UTC
(In reply to panjunyong from comment #14)
> We have the same issue with recent Libreoffice 5.2.
> 
> 1. Open a .xlsx created by MS Excel and all page break lost.
> 2. Open a Libreoffice created .xlsx using MS Excel, page break lost too.
> 
> I just googled and found someone else have the same issue:
> 
> https://ask.libreoffice.org/en/question/36586/lost-page-breaks-on-xlsx-file/

This is about creating an XLSX file in LibreOffice, not Excel. Please open a new report for your problem.
Comment 16 Johnny_M 2017-06-03 19:26:08 UTC
Created attachment 133828 [details]
Resulting XLSX file saved on test step 5

I've come across this recently as well, both with XLSX files created by LO and ones (apparently) created by MS Excel.

Minimal reproduction procedure:

Action:
1. Open a new Calc spreadsheet
2. Enter the word "test" somewhere in the middle of the sheet (e.g., cell K30)
3. Change to the page break view (menu View -> Page Break)
4. Drag and drop the right boundary of Page 1 to the one of Page 2, to have one single page instead of two
5. Save the file in the "Microsoft Excel 2007-2013 XML (.xlsx)" format
6. Close the file
7. Open the file again

Expected results:
3. Two pages are shown (Page 1 and Page 2)
4. Page 1 covers the entire used area
5. File gets saved
6. File closed
7. File opens in the Page Break view with Page 1 covering the entire used area, as set before saving

Actual results:
3. to 6. As expected
7. Page 1 and Page 2 are shown as before the boundary change


The issue also occurs with existing XLSX files created with both MS Excel or LO: One opens the file in LO, changes the page breaks and saves the file. Then, after re-opening the saved file in LO, the page breaks are back to as they were before the change. (Tested with https://bugs.documentfoundation.org/attachment.cgi?id=124761&action=edit, after first seeing the issue on another, small XLSX file apparently created by MS Excel 2016 according to its file properties.)

The issue occurs only when saving as XLSX, not with XLS or ODS. (Saving to one of the latter two is the workaround mentioned in the comment 8.)


Reproducible with (these are the only ones I tried):
- Ubuntu 16.10 Mate, 64 bit; LO as provided by Ubuntu's LO 5.2 PPA:
LO 5.2.6 release

- Ubuntu 17.04 Mate, 64 bit; LO as provided by Ubuntu's LO 5.3 PPA:
Version: 5.3.3.2
Build ID: 1:5.3.3~rc2-0ubuntu0.17.04.1~lo0
CPU Threads: 4; OS Version: Linux 4.10; UI Render: default; VCL: gtk3; Layout Engine: new; 
Locale: en-US (en_US.UTF-8); Calc: group

- Ubuntu 17.04 Mate, 64 bit, live ISO; LO as provided by TDF:
Version: 5.5.0.0.alpha0+
Build ID: 066665644b398a882e6cded98af5bb060af41d76
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-06-01_00:32:47
Locale: en-US (en_US.UTF-8); Calc: group

Given the apparent number of people affected I'm taking the liberty of changing the bug status to NEW. Additional confirmations (other OSes, LO versions, etc.) are still welcome.
Comment 17 Johnny_M 2017-06-04 12:31:28 UTC
Reproducible also on following:

- Linux Mint 17.1, 64 bit; LO as provided by Ubuntu's LO 5.2 PPA:
Version: 5.1.6.2
Build ID: 1:5.1.6~rc2-0ubuntu1~trusty1
CPU Threads: 2; OS Version: Linux 3.13; UI Render: default; 
Locale: de-DE (en_GB.UTF-8); Calc: group

- Windows XP, 32 bit; LO as TDF release:
Version: 5.2.0.4
Build-ID: 066b007f5ebcc236395c7d282ba488bca6720265
CPU-Threads: 2; BS-Version: Windows 5.1; UI-Render: Standard; 
Gebietsschema: de-DE (de_DE)

- Windows XP, 32 bit; LO portable release:
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

==> Inherited from OOo
Comment 18 Yousuf Philips (jay) (retired) 2017-07-02 23:05:11 UTC
So the problems seems to be that LO has been saving the page breaks in way that is understood by MS Office 2013, but not understood by 2010 and 2007, as opening attachment 133828 [details] in Excel 2013 works fine but doesnt in Excel 2010 and 2007.

It also seems that LO has recently (within the last 2 weeks) been able to read this 2013 type page breaks, as it opens it correctly in master.

Version: 6.0.0.0.alpha0+
Build ID: 34c77d4bf3d2924c4ad26728d4c491b393fa0fc8
CPU threads: 2; OS: Linux 4.4; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: group
Comment 19 QA Administrators 2018-07-15 02:42:48 UTC Comment hidden (obsolete)
Comment 20 Timur 2018-07-16 11:27:47 UTC
WFM now with 6.2+ and 6.0.4 per steps in Comment 16.