Bug 88418 - FORMATTING: Wingdings font not applied in DOCX file (symbols)
Summary: FORMATTING: Wingdings font not applied in DOCX file (symbols)
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: needsWingdingsFont
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-14 19:09 UTC by Geoffrey
Modified: 2015-01-15 08:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Problematic file (12.57 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-01-14 19:09 UTC, Geoffrey
Details
Word 2013 opening the problematic file (27.74 KB, image/png)
2015-01-15 08:18 UTC, Geoffrey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Geoffrey 2015-01-14 19:09:49 UTC
Created attachment 112244 [details]
Problematic file

The arrow is not visible in LibreOffice Writer, while it is in Word. If I select the arrow that is displayed as  and select Wingdings from the font list, the arrow is displayed again.
Comment 1 Robinson Tryon (qubit) 2015-01-14 20:29:32 UTC
Comment on attachment 112244 [details]
Problematic file

fix mimetype
Comment 2 Robinson Tryon (qubit) 2015-01-14 20:38:36 UTC
(In reply to Geoffrey from comment #0)
> Created attachment 112244 [details]
> Problematic file
> 
> The arrow is not visible in LibreOffice Writer, while it is in Word.

It would be great if you could attach a screenshot of how this document appears in Word (along with Word/OS version info).

> If I
> select the arrow that is displayed as  and select Wingdings from the font
> list, the arrow is displayed again.

I don't have Wingdings installed here. Perhaps you could use a more universally-supported arrow character? There are many here:
http://www.alanwood.net/unicode/arrows.html

The following 4 appear in Liberation Sans, among other fonts: ← ↑ → ↓
Comment 3 Geoffrey 2015-01-15 08:18:59 UTC
Created attachment 112275 [details]
Word 2013 opening the problematic file
Comment 4 Geoffrey 2015-01-15 08:34:56 UTC
> It would be great if you could attach a screenshot of how this document
> appears in Word (along with Word/OS version info).

Done. LibreOffice 4.3.5 on Manjaro Linux was used in testing. Word 2013 was running on Windows 7.

> > If I
> > select the arrow that is displayed as  and select Wingdings from the font
> > list, the arrow is displayed again.
> 
> I don't have Wingdings installed here. Perhaps you could use a more
> universally-supported arrow character? There are many here:
> http://www.alanwood.net/unicode/arrows.html

The problem is that I do receive many documents with a Wingdings arrow in it.<s> And despite Wingdings being installed on my system, it does not automatically apply the Wingdings font.

When I select the arrow and choose Wingdings from the font list, the arrow is displayed. But on FILEOPEN it is not.</s>
Wingdings is probably contained in WPS Office. After copying the Wingdings font from Windows C:\Windows\Fonts\wingding.ttf to /usr/share/fonts/TTF the issue is resolved. I think I was confused with webdings.

Therefore, this bug is invalid since when testing, I did not have Wingdings installed.
Comment 5 Geoffrey 2015-01-15 08:40:40 UTC
On any Arch Linux based distro, you can simply get Wingdings from AUR. The package is called webcore-fonts. No need to copy them from Windows :).