Bug Hunting Session
Bug 88438 - FONTS: Provide visual clue when substituting a metric-compatible font
Summary: FONTS: Provide visual clue when substituting a metric-compatible font
Status: RESOLVED DUPLICATE of bug 96872
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.4.0.2 rc
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Font-Substitution
  Show dependency treegraph
 
Reported: 2015-01-15 05:23 UTC by Robinson Tryon (qubit)
Modified: 2017-11-04 11:39 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Robinson Tryon (qubit) 2015-01-15 05:23:56 UTC
TESTING with LO 4.4.0.2 + Ubuntu 14.04

If a document uses fonts not present on the current system, LibreOffice engages in font substitution (e.g. see attachment 111591 [details], a DOC file that uses Cambria), and provides a subtle clue by listing the original font name in *italics* in the font-picker drop-down.

In the test file mentioned above, the missing font is Cambria, which is very convenient for us as LibreOffice can substitute Caladea, a font that's metric-compatible:
https://fedoraproject.org/wiki/Google_Crosextra_Caladea_fonts

It would be beneficial if we could provide a further clue so that users would know if font substitution is taking place with a metric-compatible font. There could be a asterisk provided, or a little red tag with text "Metric compatible", or something else.
Comment 1 Urmas 2015-01-15 06:34:44 UTC
And how exactly we can know metrics of random absent fonts?
Comment 2 Robinson Tryon (qubit) 2015-01-15 06:38:02 UTC
(In reply to Urmas from comment #1)
> And how exactly we can know metrics of random absent fonts?

There are a number of fonts that have been specifically designed to be metric-compatible with specific proprietary fonts. All we'd have to do is keep a list that matches up non-Free and Free fonts. I assume that we have something like that already (or it's inside the fonts themselves?) as LibreOffice will substitute Caladea for Cambria every time.
Comment 3 Arnaud Versini 2015-01-17 20:25:03 UTC
I agree, this bug should go to UX Team.
Comment 4 Robinson Tryon (qubit) 2016-08-25 04:21:36 UTC Comment hidden (obsolete)
Comment 5 Heiko Tietze 2017-08-14 09:25:00 UTC
This request is covered in the proposal at https://design.blog.documentfoundation.org/2016/10/21/dealing-with-missing-fonts/. The meta ticket contains further information.
Comment 6 Timur 2017-08-29 16:02:20 UTC
Since this bug is New, I'd close this one as a duplicate of Bug 96872 but changing that bug so only non metric-compatible font replacements are red.
For metric-compatible font replacement, Bug 61134 is sufficient enough.
Comment 7 Heiko Tietze 2017-08-31 11:56:56 UTC

*** This bug has been marked as a duplicate of bug 96872 ***