Bug Hunting Session
Bug 88470 - [UI] inserted images should be named with their filenames not just numbered
Summary: [UI] inserted images should be named with their filenames not just numbered
Status: RESOLVED DUPLICATE of bug 87408
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.7.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: a11y Images
  Show dependency treegraph
 
Reported: 2015-01-15 17:28 UTC by digisus
Modified: 2019-06-28 19:22 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (15.87 KB, image/png)
2015-01-15 17:28 UTC, digisus
Details

Note You need to log in before you can comment on or make changes to this bug.
Description digisus 2015-01-15 17:28:04 UTC
Created attachment 112310 [details]
screenshot

Hello!

Current behaviour:

Inserting an image in a writer document gives them a simple numbered generic name in the navigator. With many images, it becomes useless that I can use images to navigate because I would have to remember what Image15 was. So, effectively navigating by images is not possible.


Expected behaviour:

A newly inserted image is given its original filename (*.png|jpg), maybe adjusted if needed. For example, if spaces are a problem, replace them with "-" etc. The extension is (usually) negligible and could be removed.

This way the images section in the navigator becomes really useful because I can immediately understand where I am going in the document when I click e.g. "population-chart-by-age" instead of "Image17".

Thanks for making navigator even more awesome! :-)
Comment 1 Robinson Tryon (qubit) 2015-01-15 20:28:21 UTC
(In reply to digisus from comment #0)
> A newly inserted image is given its original filename (*.png|jpg), maybe
> adjusted if needed. For example, if spaces are a problem, replace them with
> "-" etc. The extension is (usually) negligible and could be removed.

Sounds like a plausible improvement.

Status -> NEW
Component -> ux-advise
Hardware -> (generalize)
Comment 2 Robinson Tryon (qubit) 2016-08-25 05:26:59 UTC Comment hidden (obsolete)
Comment 3 LibreTraining 2017-01-31 00:51:41 UTC
I came here looking to add this enhancement request myself.
Really unfortunate this has been sitting here for 2 years.

It would seem that this would not be that difficult to add.
The file name is available and just has to be entered into the name field instead of a useless generic number.

When working on long documents we can have many, many images.
Because of this we usually have some sort of naming convention to help identify all of them. 
All that is lost as soon as the image is inserted into the document.
That's just silly.

The current situation makes the Navigator image list essentially useless.
There is no useful image information there.

Just open any of the LibreOffice documentation ODT files, open the navigator, and you will see a long list of useless generic image names.

In the v5.1 Getting Started Guide the last image name is Image409!
That is not useful.

Same for the OLE objects.
The last OLE object is named Object59.
Crazy.
It should just default to the object name as it is being placed.
Much better usability.

Same with Drawing objects.
"Shape2" is useless.

The assume the goal of the Navigator is to be able to quickly find elements of the document, and then navigate to them.
Currently for the Images, OLE Objects, and Drawing objects the navigator is essentially useless.

Please consider moving this enhancement up in the queue.



P.S. I am currently working on a documentation project titled "Creating Long Documents with LibreOffice Writer 5.3" ... and would really like to be able to describe the enhancement and not the annoyances.
Comment 4 V Stuart Foote 2017-01-31 02:14:25 UTC
Absent assignment of name and description on insertion--the object has to be named something.

But this really is invalid--the file name is not especially helpful, rather bug 39558 and bug 101193 and improving handling of name, description and caption for images on insertion--forcing assignment of a useful name for the object rather than the generic numbered instance would be more helpful default across workflows.

Suppose that could be the automated to default to image name on filesystem--but even that is problematic for use in navigator.

Better to enforce bug 39558--and then assure that the name and description do not go missing on export and save-as at completion of editing.
Comment 5 V Stuart Foote 2019-06-28 19:22:18 UTC

*** This bug has been marked as a duplicate of bug 87408 ***