Bug 88497 - FILEOPEN: error bar in spreadsheet not shown
Summary: FILEOPEN: error bar in spreadsheet not shown
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2015-01-16 14:38 UTC by KELLER
Modified: 2018-11-29 21:16 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Error bar in spreasheet (364.06 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-01-16 14:44 UTC, KELLER
Details
screenshot of the error bar as shown correctly in 3.6.7 (39.66 KB, image/png)
2015-01-17 09:47 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description KELLER 2015-01-16 14:38:46 UTC

    
Comment 1 KELLER 2015-01-16 14:44:33 UTC
Created attachment 112348 [details]
Error bar in spreasheet

Hello.

My file works on LibreOffice Calc 3.6 or less, but didn't work on LibreOffice Calc 4.xx.
The error bar didn't appear.
My english isn't good to explain better.
Sorry

Good luck
Comment 2 tommy27 2015-01-17 09:45:45 UTC
I confirm issue under Win8.1 x64 using LibO 4.0.4, 4.2.5, 4.3.5 and recent 4.5.0 daily build.

works fine in 3.6.7 and 4.2.4 so it's a regression in the middle of the 4.2.x development (probably a good candidate for the MAB list)

the list of bugfixes of 4.2.5 is here:
https://wiki.documentfoundation.org/Releases/4.2.5/RC1
https://wiki.documentfoundation.org/Releases/4.2.5/RC2

probably one of those fix caused this regression as a side effect.
needs bibisecting

adding Calc developer to CC list.

@KELLER
until we try to fix the bug you can at least upgrade to LibO 4.2.4.2
Comment 3 tommy27 2015-01-17 09:47:32 UTC
Created attachment 112378 [details]
screenshot of the error bar as shown correctly in 3.6.7

that pink error bar in the 40%-50% column is not shown in LibO 4.2.5 and following relases. looks fine in 4.2.4 and older versions
Comment 4 Dave Richards 2015-01-20 13:45:04 UTC
My testing indicates that this spreadsheet is slow in scrolling, seems like LO needs some optimizations.  I was able to get a clean bibisect and it clearly stops displaying the error bar.

1de992ed60dad1fd65ff0383a8610b0468d9d772 is the first bad commit
commit 1de992ed60dad1fd65ff0383a8610b0468d9d772
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Tue May 20 12:30:20 2014 +0000

    source-hash-8bf0b9536cb33dfcce8a811b70c2ead285300f3f
    
    commit 8bf0b9536cb33dfcce8a811b70c2ead285300f3f
    Author:     Chris Sherlock <chris.sherlock79@gmail.com>
    AuthorDate: Thu May 1 23:42:49 2014 +1000
    Commit:     Chris Sherlock <chris.sherlock79@gmail.com>
    CommitDate: Fri May 2 00:18:10 2014 +1000
    
        coverity#1209779 & coverity#1209780 Resource leak
    
        Have the testBasics() function clean up after itself - delete p2 and
        p4 at the end of the function.
    
        Change-Id: Ib0c732e1962da94fde0e0da307f610dd36f49eda

:100644 100644 5a882bfa118f7e6bdce2a5352a84980e3317b63c 1315213d62e9db779916ce48371a89fa31867b0b M	ccache.log
:100644 100644 f8bdc1225a7c2dc7a94ed9a6367b7298f4ee0a37 9c728d68efbe36be265f19b9a78f9d6280176e98 M	commitmsg
:100644 100644 3cd5d50875f1e67f2f758bdfd10744eb6d47d13b 58e54f9015582d37978cd75e1ebdaed7ba12ea8f M	make.log
:040000 040000 65e23a71dc754b4a799d96c3e25d191237cfddb1 8236eb41fc03f7f798cda8f31383bf2087db52e9 M	opt


# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect good 4850941efe43ae800be5c76e1102ab80ac2c085d
# skip: [a900e72b6357882284c5955bdf939bf14269f5fb] source-hash-dd1050b182260a26a1d0ba6d0ef3a6fecc3f4e07
git bisect skip a900e72b6357882284c5955bdf939bf14269f5fb
# skip: [3dda83fc3a43afc6af7f5c0ffd029e610ec1b9a3] source-hash-c59b3d6c5c8096486730007d9b9b053793b90b1e
git bisect skip 3dda83fc3a43afc6af7f5c0ffd029e610ec1b9a3
# good: [4f705a8cfb1998b09f2062510b207d35a33647d8] source-hash-1eeb20f3958666ec6ba6e0fcf52e92e5eb447a14
git bisect good 4f705a8cfb1998b09f2062510b207d35a33647d8
# good: [465e2be02951f9645beb3024506a5212907caf5f] source-hash-674801eb4af21c9ae83c122499f15fa4f4785b0f
git bisect good 465e2be02951f9645beb3024506a5212907caf5f
# bad: [1de992ed60dad1fd65ff0383a8610b0468d9d772] source-hash-8bf0b9536cb33dfcce8a811b70c2ead285300f3f
git bisect bad 1de992ed60dad1fd65ff0383a8610b0468d9d772
# good: [ce3d21bc00b0756f1e7dbb4974db30e6d51b913b] source-hash-8485a276022e05bd34afb2321e72ecfad4589f7e
git bisect good ce3d21bc00b0756f1e7dbb4974db30e6d51b913b
# good: [89894d82385af13d5393f07abeb76a2c309b1828] source-hash-062e69f40b749aa8a6058c3e6ca328af86aeb45b
git bisect good 89894d82385af13d5393f07abeb76a2c309b1828
# good: [038ec16923792263990256ed738920cd761e4f70] source-hash-11b81c1026c17548bfdbb861ac696f9c6acc628e
git bisect good 038ec16923792263990256ed738920cd761e4f70
# good: [741197a13a361480f59eeb3bd1401f984f49f1c0] source-hash-9a61470eb1fa161cba70f2e9c4ea8817dc7f617e
git bisect good 741197a13a361480f59eeb3bd1401f984f49f1c0
Comment 5 Matthew Francis 2015-01-23 10:07:39 UTC
The behaviour changed as of the below commit.

Adding Cc: to markus.mohrhard@googlemail.com; Could you possibly take a look at this? Thanks


commit 200963d3019b7d296f4e22c5e6874eef8b84012b
Author: Markus Mohrhard <markus.mohrhard@googlemail.com>
Date:   Wed Apr 30 01:20:36 2014 +0200

    set graphic properties for error bars during import, fdo#78041
    
    Change-Id: I43138745b074dcacdafa090d97eeb9aa2ccecf78
Comment 6 Robinson Tryon (qubit) 2015-12-13 11:12:22 UTC Comment hidden (obsolete)
Comment 7 Xisco Faulí 2016-09-26 17:07:40 UTC
Adding Cc: to Markus Mohrhard
Comment 8 Xisco Faulí 2017-09-29 08:53:59 UTC Comment hidden (obsolete)
Comment 9 Markus Mohrhard 2018-11-29 21:16:03 UTC
Actually this looks like it is correct how it is implemented by now. The file is storing a draw:stroke="none" which tells LibreOffice to draw an error bar without a line.

I don't consider this a bug or a regression. It looks like we fixed a previous bug and unfortunately one needs to change the line format from none to continuous once. I checked that the format is correctly exported in master.