Bug Hunting Session
Bug 88529 - HIDPI support: a lot of buttons missing at editing table of contents at 120 dpi display setting
Summary: HIDPI support: a lot of buttons missing at editing table of contents at 120 d...
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: HiDPI
  Show dependency treegraph
 
Reported: 2015-01-17 10:24 UTC by Zoltán Hegedüs
Modified: 2017-05-03 08:25 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
A document with a table of contents created by an older LibreOffice or OpenOffice.org, I forget this. (336.29 KB, application/vnd.oasis.opendocument.text)
2015-01-17 10:24 UTC, Zoltán Hegedüs
Details
There is no button at 4.3.5.2 release, Hungarian, 120 dpi (116.02 KB, image/jpeg)
2015-01-17 11:47 UTC, Zoltán Hegedüs
Details
Buttons at 96 dpi (38.35 KB, image/png)
2015-01-17 19:09 UTC, Tibor Kovács
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Zoltán Hegedüs 2015-01-17 10:24:48 UTC
Created attachment 112380 [details]
A document with a table of contents created by an older LibreOffice or OpenOffice.org, I forget this.

At LibreOffice 4.3, (there is an example document) move the cursor to the table of contents, call local menu, choose edit. There is no button to create begin of hiperlink, and there is no button to create end of hiperlink. If the table of contents created by an older version of LibreOffice, or created not by LibreOffice, for example, by OpenOffice.org, at the description of the entries, the "begin/end of hiperlink" signs remained, you can move and delete these, but you can not create a new. If you delete these, you can not put back these. When you view the document, Ctrl+click to the table of contents, Writer will jump to the chapter. If the table of contents is created by LibreOffice 4.3, this is not manages, because of there is no hiperlink begin/end sign in the entries. I tried this.
Comment 1 Zoltán Hegedüs 2015-01-17 11:47:35 UTC
Created attachment 112385 [details]
There is no button at 4.3.5.2 release, Hungarian, 120 dpi

At Hungarian forum, a zizi64 tested this, and he said he sees the button. He still not give a picture from this. In Windows, the default display setting is 96 dpi, I set this to 120 dpi. Maybe this is the cause.
Comment 2 Zoltán Hegedüs 2015-01-17 15:01:32 UTC
At the line, all the buttons missing. At 96 dpi, all the buttons is visible. So this is a high-dpi support error.
Comment 3 Tibor Kovács 2015-01-17 19:09:05 UTC
Created attachment 112401 [details]
Buttons at 96 dpi

Buttons at 96 dpi
Comment 4 Zoltán Hegedüs 2015-01-17 19:23:12 UTC
Comment on attachment 112385 [details]
There is no button at 4.3.5.2 release, Hungarian, 120 dpi

Obsolete removed: the picture is required to show the difference.
Comment 5 Robinson Tryon (qubit) 2015-05-01 17:55:19 UTC
(In reply to Zoltán Hegedüs from comment #2)
> At the line, all the buttons missing. At 96 dpi, all the buttons is visible.
> So this is a high-dpi support error.

Blocks: HiDPI
Comment 6 Keith Curtis 2016-03-05 02:47:13 UTC
Can't repro on Linux with LO 5.1.
Comment 7 Buovjaga 2016-03-21 20:17:00 UTC
Zoltán: please test with 5.1.1.

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.
Comment 8 Xisco Faulí 2016-10-10 11:25:47 UTC Comment hidden (obsolete)
Comment 9 QA Administrators 2016-11-08 13:09:40 UTC Comment hidden (obsolete)
Comment 10 Yousuf Philips (jay) (retired) 2016-11-09 12:35:51 UTC
@Stuart, @Heiko, @Buovjaga: Can you guys test this to confirm this is resolved on 120 dpi on windows?
Comment 11 Buovjaga 2016-11-10 11:53:44 UTC
Zoltán: do we need a hi-dpi screen to test this? Or is it enough to use a regular screen and just mess with Windows DPI settings (in Win 8 and newer)?

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the information. And do close as worksforme, if the problem went away.
Comment 12 Heiko Tietze 2017-05-03 08:25:57 UTC
(In reply to Buovjaga from comment #11)
> Zoltán: do we need a hi-dpi screen to test this? ...

There have been some reminders. And a 'not confirmed' in comment 6, so an update likely solves the issue. Closing this ticket as ID.