Bug 88543 - REPORTBUILDER crash when defining formula of new function in Navigator
Summary: REPORTBUILDER crash when defining formula of new function in Navigator
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.4.0.2 rc
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-17 20:40 UTC by wrcam1531-libreoffice
Modified: 2015-10-11 14:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wrcam1531-libreoffice 2015-01-17 20:40:21 UTC
LibreOffice Version 4.3.5.2 (not shown in Version list), on Mac OS X 10.9.5.

Attempting to define new SUM Formula for Group Footer. When I type the left parenthesis after =SUM, LibreOffice crashes. ReportBuilder editor is unusable. Problem is repeatable. OS X reports the following:

Date/Time:       2015-01-17 15:34:36.332 -0500
OS Version:      Mac OS X 10.9.5 (13F34)
Report Version:  11
Anonymous UUID:  B95FE38D-F092-BC96-B159-0DE8CA9FE758

Sleep/Wake UUID: 694328CC-96D9-4825-B882-EC69EBA92D34

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00000000c5a60bf3
Comment 1 Alex Thurgood 2015-01-18 13:15:36 UTC
Please provide a test ODB file, with a form without the SUM function and detailed instructions as to which field you are summing on, so that we can try and reproduce.
Setting to NEEDINFO pending required information.

Please set back to UNCONFIRMED when you have done so.
Comment 2 Robert Großkopf 2015-05-03 15:09:09 UTC
Could this be a duplicate of https://bugs.documentfoundation.org/show_bug.cgi?id=89643?
Comment 3 Julien Nabet 2015-10-11 14:05:50 UTC
No feedback since about 9 months + according to last comment could be already fixed.
Let's put this one to WFM.
wrcam1531: don't hesitate to reopen this one if you can still reproduce this with recent LO version + after having provided asked information in comment 1.