Bug Hunting Session
Bug 88544 - EDITING Tools Solver fails with 4.3.5.1 under multiple OS
Summary: EDITING Tools Solver fails with 4.3.5.1 under multiple OS
Status: RESOLVED DUPLICATE of bug 80680
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: NeedsMacOSX
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-17 21:02 UTC by Spencer Graves
Modified: 2015-01-24 23:34 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Spencer Graves 2015-01-17 21:02:57 UTC
In Spreadsheet 4.3.5.1, Tools -> Solver under OS X 10.10.1 (and Windows 7 on an HP Pavilion) gave "LibreOffice requires a Java runtime environment (JRE) to perform this task.  Please install a JRE and restart LibreOffice.” I tried that on OS X.  This it said it needed an older version of JRE.  After I got that, Tools -> Solver produced, "LibreOffice quit unexpectedly.  Click Reopen to open the application again.”  

In Spreadsheet 4.3.5.1 under Ubuntu 14.04 LTS, with A1=1, A2=2, A3=(A1-A2)^2, when I asked Solver to minimize A3 by varying A1, it said, "No solution was found.  The model is not linear."  

In Spreadsheet 4.3.4.2 on a Windows 7 Fujitsu notebook, it works.
Comment 1 raal 2015-01-18 13:10:35 UTC
(In reply to Spencer Graves from comment #0)
> In Spreadsheet 4.3.5.1, Tools -> Solver under OS X 10.10.1 (and Windows 7 on
> an HP Pavilion) gave "LibreOffice requires a Java runtime environment (JRE)
> to perform this task.  Please install a JRE and restart LibreOffice.” I
> tried that on OS X.  This it said it needed an older version of JRE.  After
> I got that, Tools -> Solver produced, "LibreOffice quit unexpectedly.  Click
> Reopen to open the application again.”  

Please specify Java version.

> 
> In Spreadsheet 4.3.5.1 under Ubuntu 14.04 LTS, with A1=1, A2=2,
> A3=(A1-A2)^2, when I asked Solver to minimize A3 by varying A1, it said, "No
> solution was found.  The model is not linear."  

Works for me with Version: 4.3.6.0.0+
Build ID: 1b9bcc2e7f31e880e71c8d2a2aaf1b2839d4d32a
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-3, Time: 2014-12-14_15:56:02
Seems to be fixed in newer version. What is the correct result? Lo 4.3.6 and 4.5 give different results..
Comment 2 Spencer Graves 2015-01-20 02:01:08 UTC
1.  How can I find the Java version being used?  

2.  The correct answer for A1=1, A2=2, A3=(A1-A2)^2 Solver minimize A3 by varying A1 is approximately 2, e.g., 1.9999999876 (2 to within something like 1e-8).  Thanks.
Comment 3 raal 2015-01-20 07:01:42 UTC
(In reply to Spencer Graves from comment #2)
> 1.  How can I find the Java version being used?  
> 

in Menu Tools-options-LibreOffice-Advanced
Comment 4 Spencer Graves 2015-01-21 05:47:58 UTC
Tools -> Solver generates "LibreOffice quit unexpectedly" under LO 4.3.5.1 with both Java Oracle 1.8.0_25 and Apple 1.6.0_65.  Thanks for your work on this (and many other issues that have helped make LO such a great software package.  Spencer Graves
Comment 5 raal 2015-01-21 19:49:07 UTC
I can not confirm crash with Version: 4.5.0.0.alpha0+
Build ID: 88562ee6e352b5446bb55e906e8f1c2f34035a49
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-01-16_23:58:11
Oracle Java 1.8.0_31

I can not confirm crash with  Version: 4.3.6.0.0+
Build ID: 1b9bcc2e7f31e880e71c8d2a2aaf1b2839d4d32a
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-3, Time: 2014-12-14_15:56:02
Oracle Java 1.8.0_31
Comment 6 Spencer Graves 2015-01-21 20:23:33 UTC
(In reply to Spencer Graves from comment #4)
> Tools -> Solver generates "LibreOffice quit unexpectedly" under LO 4.3.5.1
> with both Java Oracle 1.8.0_25 and Apple 1.6.0_65.  Thanks for your work on
> this (and many other issues that have helped make LO such a great software
> package.  Spencer Graves

oops: That was 4.3.5.2 not 4.3.5.1.  Solver works as expected in LO 4.3.4.1 under Windows 7 with NO version of Java indicated  Thanks again, Spencer
Comment 7 Spencer Graves 2015-01-22 22:24:04 UTC
(In reply to raal from comment #5)
> I can not confirm crash with Version: 4.5.0.0.alpha0+
> Build ID: 88562ee6e352b5446bb55e906e8f1c2f34035a49
> TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time:
> 2015-01-16_23:58:11
> Oracle Java 1.8.0_31
> 
> I can not confirm crash with  Version: 4.3.6.0.0+
> Build ID: 1b9bcc2e7f31e880e71c8d2a2aaf1b2839d4d32a
> TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-3, Time:
> 2014-12-14_15:56:02
> Oracle Java 1.8.0_31

I just got "LibreOffice quit unexpectedly" from Tools -> Solver in Calc in LO 4.3.6.1 build 9629686a67dd1f357477c13325e45a66f3452bb9 with both Java Oracle 1.8.0_25 and Apple 1.6.0_65 under OS X 10.10.1.  Next:  Try 4.5.  Thanks for your support.  Spencer Graves
Comment 8 Spencer Graves 2015-01-23 00:04:03 UTC
(In reply to Spencer Graves from comment #7)
> (In reply to raal from comment #5)
> > I can not confirm crash with Version: 4.5.0.0.alpha0+
> > Build ID: 88562ee6e352b5446bb55e906e8f1c2f34035a49
> > TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time:
> > 2015-01-16_23:58:11
> > Oracle Java 1.8.0_31
> > 
> > I can not confirm crash with  Version: 4.3.6.0.0+
> > Build ID: 1b9bcc2e7f31e880e71c8d2a2aaf1b2839d4d32a
> > TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-3, Time:
> > 2014-12-14_15:56:02
> > Oracle Java 1.8.0_31
> 
> I just got "LibreOffice quit unexpectedly" from Tools -> Solver in Calc in
> LO 4.3.6.1 build 9629686a67dd1f357477c13325e45a66f3452bb9 with both Java
> Oracle 1.8.0_25 and Apple 1.6.0_65 under OS X 10.10.1.  Next:  Try 4.5. 
> Thanks for your support.  Spencer Graves

I just got "LibreOffice quite unexpectedly" from Tools -> Solver in Calc in LO 4.4.0.1 with both Java Oracle 1.8.0_25 and Apple 1.6.0_65 under OS X 10.10.1 on a MacBook Pro with 2.8 GHz Intel Core i7 with 16 GB 1600 MHz DDR3.  I could not find 4.5.0.0.alpha0+.  

*** What next?  I have LO 4.3.4.1 where Calc Tools Solver minimizes a quadratic on Windows 7 without Java.  I can try to install 4.3.4.1 on the other Windows 7 machine I have to see if I can replicate this there.  Spencer
Comment 9 raal 2015-01-23 06:38:05 UTC
Hello,

(In reply to Spencer Graves from comment #8)
> (In reply to Spencer Graves from comment #7)
> > (In reply to raal from comment #5)
> 
> I just got "LibreOffice quite unexpectedly" from Tools -> Solver in Calc in
> LO 4.4.0.1 with both Java Oracle 1.8.0_25 and Apple 1.6.0_65 under OS X
> 10.10.1 on a MacBook Pro with 2.8 GHz Intel Core i7 with 16 GB 1600 MHz
> DDR3. 

setting whiteboard: NeedsMacOSX, leaving hardware: All- maybe java issue..

> I could not find 4.5.0.0.alpha0+. 

dev builds are here:   http://dev-builds.libreoffice.org/daily/
directory master is 4.5.x

> 
> *** What next?  I have LO 4.3.4.1 where Calc Tools Solver minimizes a
> quadratic on Windows 7 without Java.  I can try to install 4.3.4.1 on the
> other Windows 7 machine I have to see if I can replicate this there.  Spencer

Works for me on LO 4.3.5, win7 (java 1.7.0_17).

Maybe try latest java: https://www.java.com/en/download/manual.jsp
Comment 10 Owen Genat (retired) 2015-01-24 23:32:49 UTC
Bug 80860 was reported for Windows only, but is now specified as multi-platform. Alex has provided testing in the related bug report and pointed out the duplication in this mailing list thread:

http://nabble.documentfoundation.org/Solver-kills-LiberOffice-under-Mac-OS-X-10-td4136388.html

*** This bug has been marked as a duplicate of bug 80860 ***
Comment 11 Owen Genat (retired) 2015-01-24 23:34:25 UTC
Sorry, I transposed some numbers. Corrected.

*** This bug has been marked as a duplicate of bug 80680 ***