Bug 88546 - "clear formatting" does not clear formatting
Summary: "clear formatting" does not clear formatting
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-17 22:19 UTC by Andrew Grillet
Modified: 2015-10-09 20:50 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Grillet 2015-01-17 22:19:44 UTC
Clear formatting in the style toolbar does not remove formatting.

I created a document in docx format using Phoenix office, whihc had various headings styled in various ways.

I attempted to change the formatting by selecting various paragraphs and selecting styles such as "Titie", "Heading 1" etc. The results were bizarre and inconsistent.

Instead, I selected the entire document with ctrl-A, and then selected "clar formatting". The formatting changed again, but not to anything useful and I was unable to format my headings  - typically, the wrong font was selected, or the wrong size of wrong colour - often all three.

I have also had this problem repeatedly when pasting text from web sites.

This is almost certainly what was being described in 47208, 70759, 70860 and 83294. As implemented at presuent, LO is not in fact useable. This should be treated as mission critical, not "RESOLVED - NOTABUG" Clear formatting needs to REMOVE ALL FORMATTING.
Comment 1 Robinson Tryon (qubit) 2015-01-17 23:34:58 UTC
(In reply to Andrew Grillet from comment #0)
> Clear formatting in the style toolbar does not remove formatting.
> 
> I created a document in docx format using Phoenix office, whihc had various
> headings styled in various ways.

Not sure I've ever used Phoenix Office before. Got a link to the project page?

> 
> I attempted to change the formatting by selecting various paragraphs and
> selecting styles such as "Titie", "Heading 1" etc. The results were bizarre
> and inconsistent.

Hi Andrew,
Please attach example file showing this problem (along with repro steps to duplicate the styling that resulted in bizarre/inconsistent results).

Status -> NEEDINFO

(Please change status back to UNCONFIRMED after you provide the info. Thanks!)
Comment 2 m.a.riosv 2015-01-18 03:12:04 UTC
By the way, verify that there are not Character styles applied, they are not clear for the clear formatting option.
Comment 3 QA Administrators 2015-07-18 17:36:20 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

This NEEDINFO message was generated on: 2015-07-18
Comment 4 Andrew Grillet 2015-07-19 07:45:29 UTC
This bug is a very unfortunate case of "working as designed".

LO Writer "clear formatting" does not clear "character formatting" but, for a not technical person (eg office typist) this is a distinction too complex to grasp, particularly given that it may take 30 minutes of Googling to find the explanation for why "clear formatting" does not appear to clear formatting. 

It would appear that Phoenix Office (and Android App) uses character formatting where you would expect a style to be applied, thus making discovery of the problem a task requiring significant forensic software skills. (I have encountered the problem before in documents imported from other tools).

LO Writer is supposed to be an office tool, and not a wierd programmer's test of skills. It is simply not acceptable that a relatively unskilled person should be faced with "Clear formatting" not clearing formatting under indecipherably obscure circumstances, and for no useful purpose. This is sort of design decision is a major obstacle to widespread acceptance.