Bug Hunting Session
Bug 88580 - Find bar message display delayed
Summary: Find bar message display delayed
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.5.1 rc
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2015-01-19 11:48 UTC by Matthew Francis
Modified: 2016-09-05 09:55 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Video capture (290.22 KB, video/mp4)
2015-01-19 15:37 UTC, Matthew Francis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Francis 2015-01-19 11:48:27 UTC
This seems like a problem specific to OSX - I can't reproduce on Linux. It occurs in 4.3.5.1 and 4.4.0.2 but not 4.3.0.4(* however, see below)

Steps to reproduce
1. In a blank Writer document, type "asdasdasd"
2. Move the cursor back to the start of the line
3. Cmd+F to open the find bar
4. Search for "asd"
5. Use the find bar buttons to move to the next match until the search wraps to the beginning of the line

Expected result:
- "Reached the end of the document" appears immediately

Actual result:
- "Reached the end of the document" appears only after the mouse moves off the button


(If Cmd+G with the find bar focused is used to advance the search instead, the wrap message never appears until the mouse is moved over the find bar. This does also occur with 4.3.0.4)
Comment 1 Alex Thurgood 2015-01-19 14:03:39 UTC
Confirming on OSX 10.10.1 with LO 4.3.5.2

I do see a notification at the bottom left hand corner of the Writer window indicating that the end of the document has been reached, but it is overlaid on top of the other UI elements.
Comment 2 Alex Thurgood 2015-01-19 14:10:48 UTC
Sorry, Matthew, actually, re-reading your description, I get the End of document reached message immediately with no lag, so I can't confirm.
Comment 3 Matthew Francis 2015-01-19 15:37:19 UTC
Created attachment 112480 [details]
Video capture

Demosntrates the issue twice using the find bar button and once with the keyboard
Comment 4 Joe P. 2015-02-14 01:42:42 UTC
So I just tried this and I'll add two additional observations that might be relevant. 

1. Following Matthew's steps but using the 'Find Next' button as opposed to the 'Next Element' button the 'Reached the end of the document' message appears for me as expected.

2. If I cycle through the three sub strings just pressing 'Return' the  'Reached the end of the document' never shows up. The search just wraps.
Comment 5 Massimiliano 2015-05-02 18:01:50 UTC
Works fine form me in 4.4.4.0.0+ version
Comment 6 Alex Thurgood 2015-07-12 08:41:16 UTC
@Matthew : do you still see this in latest master or release builds ?
Comment 7 Alex Thurgood 2016-09-05 09:55:37 UTC
From comment 5, and no response from Matthew, setting to WFM