Bug Hunting Session
Bug 88608 - Find bar doesn't reset message area when search box is cleared
Summary: Find bar doesn't reset message area when search box is cleared
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: All All
: medium normal
Assignee: Jorendc
URL:
Whiteboard: target:5.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-20 03:38 UTC by David H. Gutteridge
Modified: 2015-05-10 19:49 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David H. Gutteridge 2015-01-20 03:38:40 UTC
Since the find/replace functionality was changed to remove modal dialog boxes for informational responses and replace them with a message area in the find bar, it doesn't keep consistent state between that message area and the input box. If a user changes the input box in any way (clears it or enters a different term), the message box should reset itself to match state. It doesn't.

Steps to reproduce:

1. Enter a search term you know isn't in the document.
2. Note the find bar says "Search key not found" in the new message area.
3. Clear the search box and enter a new term.
4. Imagine you were distracted for a moment and forgot what you were doing.
5. Look back and see you've entered a new term where it says "Search key not found". That's not true, because you haven't searched for it yet.

Also, it consistently says "Reached the end of the document" when it wraps, regardless of direction, even when a user is searching backwards and it has reached the start of the document and wrapped to the end. It should really say "Reached the start of the document" then...

(By the way, from my perspective this was an intrusive UI change which left me wondering if search was broken, because previously I'd positioned the find bar to the right of another bar, as it had sufficient space to fit all its buttons. When I upgraded to 4.3 I couldn't see the text area that'd been added for messages. After I dragged the bar around I noticed messages were being displayed in it. This change wasn't mentioned in the release notes for 4.3. It should've been.)
Comment 1 Buovjaga 2015-01-29 18:24:16 UTC
Confirmed.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-25_23:07:36
Comment 2 Commit Notification 2015-05-09 20:03:32 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4a0cf72f40e9545d367f48617c2834146d7bec1a

tdf#88608: clear SearchLabel when altering the search string

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2015-05-10 19:49:55 UTC
Joren De Cuyper committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=69b35cb45375c324c1e28fd4547ce874e4894f30

related tdf#88608: find: add string for reaching start of document

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.