Bug Hunting Session
Bug 88610 - Incorrect rendering of some characters in Symbol font
Summary: Incorrect rendering of some characters in Symbol font
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-20 04:59 UTC by vvort
Modified: 2017-03-06 15:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file (9.95 KB, application/vnd.oasis.opendocument.graphics)
2015-01-20 04:59 UTC, vvort
Details
Screenshot (164.96 KB, image/png)
2015-01-20 04:59 UTC, vvort
Details
Screenshot (Windows 10) (87.11 KB, image/png)
2015-01-30 05:07 UTC, vvort
Details
screenshot with russian (102.69 KB, image/png)
2015-02-03 17:36 UTC, Yousuf Philips (jay) (retired)
Details
screenshot of win7 ru (132.75 KB, image/png)
2015-02-03 19:36 UTC, tagezi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vvort 2015-01-20 04:59:11 UTC
Created attachment 112514 [details]
Test file

There several possible ways to encode characters for use with Symbol font:
1. Use 8-bit ASCII codes: U+0020..U+00FE range (λ = U+006C).
2. Use Unicode codes (λ = U+03BB).
3. Use Unicode private range: U+F020..U+F0FE (λ = U+F06C).

All this methods works fine in Ubuntu 14.10 + LibreOffice 4.3.3.2.
But with Windows 7 SP1 + LibreOffice 4.5.0.0 master @ ee21771d, half of Symbol's ASCII range is rendered as empty rectangles.
I think it's a bug.

Attaching test file and it's screenshots.
Comment 1 vvort 2015-01-20 04:59:51 UTC
Created attachment 112515 [details]
Screenshot
Comment 2 vvort 2015-01-20 09:19:49 UTC
Also tested with Ubuntu 14.10 + LibreOffice 4.5.0.0 master @ 07e84cae - works well, same result as with Ubuntu 14.10 + LibreOffice 4.3.3.2
Comment 3 Buovjaga 2015-01-29 18:25:57 UTC
I don't get empty rectangles.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-25_23:07:36
Comment 4 vvort 2015-01-30 05:07:27 UTC
Created attachment 112936 [details]
Screenshot (Windows 10)

Same problem with Windows 10.
Comment 5 Yousuf Philips (jay) (retired) 2015-02-02 19:48:11 UTC
Works fine for me on Windows 7.

Version: 4.5.0.0.alpha0+
Build ID: 802b80fcd378d5788adff1c7c98af526651a30c2
TinderBox: Win-x86@39, Branch:master, Time: 2015-01-25_10:20:28
Comment 6 Yousuf Philips (jay) (retired) 2015-02-02 19:53:17 UTC
What is the difference between the three lines of text, as they all show as if they are formatted as Symbol 26pt, but line 2 has to be something different than the others.
Comment 7 Urmas 2015-02-02 20:14:36 UTC
Looks similar to #88021. Maybe the Russian locale is to blame?
Comment 8 Yousuf Philips (jay) (retired) 2015-02-03 17:36:00 UTC
Created attachment 113098 [details]
screenshot with russian

Changed the UI and locale to russian on Windows 7 and still no luck. Note that changing the locale in Tools > Options doesnt change the locale in the about dialog, so that must be the user's system locale.
Comment 9 tagezi 2015-02-03 19:36:38 UTC
Created attachment 113102 [details]
screenshot of win7 ru

OS: Windows 7 64 bit RU
LibreOffice 4.5+master
Libreoffice 4.3.2

For me this file open with square in first line.
Comment 10 QA Administrators 2016-02-21 08:37:40 UTC Comment hidden (obsolete)
Comment 11 QA Administrators 2017-03-06 15:58:15 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice 
(5.2.5 or 5.3.0  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and 
your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to "inherited from OOo";
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug-20170306