Bug Hunting Session
Bug 88653 - Queries open in background with OpenSUSE 13.2
Summary: Queries open in background with OpenSUSE 13.2
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-21 07:17 UTC by Robert Großkopf
Modified: 2015-06-10 18:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Open the database and the query in OpenSUSE 13.2 - opens in background (3.24 KB, application/vnd.oasis.opendocument.base)
2015-01-21 07:17 UTC, Robert Großkopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2015-01-21 07:17:26 UTC
Created attachment 112585 [details]
Open the database and the query in OpenSUSE 13.2 - opens in background

Don't know if the following is a bug for OpenSUSE 13.2 or a bug for LO.

Open the attached database.
Open the query.
The window for the query will open in the background, if you are using OpenSUSE 12.3/KDE and all LO-Versions since LO 4.1.2.2. 
The buggy behavior doesn't appear in 4.1.1.1 and all versions of LO before. The buggy behavior didn't appear in other OpenSUSE-versions.

Tested with OpenSUSE 13.2/64bit/KDE and different LO-versions.
Comment 1 Alex Thurgood 2015-01-30 13:30:17 UTC
Well at least for my Mac master build the query window opens in foreground
Comment 2 Alex Thurgood 2015-02-01 16:42:38 UTC
Also not reproducible on Linux Mint 17.1

Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale : fr_FR

Specific to OpenSuse then ?
Comment 3 Buovjaga 2015-02-03 07:56:22 UTC
Not reproducible with openSUSE KDE 13.2 64-bit
LibO Version: 4.3.5.2.0+
Build ID: 430m0(Build:2)
Comment 4 Alex Thurgood 2015-02-05 17:40:30 UTC
I can however confirm this with LO 4242 Ubuntu packaged as provided with Linux Mint 17.1

In that particular version of LO, the Query window opens behind the main ODB window.
Comment 5 Robert Großkopf 2015-06-10 18:28:05 UTC
Seems it has been gone with Version: 5.0.0.0.beta3
Build-ID: 96345c15d8ab19c49014f055fe41ba8e1f421e5c

So I set this bug to worksforme.