Bug Hunting Session
Bug 88674 - right-to-left cells revert back to left-to-right cells after save - close - re-open
Summary: right-to-left cells revert back to left-to-right cells after save - close - r...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.3.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-21 20:22 UTC by Yoram
Modified: 2015-01-30 20:47 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yoram 2015-01-21 20:22:13 UTC
When changing all cells in the spreadsheet to be right-to-left, writing Hebrew text, saving, closing and re-opening, all cells are back to be left-to-right.
It confuses the punctuation.
Comment 1 Buovjaga 2015-01-29 18:46:55 UTC
RTL is retained fine here.

Can you test with 4.4 that was just released and report here? Thanks.

Set to NEEDINFO.
Change back to UNCONFIRMED, if the problem persists. Change to RESOLVED WORKSFORME, if the problem went away.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-25_23:07:36
Comment 2 Yoram 2015-01-30 20:47:29 UTC
Just installed 4.4.0.3 and the problem is gone.
Thanks!

(Note that when opening a file created with 4.3 , on a 4.4 , the problem still exists, even when changing cells to RTL and saving. I had to copy-paste the spreadsheet contents into a new file created with 4.4 , and then the problem is gone)