Bug Hunting Session
Bug 88757 - Display of Windows “Styles and Formatting” and “Gallery” is not Possible without Displaying the Sidebar Icons
Summary: Display of Windows “Styles and Formatting” and “Gallery” is not Possible with...
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.2 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-23 17:07 UTC by Harald Koester
Modified: 2015-02-10 12:55 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2015-01-23 17:07:50 UTC
If you display the “Gallery” or the “Styles and Formatting” window, always the icons of the sidebar are displayed too. Especially if you need the full width of your monitor, e.g. with a laptop or if 2 pages or 2 windows of different apps should be displayed, this is disadvantageous. To my opinion this is a regression to former versions. Hence it should be possible to close and/or to hide the bar with the sidebar icons even if the Gallery or the Styles window is displayed.
Comment 1 Cor Nouws 2015-01-23 17:35:20 UTC
Hi Harald,

(In reply to Harald Koester from comment #0)
> If you display the “Gallery” or the “Styles and Formatting” window, always
> the icons of the sidebar are displayed too. Especially if you need the full
> width of your monitor, e.g. with a laptop or if 2 pages or 2 windows of
> different apps should be displayed, this is disadvantageous. 

Styles and Formatting was vertical - anyway for me ;)
But you can make the side bar floating. Does that help?

> ...  To my opinion
> this is a regression to former versions. Hence it should be possible to
> close and/or to hide the bar with the sidebar icons even if the Gallery or
> the Styles window is displayed.

Hmm. has been chosen to be this way by the UX team.
I hope floating side bar is fine enough. Apart from that- future plans for all floating and customising panels are there too...
Cheers - Cor
Comment 2 V Stuart Foote 2015-01-24 21:14:29 UTC
The exposed Sidebar Tab bar with the Sidebar deck open and holding Gallery and Styles and Formatting content panels, or any of the other content panels, is functioning as designed/developed.

The Sidebar Tab bar is intended to remain visible when Sidebar is active. The entire sidebar can be hidden when docked (Hide/Show button mid-way down frame), otherwise the Tab bar is exposed. Sidebar--Tab bar and Deck--can be opened or toggled from the Sidebar or from main toolbar View -> Sidebar

Resolving Invalid...
Comment 3 Theo Hopman 2015-02-10 01:37:19 UTC
I agree that this is a regression. When working with two documents side-by-side
on a 19" monitor, I lose about 10% of of my working area with just the sidebar
icons displayed. With the Styles and Formatting desk shown as well, the text
in my document is no longer readable when I have optimal zoom set. Without the
sidebar, it was small but readable. I can no longer easily apply paragraph
formats and see the full width of the document.
Comment 4 Cor Nouws 2015-02-10 12:55:00 UTC
19" 10%   Oops...