Bug Hunting Session
Bug 88765 - OS X 10.10.1 - current daily builds from @61 4.4.1 and 4.5.0 crashing -- liblnglo or libpyuno
Summary: OS X 10.10.1 - current daily builds from @61 4.4.1 and 4.5.0 crashing -- libl...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium normal
Assignee: Robert Antoni Buj i Gelonch
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-24 00:12 UTC by V Stuart Foote
Modified: 2015-04-03 06:26 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
OS X 10.10.1 problem report of TB61 4.4.1.0 crashing (24.08 KB, application/x-gzip)
2015-01-24 00:19 UTC, V Stuart Foote
Details
OS X 10.10.1 problem report of TB61 4.5.0.0 crashing (19.67 KB, application/x-gzip)
2015-01-24 00:38 UTC, V Stuart Foote
Details

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2015-01-24 00:12:53 UTC
Hey, neophyte working QA with OS X builds TB61 highly builds.

4.4.0.2 and 4.3.6.1 are stable, but builds from TB61 keep crashing.

Looks like maybe, liblnglo.dylib or libpyuno.dylib unfortunately I'm not at all sure about reading these OS X problem reports.

attaching...
Comment 1 V Stuart Foote 2015-01-24 00:19:18 UTC
Created attachment 112754 [details]
OS X 10.10.1 problem report of TB61 4.4.1.0 crashing

gzip of text Problem report
Comment 2 V Stuart Foote 2015-01-24 00:38:21 UTC
Created attachment 112755 [details]
OS X 10.10.1 problem report of TB61 4.5.0.0 crashing

This log for current TB61 build of master, seems the same as the log for 4.4.1

Have crashes of at least Writer and Calc--if starting to type any text on a word break or return then crash.

Looking at problem log, maybe looks to be calls to liblnglo LngSvcMgr-- so a Grammar check or spell check issue?
Comment 3 retired 2015-01-24 22:00:59 UTC
Hi Stuart, @49 builds do work.
@61 builds have never worked for me. Thanks for filing the bug. Instantly crashes when opening writer from startscreen.

Confirming thus NEW
Comment 4 Robert Antoni Buj i Gelonch 2015-01-25 13:43:26 UTC
MASTER

sudo find /Applications/LibreOfficeDev.app/Contents/Frameworks/LibreOfficePython.framework/Versions/3.3/lib/python3.3/lib-dynload -name "*.so" -exec install_name_tool -change /Volumes/Master/lo/core/workdir/UnpackedTarball/python3/python-inst/@__________________________________________________OOO/LibreOfficePython.framework/Versions/3.3/LibreOfficePython @loader_path/../../../LibreOfficePython '{}' \;

LO-4.4

sudo find /Applications/LibreOfficeDev.app/Contents/Frameworks/LibreOfficePython.framework/Versions/3.3/lib/python3.3/lib-dynload -name "*.so" -exec install_name_tool -change /Volumes/Fresh/lo/core/workdir/UnpackedTarball/python3/python-inst/@__________________________________________________OOO/LibreOfficePython.framework/Versions/3.3/LibreOfficePython @loader_path/../../../LibreOfficePython '{}' \;
Comment 5 V Stuart Foote 2015-01-25 16:51:06 UTC
Robert, *,

Thanks, but do you need us to test that workaround patch on our existing TB61 installs? Or is it just fyi, and the TB61 builds for Master and 4.4 will be patched on future installs?

Stuart
Comment 6 Robert Antoni Buj i Gelonch 2015-01-25 17:55:55 UTC
I sent a path in gerrit.

https://gerrit.libreoffice.org/#/c/12200/
Comment 7 V Stuart Foote 2015-01-25 18:33:09 UTC
Robert,
(In reply to Robert Antoni Buj i Gelonch from comment #6)
> I sent a path in gerrit.
> 
> https://gerrit.libreoffice.org/#/c/12200/

Hmm, don't see it as having made it in

http://opengrok.libreoffice.org/xref/core/external/python3/ExternalProject_python3.mk
Comment 8 Alex Thurgood 2015-01-31 14:17:38 UTC
I don't understand why this bug shows up as unconfirmed for me.

Also, if a patch has been submitted, shouldn't there be a commit message in the bug report automatically ?
Comment 9 V Stuart Foote 2015-01-31 15:26:25 UTC
(In reply to Alex Thurgood from comment #8)
> I don't understand why this bug shows up as unconfirmed for me.
> 
Bug history shows it as having been set NEW on 2014-01-24

> Also, if a patch has been submitted, shouldn't there be a commit message in
> the bug report automatically ?
>
Robert's missing commit to ExternalProject_python3.mk predates this issue by 3 months (2014-11-02) so THAT would be unreasonable...
Comment 10 V Stuart Foote 2015-01-31 15:37:12 UTC
s/NEW on 2014-01-24/NEW on 2015-01-24/
Comment 11 Robert Antoni Buj i Gelonch 2015-02-01 18:22:43 UTC
Christian Lohmaier reported to me about it on Fri, Oct 31, 2014 at 11:16 AM.
http://lists.freedesktop.org/archives/libreoffice/2014-November/064316.html
Comment 12 Stephan Bergmann 2015-02-02 22:16:35 UTC
<https://gerrit.libreoffice.org/#/c/12200/> pushed to master now as <http://cgit.freedesktop.org/libreoffice/core/commit/?id=40432ac6caa478474d73786f95b808c14e106ff2> "pyhon: add lib-dynload libs to fixinstallnames (OS X)."

What is odd is that the Contents/Frameworks/LibreOfficePython.framework/Versions/3.3/lib/python3.3/lib-dynload/*.so reference the LibreOfficePython library (and thus caused the failure) only in some builds (like <http://dev-builds.libreoffice.org/daily/master/MacOSX-10.10@61/2015-02-02_01.15.45/master~2015-02-02_01.15.45_LibreOfficeDev_4.5.0.0.alpha0_MacOS_x86-64.dmg>) but not in others (like <http://donate.libreoffice.org/home/dl/mac-x86_64/4.4.0/en-US/LibreOffice_4.4.0_MacOS_x86-64.dmg>).
Comment 13 retired 2015-02-03 09:22:49 UTC
Thanks for fixing this! @61 has been broken for months, no longer. That's great news.

A small annoyance remains with this build: When closing I'm being asked to install java since otherwise "this webcontent cannot be displayed". This does not happen when opening the same document with a nightly build from @49.

Should I open another bug for that?
Comment 14 Stephan Bergmann 2015-02-03 09:52:28 UTC
(In reply to foss from comment #13)
> A small annoyance remains with this build: When closing I'm being asked to
> install java since otherwise "this webcontent cannot be displayed". This
> does not happen when opening the same document with a nightly build from @49.

Might be related to what bundled extensions are enabled in the different builds.  But best file a separate issue for it (and report here its ID).
Comment 15 Adolfo Jayme 2015-04-03 06:26:17 UTC
Removing “Blocks 42082”. See bug 42082 comment 14 for why.