Bug Hunting Session
Bug 100013 - Solaris build: gtar: You may not specify more than one '-Acdtrux', '--delete' or '--test-label' option
Summary: Solaris build: gtar: You may not specify more than one '-Acdtrux', '--delete'...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All Solaris
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.0.0
Keywords: notBibisectable, regression
Depends on:
Blocks:
 
Reported: 2016-05-23 15:37 UTC by Richard PALO
Modified: 2017-09-29 15:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard PALO 2016-05-23 15:37:59 UTC
Noticed the following during a build in progress (pkgsrc libreoffice SunOS i386):
[build PRL] CustomTarget/sysui/share/libreoffice/build.flag
[build PRL] CustomTarget/sysui/share/libreoffice/openoffice.org.xml
[build PRL] CustomTarget/sysui/share/libreoffice/openoffice.keys
[build PRL] CustomTarget/sysui/share/libreoffice/mimelnklist
[build PRL] CustomTarget/sysui/share/libreofficedev/build.flag
[build PRL] CustomTarget/sysui/share/libreofficedev/openoffice.org.xml
[build PRL] CustomTarget/sysui/share/libreofficedev/openoffice.keys
[build PRL] CustomTarget/sysui/share/libreofficedev/mimelnklist
[build CUS] tools/string
gtar: You may not specify more than one '-Acdtrux', '--delete' or  '--test-label' option
Try 'gtar --help' or 'gtar --usage' for more information.
[build CXX] unoidl/source/unoidl-read.cxx
[build DEP] LNK:Library/libunoidllo.so
Comment 1 Michael Stahl (CIB) 2016-05-26 12:46:50 UTC
there is a GNUTAR invocation in sysui/CustomTarget_solaris.mk - perhaps that is causing the trouble, some wrong variable expansion there?
Comment 2 Michael Stahl (CIB) 2016-05-26 12:53:36 UTC
ah that broke in the gbuild conversion, see commit 01344a8ca57636ac87108c22f777a02fe6d963d5
file sysui/desktop/solaris/makefile.mk
had this line

@$(GNUTAR) -cf - -C $(PKGDIR) $(@:b:b:s/-/ /:1:s/.//)$(PRODUCTVERSIONSHORT)-desktop-int | gzip > $@
Comment 3 Richard PALO 2016-05-26 13:01:44 UTC
Hmm, I have no idea what this is supposed to be now...

but what it is now certainly looks odd:
$(GNUTAR) -cf - -C $(solaris_WORKDIR) $*$(LIBO_MAJOR) -desktop-int | gzip > $@
Comment 4 Richard PALO 2016-05-30 09:37:58 UTC
Tried the following after looking in the target directory...

--- sysui/CustomTarget_solaris.mk.orig	2016-05-03 22:51:19.000000000 +0000
+++ sysui/CustomTarget_solaris.mk
@@ -50,6 +50,6 @@ $(solaris_WORKDIR)/%/prototype: $(solari
 
 $(solaris_WORKDIR)/%-desktop-integration.tar.gz: $(solaris_WORKDIR)/%/copyright $(solaris_WORKDIR)/%/pkginfo $(solaris_WORKDIR)/%/depend $(solaris_WORKDIR)/%/mailcap $(solaris_WORKDIR)/%/postinstall $(solaris_WORKDIR)/%/postremove $(solaris_WORKDIR)/%/prototype $(call gb_CustomTarget_get_workdir,sysui/share)/%/openoffice.org.xml
 #	pkgmk -l 1073741824 -r $(solaris_WORKDIR) -f $(solaris_WORKDIR)/$*/prototype -o -d $(solaris_WORKDIR) ARCH=all VERSION=$(PKGVERSION.$*)
-	$(GNUTAR) -cf - -C $(solaris_WORKDIR) $*$(LIBO_MAJOR) -desktop-int | gzip > $@
+	$(GNUTAR) -cf - -C $(solaris_WORKDIR) $* | gzip > $@
 
 # vim: set noet sw=4 ts=4:

gives me:
richard@omnis:/tmp/pkgsrc/misc/libreoffice/work/libreoffice-5.1.3.2/workdir/CustomTarget/sysui/solaris$ for f in ./*.tar.gz; do echo $f;gtar tvfa $f; done
./libreoffice-desktop-integration.tar.gz
drwxr-xr-x richard/staff     0 2016-05-30 09:45 libreoffice/
-rw-r--r-- richard/staff   389 2016-05-30 09:45 libreoffice/pkginfo
-rw-r--r-- richard/staff   231 2016-05-30 09:45 libreoffice/depend
-rw-r--r-- richard/staff  4925 2016-05-30 09:45 libreoffice/mailcap
-rw-r--r-- richard/staff   106 2016-05-30 09:45 libreoffice/copyright
-rw-r--r-- richard/staff  1299 2016-05-30 09:45 libreoffice/postinstall
-rw-r--r-- richard/staff  1109 2016-05-30 09:45 libreoffice/postremove
-rw-r--r-- richard/staff  5456 2016-05-30 09:45 libreoffice/prototype
./libreofficedev-desktop-integration.tar.gz
drwxr-xr-x richard/staff     0 2016-05-30 09:45 libreofficedev/
-rw-r--r-- richard/staff   359 2016-05-30 09:45 libreofficedev/pkginfo
-rw-r--r-- richard/staff   231 2016-05-30 09:45 libreofficedev/depend
-rw-r--r-- richard/staff  5102 2016-05-30 09:45 libreofficedev/mailcap
-rw-r--r-- richard/staff   106 2016-05-30 09:45 libreofficedev/copyright
-rw-r--r-- richard/staff  1109 2016-05-30 09:45 libreofficedev/postremove
-rw-r--r-- richard/staff  1299 2016-05-30 09:45 libreofficedev/postinstall
-rw-r--r-- richard/staff  5615 2016-05-30 09:45 libreofficedev/prototype
Comment 5 Richard PALO 2016-05-30 10:21:29 UTC
So looking at bit at the contents of this, I'm not so sure it is worth keeping
around as it is probably of limited use given the evolution since S10 of the SunOS 
platform.

For example, on SunOS 5.11(illumos), the 'depend' file is meaningless:
P SUNWcar Core Architecture, (Root)
P SUNWkvm Core Architecture, (Kvm)
P SUNWcsr Core Solaris, (Root)
P SUNWcsu Core Solaris, (Usr)
P SUNWcsd Core Solaris Devices
P SUNWcsl Core Solaris, (Shared Libs)
P SUNWloc System Localization

>$ pkg list -af SUNWcar SUNWkvm SUNWcsr SUNWcsd SUNCcsl SUNWloc | sort -u
> 
>pkg list: aucun package correspondant à 'SUNWcsr, SUNCcsl n'existe
>NAME (PUBLISHER)                                  VERSION                    IFO
>SUNWcar                                           0.5.11-0.133               --r
>SUNWcsd                                           0.5.11-0.151019            i--
>SUNWkvm                                           0.5.11-0.133               --r
>SUNWloc                                           0.5.11-0.133               --r

distributions can package as need be, for example I'm using pkgsrc which packages
without using the either of the legacy SunOS package manager.
Comment 6 Xisco Faulí 2016-09-12 12:22:16 UTC
Adding keyword 'bibisectRequest'.
Comment 7 Michael Stahl (CIB) 2016-09-12 12:47:25 UTC
removing "bibisectRequest", unlikely to help for a Solaris build issue :)
Comment 8 Xisco Faulí 2016-09-12 21:17:44 UTC
Then adding keyword 'notBibisectable'. Sorry for the noise...
Comment 9 Xisco Faulí 2017-09-29 08:51:36 UTC Comment hidden (obsolete, spam)
Comment 10 Commit Notification 2017-09-29 15:01:56 UTC
Richard PALO committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ba65817fb927b1b2db8872fc981fd878219ab968

tdf#100013 sysui: fix invalid tar invocation

It will be available in 6.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Michael Stahl (CIB) 2017-09-29 15:02:59 UTC
okay i've pushed the patch from comment #4 now, mainly so that bugzilla stops sending me mails about this :)