Bug 100039 - while editing calc crashes, repeatedly.
Summary: while editing calc crashes, repeatedly.
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.6.2 rc
Hardware: x86 (IA32) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: profile
Keywords:
Depends on:
Blocks: User-Profile
  Show dependency treegraph
 
Reported: 2016-05-25 02:17 UTC by Will MacGhee
Modified: 2017-06-25 23:00 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
is the registrymodications.xcu file from my crashy Libreoffice install (1.05 MB, text/plain)
2016-05-28 22:01 UTC, Will MacGhee
Details
backtraces (2.80 KB, text/plain)
2016-08-04 00:41 UTC, Will MacGhee
Details
another backtrace (2.93 KB, text/plain)
2016-08-04 00:41 UTC, Will MacGhee
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Will MacGhee 2016-05-25 02:17:22 UTC
I am running Windows 10.
Version 5.0.6.3 (x64)

I normally have the spreadsheet saving to a Dropbox directory, but even without that, the program is still crashing. 

The text on the screen corrupts, and Windows closes it.

Upon reopening, it cycles through a recovery process, pretty much reverting to the saved copy. 

I had a problem like this before, but had changed to the Still distribution, from Fresh and that worked... for a while.

I noticed that I was running the 32bit version, and changed to 64bit, no diff.

I have seven tabs of checkbook info on this spread sheet. They refer to each other for calculations.
Comment 1 m.a.riosv 2016-05-25 11:52:01 UTC
Please try resetting the user profile, sometimes solves strange issues.
https://wiki.documentfoundation.org/UserProfile
Usually it's enough renaming/deleting the file "user/registrymodifications.xcu",  it affects all the options in Menu/Tools/Options, and the files "user/basic/dialog.xlc" and "scrip.xlc" are overwritten, additionally custom colors in "user/config/standard.soc" are lost.
Comment 2 Will MacGhee 2016-05-26 02:47:36 UTC
I did what was suggested in Comment 1, and it seems to have worked.
Comment 3 m.a.riosv 2016-05-26 12:21:40 UTC
Thanks Will, please if there are not private information, attach the "registrymodifications.xcu" file, they are collected to look why profiles sometimes fail.
Comment 4 Will MacGhee 2016-05-28 22:01:19 UTC
Created attachment 125361 [details]
is the registrymodications.xcu file from my crashy Libreoffice install

Here is my "registrymodifications.xcu" file. I had renamed it "registrymodifications_xcu-old" to take it out of service. Interestingly, it has not been regenerated in that directory yet.
Comment 5 Will MacGhee 2016-05-29 02:12:08 UTC
It's still crashing a bunch though. Possibly associated with pasting unforamatted text into a field..
Comment 6 m.a.riosv 2016-05-29 10:21:35 UTC
Then maybe it's an issue with the openGL but it is an option just in the View configuration.

Perhaps first testing renaming the whole profile.

If it doesn't work, could you test with a portable version, it can be installed anywhere, there are available for download:
http://downloadarchive.documentfoundation.org/libreoffice/old/?C=M;O=D

Reopened to needinfo.
Comment 7 Will MacGhee 2016-05-30 21:14:11 UTC
Have been testing with Portable Version. It appears to be working well.
Comment 8 Will MacGhee 2016-08-02 22:50:30 UTC
A new update came out to Libreoffice, at first I thought it fixed the issue, and then alas I realized no.

But I messed around a bit.

I find that Calc crashes for me on every third save. This is if I use Save As, or Save.

Also this crashing persists using local directories that are not part of Dropbox (my usual storage spot).

But: if I don't save in the ods format, but save in the MS xls format: it doesn't crash.

Also, another note, this crashing in ods format, doesn't happen when I open the sheet from my Ubuntu machines.

Will MacGhee
Comment 9 m.a.riosv 2016-08-02 23:15:27 UTC
As I'm not able to reproduce change to Unconfirmed so someone else test.
Comment 10 Joel Madero 2016-08-03 05:20:06 UTC
Did you test with openGL off?

A backtrace would be useful - you'll have to install symbols and follow these instructions: https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
Comment 11 Will MacGhee 2016-08-04 00:41:17 UTC
Created attachment 126560 [details]
backtraces
Comment 12 Will MacGhee 2016-08-04 00:41:58 UTC
Created attachment 126561 [details]
another backtrace
Comment 13 Buovjaga 2016-08-07 15:03:45 UTC
Unfortunately the backtrace analysis seems to have failed for some reason.

Will: would you like to test with version 5.2? It fixes a lot of weird crashes.
Comment 14 Will MacGhee 2016-08-08 12:44:23 UTC
Unfortunately, I am away and won't be able to diagnose this deal until about 8/14/16. 

Will MacGhee