Bug 100079 - FILEOPEN of .docx file drive CPU usage, almost freezes Writer
Summary: FILEOPEN of .docx file drive CPU usage, almost freezes Writer
Status: RESOLVED DUPLICATE of bug 60425
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: TooBusyNowNeedsFurtherTestingForPossi...
Keywords: perf
Depends on:
Blocks:
 
Reported: 2016-05-27 03:31 UTC by konsultor
Modified: 2016-05-28 03:26 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
.docx file that pushes CPU usage, nearly kills Writer (5.03 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-05-27 03:31 UTC, konsultor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description konsultor 2016-05-27 03:31:36 UTC
Created attachment 125315 [details]
.docx file that pushes CPU usage, nearly kills Writer

The submitted file is from the NSF web site (public).  It is 4 pages of text with some decoration, but the file size is 5 MB.  On opening this file, the initial load takes minutes with CPU usage near 50% (90%+ on one core).  All Writer functions stop until this file finishes displaying.
System Monitor (openSuse 42.1, 64-bit) shows that "X" is the top activity by CPU percentage (24%, or one thread of a dual-core CPU).  soffice.bin takes almost as much, and produces a zombie process when I try to kill LibreOffice.
Tried to delete the decorations (possibly in the header), but the system was so slow that I couldn't.
Managed to save this file as .odt and .doc but upon opening those formats found the same problem.
Comment 1 raal 2016-05-27 04:43:43 UTC
I can confirm with Version: 5.2.0.0.alpha1+
Build ID: fa9416906e615f5f19ad8524176d2ed693662769
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-05-24_00:05:55
File works in word2010.
Comment 2 Aron Budea 2016-05-28 03:26:58 UTC
Reproduced with 5.1.3.2, 4.3.0.4  and 3.6.0.4 in Windows 7.
In 3.3 the document opened quickly, but it seemed like some elements of the document were missing. Like those headers in pages 2-4. The logo is a 27 MB EMF embedded in the doc, which is handled extremely slowly (the header of the 1st page is an embedded png, no problem with that).
So, not a regression.

When I tried inserting the extracted EMF into ane empty document, LibreOffice became unresponsive. This seems to be the same issue as bug 60425, just a lot more severe due to the much larger file size.

*** This bug has been marked as a duplicate of bug 60425 ***