Bug 100103 - Writer hangs when graphics are added
Summary: Writer hangs when graphics are added
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.7.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Images
  Show dependency treegraph
 
Reported: 2016-05-28 10:39 UTC by Dr. Matthias Weisser
Modified: 2017-10-29 16:12 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test file showing crash problem (26.40 KB, application/vnd.oasis.opendocument.text)
2016-05-28 10:39 UTC, Dr. Matthias Weisser
Details
test picture 1 for test file (3.74 MB, image/jpeg)
2016-05-28 10:47 UTC, Dr. Matthias Weisser
Details
test picture 2 for test file (3.67 MB, image/jpeg)
2016-05-28 10:49 UTC, Dr. Matthias Weisser
Details
Screenshot grpahics cache options. (14.42 KB, image/png)
2016-05-28 12:22 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dr. Matthias Weisser 2016-05-28 10:39:32 UTC
Created attachment 125341 [details]
test file showing crash problem

I have a small odt document - 28kB. Its possible editing without problems. When adding pictures with "Einfügen Bild" "Verknüpfen" the picture comes up. I then change picture type to "Als Zeichen" "unten" "Zeichen". I am adding 2 other pictures the same way. The pictures are jpg from a digital camera (Panasonic). The document is saved as 2016_test_lo1.odt.

When opening the file it takes small time to load. The first page is shown. When scrolling to the second page the 2 pictures are shown correctly. When scrolling to the end and then back the pictures are not shown any longer. Instead the system trys loading and shows read error "Lesefehler". Scrolling does not work any longer. The task manager has to be used to kill LO.

The system is Win7 professional. 4GB RAM or more. This happens on an older E8420 notebook and also on a new E554 notebook with 8GB RAM. So it does not seem to be a bad profile problem.
Comment 1 Dr. Matthias Weisser 2016-05-28 10:47:38 UTC
Created attachment 125342 [details]
test picture 1 for test file

first test picture for the above odt file. To be stored in folder 2015_1222_knochenbruch_margit.
Comment 2 Dr. Matthias Weisser 2016-05-28 10:49:50 UTC
Created attachment 125343 [details]
test picture 2 for test file

same as with picture 1.
Comment 3 m.a.riosv 2016-05-28 12:22:42 UTC
Created attachment 125345 [details]
Screenshot grpahics cache options.

Thanks for reporting.

I can't reproduce.
Win10x64
Version: 4.4.7.2
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600

Please try with the options in Menu/Tools/Options, like in the attached screeenshot.

If doesn't work, please try resetting the user profile, sometimes solves strange issues.
https://wiki.documentfoundation.org/UserProfile
Usually it's enough renaming/deleting the file "user/registrymodifications.xcu",  it affects all the options in Menu/Tools/Options, and the files "user/basic/dialog.xlc" and "scrip.xlc" are overwritten, additionally custom colors in "user/config/standard.soc" are lost.
Comment 4 Dr. Matthias Weisser 2016-05-28 13:20:06 UTC
Thank you very much for your response. 

I do not use Win10 but Win7 64bit SP1.

The problem can be reproduced on both Win7 systems that I have.

renaming "registrymodifications.xcu" to "registrymodifications.xcu_weg" did not solve this problem. Just happens again.
Comment 5 m.a.riosv 2016-05-28 13:34:00 UTC
Have you test changing Graphics cache options?, there it¡s a big difference with 48 MB or more.
If it doesn't work, test changing the option for OpenGL:
Menu/Tools/LibreOffice/View - Graphics Output - Use OpenGL (need restart)
Comment 6 Dr. Matthias Weisser 2016-05-28 13:38:07 UTC
this problem does not seem to occur using LO 5.0.6.3.
Comment 7 Dr. Matthias Weisser 2016-05-28 13:39:56 UTC
(In reply to m.a.riosv from comment #5)
> Have you test changing Graphics cache options?, there it¡s a big difference
> with 48 MB or more.

not yet. On one system I installed the newer LO which fixed it. On the other system I can have a look at.
Comment 8 Dr. Matthias Weisser 2016-05-29 21:37:55 UTC
(In reply to m.a.riosv from comment #5)
> Have you test changing Graphics cache options?, there it¡s a big difference
> with 48 MB or more.

it seems to be better this way - but crashed once more.

It does not longer crash when using LO 5.0.6.
Comment 9 QA Administrators 2016-12-07 12:44:25 UTC Comment hidden (obsolete)
Comment 10 Telesto 2016-12-27 15:13:04 UTC
I can't reproduce a crash, but I can confirm a problem with linked images. The keep reloading

Steps to Reproduce:
1. Download attachment 125341 [details], attachment 125342 [details] and attachment 125343 [details]
2. Open the ODT file with Writer. 
3. Scroll to the second page. 
4. Right click on the first empty image frame. 
5. Select properties 
6. Go to tab 'Images'
7. Add P1020366.JPG (downloaded in step 1)
8. Click OK
9. Right click on the second empty image frame. 
10. Select properties 
11. Go to tab 'Images'
12. Add P1020373.JPG (downloaded in step 1)
13. Click OK
14. Save a copy of the file
15. Reopen the file
16. Scroll down and up. Images will disappear.
Comment 11 Telesto 2017-10-29 11:49:51 UTC
I can't reproduce it (anymore)
Version: 6.0.0.0.alpha1+
Build ID: b17294826830e278d060c876cf4f94a9b4ec16cc
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-10-23_06:32:42
Locale: nl-NL (nl_NL); Calc: CL
Comment 12 Dr. Matthias Weisser 2017-10-29 16:00:58 UTC
(In reply to Telesto from comment #11)
> I can't reproduce it (anymore)
> Version: 6.0.0.0.alpha1+

thank you very much for checking. I have not seen this problem in the newer versions 5.0.6.3 and 5.2.6.2. But I reduced picture size as much as I can in my books. So this is now not so easy to see for me as it was before.
Comment 13 Telesto 2017-10-29 16:12:00 UTC
Lets close it as WFM for now. It always possible to set it back to NEW, if the problem occurs again.