Bug 100104 - Crash when using attached template, if both OpenCL options are enabled
Summary: Crash when using attached template, if both OpenCL options are enabled
Status: CLOSED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.2.0.0.alpha0+
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Tomaz Vajngerl
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: OpenCL
  Show dependency treegraph
 
Reported: 2016-05-28 12:09 UTC by Regina Henschel
Modified: 2016-07-14 13:33 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Crashing template (33.00 KB, application/vnd.oasis.opendocument.spreadsheet-template)
2016-05-28 12:09 UTC, Regina Henschel
Details
Backtrace as suggested (11.94 KB, text/plain)
2016-05-28 17:54 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2016-05-28 12:09:58 UTC
Created attachment 125344 [details]
Crashing template

Creating a document with the attached template or using a document based on that template crashes Calc. This is a recently introduced regression. 

With the versions I have got, I see the crash first in Version: 5.2.0.0.alpha1+
Build ID: 51e953a3579fb91f30f7f0d6159b737684976959
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-04-30_03:08:13
Locale: de-DE (de_DE)

The last version without crash, which I have got, is Version: 5.2.0.0.alpha0+
Build ID: ac488ccba124fc2539f765d354a0b97c9b843f51
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-03-22_04:19:21
Locale: de-DE (de_DE)
Comment 1 m.a.riosv 2016-05-28 12:38:25 UTC
I can't reproduce.
Win10x64
Version: 5.2.0.0.alpha1+
Build ID: 7b704dfbdb23540ff6366fa60c73474bbda9dc26
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-05-20_05:45:40

With OpenGL enable and disable.
Comment 2 Regina Henschel 2016-05-28 12:59:35 UTC
I'm on Windows 7, 32 bit.
Comment 3 Regina Henschel 2016-05-28 14:26:11 UTC
Goto Tools > Options > LibreOffice > OpenCL. Find the options
(1) Allow use of Software Interpreter (even when OpenCL is not available)
(2) Allow use of OpenCL.

If both options are checked, then it crashes.
If only one or no option is checked, it does not crash.

The default is, that both options are checked.
Comment 4 m.a.riosv 2016-05-28 15:39:41 UTC
I can't reproduce in any case, with both, one or none.

Maybe a not blacklisted OpenCL

There are two log files on the cache folder with information about the devices.
Opencl_devices.log
Opencl_device.log
Comment 5 Regina Henschel 2016-05-28 16:14:47 UTC
For my PC the file content is:

opencl_devices.log
------------------
Device Index: 0
  Selected: false
  Device Name: AMD Phenom(tm) II X4 940 Processor
  Device Vendor: AuthenticAMD
  Device Version: OpenCL 1.2 AMD-APP (937.2)
  Driver Version: 2.0 (sse2)
  Device Type: cpu 
  Device Extensions: cl_khr_fp64 cl_amd_fp64 cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_byte_addressable_store cl_khr_gl_sharing cl_ext_device_fission cl_amd_device_attribute_query cl_amd_vec3 cl_amd_printf cl_amd_media_ops cl_amd_popcnt cl_khr_d3d10_sharing 
  Device OpenCL C Version: OpenCL C 1.2 
  Device Available: true
  Device Compiler Available: true
  Device Linker Available: false
  Platform Name: AMD Accelerated Parallel Processing
  Platform Vendor: Advanced Micro Devices, Inc.
  Platform Version: OpenCL 1.2 AMD-APP (937.2)
  Platform Profile: FULL_PROFILE
  Platform Extensions: cl_khr_icd cl_amd_event_callback cl_amd_offline_devices cl_khr_d3d10_sharing

opengl_device.log
-----------------
DriverVersion: 8.970.100.7000
DriverDate: 11-16-2012
DeviceID: PCI\VEN_1002&DEV_9610&SUBSYS_75011462&REV_00
AdapterVendorID: 0x1002
AdapterDeviceID: 0x9610
AdapterSubsysID: 0x75011462
DeviceKey: System\CurrentControlSet\Control\Video\{331693BC-4FB7-4781-B597-9FB2E140569F}\0000
DeviceString: ATI Radeon HD 3200 Graphics
Comment 6 Buovjaga 2016-05-28 16:32:53 UTC
Maybe a backtrace using a TB39 build would be useful: https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg
Comment 7 Regina Henschel 2016-05-28 17:54:32 UTC
Created attachment 125357 [details]
Backtrace as suggested
Comment 8 m.a.riosv 2016-05-28 21:28:03 UTC
Perhaps a try updating the graphics driver.

http://support.amd.com/en-us/download/desktop/legacy?product=legacy2&os=Windows%20XP%20-%20Professional/Home&RenderOnServer=true

not too much modern, but who knows.

As there is a backtrace and this kink of bug are can't be reproduce without the same hardware, changed the status to new.
Comment 9 raal 2016-05-30 07:25:00 UTC
This seems to have begun at the below commit.
Adding Cc: to Tomaž ; Could you possibly take a look at this one? Thanks

97d366b4fa31a6aab550dbe001a893c4dd0e5bc3 is the first bad commit
commit 97d366b4fa31a6aab550dbe001a893c4dd0e5bc3
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sat Apr 23 11:43:22 2016 -0700

    source sha:334e2dc9c3da4519e31e0452a40d3a958c401876
author	Tomaž Vajngerl <tomaz.vajngerl@collabora.co.uk>	2016-04-20 13:19:47 (GMT)
committer	Tomaž Vajngerl <quikee@gmail.com>	2016-04-22 11:27:05 (GMT)
commit	334e2dc9c3da4519e31e0452a40d3a958c401876 (patch)
tree	bfe420e41e0e9c5e7767c4ce657bd5e29192d91f
parent	cb5438a3d16634eb267584122169758ab2b76930 (diff)
opencl: better logging of devices and device selection
Comment 10 Michael Meeks 2016-05-30 14:13:10 UTC
Tomaz - I guess one to append to your queue.
Comment 11 Regina Henschel 2016-05-31 21:51:22 UTC
I have uninstalled the driver, without installing a new one. Now I have got a ATI Technologies Inc. driver version 8.632.1.2000 from 17.08.2009. That seems to be the default driver from Windows 7? With this driver it no longer crashes. So my previous driver seems to be a candidate for the blacklist.
Comment 12 Tomaz Vajngerl 2016-06-08 11:13:02 UTC
Does this still happen after [1]? Can anybody check?

[1] https://cgit.freedesktop.org/libreoffice/core/commit/?id=40b0b9ab7703a165295b008f47df14d2ec076fb1
Comment 13 Tor Lillqvist 2016-06-29 07:19:36 UTC
Do you have any OpenCL support at all with that driver you now are using? (If you remove the opencl_devices.log, does a new one appear? What does it contain?)
Comment 14 Regina Henschel 2016-06-29 13:24:11 UTC
When I remove all files in Cache, on restart a file "opengl_device.log" is generated. It contains:

DriverVersion: 8.632.1.2000
DriverDate: 8-17-2009
DeviceID: PCI\VEN_1002&DEV_9610&SUBSYS_75011462&REV_00
AdapterVendorID: 0x1002
AdapterDeviceID: 0x9610
AdapterSubsysID: 0x75011462
DeviceKey: System\CurrentControlSet\Control\Video\{331693BC-4FB7-4781-B597-9FB2E140569F}\0000
DeviceString: ATI Radeon HD 3200 Graphics

My current version of LO is Version: 5.3.0.0.alpha0+
Build ID: 3ab13873ebb6dc4738be2e2184ee4433a2447c1d
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-06-16_01:48:01
Locale: de-DE (de_DE)
Comment 15 Michael Meeks 2016-07-14 13:11:31 UTC
Hi Regina, thanks for the feedback - we've added code now to test OpenCL by doing some real calculations on first-start and/or driver change - which should avoid this problem by crashing and disabling CL in the first instance.

I guess we will collect stats from the crash-reporter on that over time as we add OCL information to it, but of course testing of that much appreciated vs. a recent build yourself.

Otherwise - I guess closing this as NOTOURBUG is perhaps the best approach ? =)

Thanks !
Comment 16 Regina Henschel 2016-07-14 13:33:19 UTC
Hi Michael, I do not have installed the problematic driver any longer, so I cannot test it. Therefore I agree to close it.