Bug 100136 - "hyphenation active" does not work in Calc for "English (USA)"
Summary: "hyphenation active" does not work in Calc for "English (USA)"
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL: https://help.libreoffice.org/6.4/en-U...
Whiteboard:
Keywords:
Depends on:
Blocks: Hyphenation
  Show dependency treegraph
 
Reported: 2016-05-30 09:24 UTC by tagezi
Modified: 2019-10-26 02:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tagezi 2016-05-30 09:24:34 UTC
OS: Gentoo Linux kernel 4.4.6-gentoo
LO 5.1.2.2.0 build ID: Gentoo official package ru_RU
OS: Ubuntu 12.04
LO 5.0.5 ru_RU

Steps to reproduce:
1. Open Calc
2. Enter some long text into a cell
3. Right-click on the cells and open the "Format cells..." dialog
4. Go to the Alignment tab and check "Wrap text automatically" and "Hyphenation active"
5. Click Ok

Hyphenation does not function. It also does not in en_US locale.

Words must be carried by syllables, if Hyphenation active is checked and text is long.
Comment 1 raal 2016-05-31 03:42:00 UTC
I can confirm with Version: 5.3.0.0.alpha0+
Build ID: 86d84ae4bba0d4c45bc13232645318291a8aed75
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-05-26_14:33:24
and 3.5
Comment 2 QA Administrators 2017-09-01 11:15:34 UTC Comment hidden (obsolete)
Comment 3 Timur 2018-07-19 13:27:24 UTC
"hyphenation active" does work in Calc, only doesn't for English (USA). For example, it works for English (UK).
So I change to Localization and update the Summary.
For test, language support must be installed so it should be tested with release versions. I confirm with 6.1.
Comment 4 QA Administrators 2019-10-25 02:40:10 UTC Comment hidden (obsolete)
Comment 5 Timur 2019-10-25 08:56:47 UTC
I can't say why I noted that hyphenation in Cal does not work only for "English (USA)".
But I see now that there's another broader issue here, tested in LO 6.4+ when default language is a different one:

hyphenation *works* for existing text if desired and supported language is set via Tools-Language-For All Text..

hyphenation does *not* work if language for existing text is set via Format-Cells-Numbers-Language 

hyphenation *works* for new text if language set via status bar Text Language button.

Maybe that's as intended (language for numbers is just number format), it should then be written in Help under "Hyphenation active".
Comment 6 Timur 2019-10-25 08:59:41 UTC
Per https://bugs.documentfoundation.org/show_bug.cgi?id=127856#c3 that's correct behavior. So I close the bug.
Feel free to set back New if retested wrong, but with exact details and steps.
Comment 7 QA Administrators 2019-10-26 02:11:19 UTC Comment hidden (obsolete)