Bug 100139 - Can't work on specific docx file with tracked changes visible (specials fonts, two huge tables..)
Summary: Can't work on specific docx file with tracked changes visible (specials fonts...
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:docx
Depends on:
Blocks: DOCX
  Show dependency treegraph
 
Reported: 2016-05-30 12:51 UTC by Levan
Modified: 2019-01-20 21:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
docx file (1.53 MB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2016-05-30 12:51 UTC, Levan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Levan 2016-05-30 12:51:39 UTC
Created attachment 125390 [details]
docx file

I noticed that it was impossible to work on certain .docx file.
Well libreoffice opens it but it hangs and basically it is unusable  

I even tried to export this file as open document but still same issue.

I am attaching the docx file.
Comment 1 MM 2016-05-30 18:33:45 UTC
Confirmed with v5.2.0.0a1 under ubuntu 16.04 x64.
Comment 2 Cor Nouws 2016-05-31 08:36:22 UTC
Thanks for reporting Levan.
I confirm the problem in daily20160525 on Ubuntu 32 bits.

Loading takes long ; working in the document not possible.

Writer continuously fights with the page count. Looks as if a/the table(s) have something to do with it.
I see there is change tracking too in the document. Turning of showing the changes (waiting...) makes that the file is editable..
But then SaveAs takes a huge time again...
Opening in 3.3.0 is a pain too.
Comment 3 Cor Nouws 2016-05-31 08:36:43 UTC
thus new
Comment 4 QA Administrators 2017-12-10 16:41:47 UTC Comment hidden (obsolete)
Comment 5 Cor Nouws 2017-12-28 22:39:51 UTC
still the same problem in 
Version: 6.1.0.0.alpha0+
Build ID: a9b202a6b7000e7af34f2a639ca207122a3968bf
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2017-12-26_23:09:36
Locale: nl-NL (nl_NL.UTF-8); Calc: group threaded
Comment 6 QA Administrators 2018-12-29 03:49:53 UTC Comment hidden (obsolete)
Comment 7 Cor Nouws 2019-01-20 21:51:22 UTC
unchanged in 6.3 master