Bug 100220 - Result of the Combination IF() and AND()
Summary: Result of the Combination IF() and AND()
Status: RESOLVED DUPLICATE of bug 75650
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-04 19:52 UTC by h7rojas
Modified: 2016-06-10 00:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screen Capture (107.78 KB, image/png)
2016-06-04 19:55 UTC, h7rojas
Details
Schrödinger's cat (8.67 KB, application/x-vnd.oasis.opendocument.spreadsheet)
2016-06-06 15:16 UTC, Aron Budea
Details

Note You need to log in before you can comment on or make changes to this bug.
Description h7rojas 2016-06-04 19:52:35 UTC

    
Comment 1 h7rojas 2016-06-04 19:55:13 UTC
Created attachment 125488 [details]
Screen Capture
Comment 2 Julien Nabet 2016-06-05 10:52:28 UTC
On pc Debian x86-64 with LO Debian package 5.1.3.2, I could reproduce this but I don't reproduce with LO master sources updated today.
Comment 3 Aron Budea 2016-06-06 07:25:51 UTC
Can you? I couldn't, and see 150 in 5.1.3.2 as well.
The formula translates to this in English, right?: =IF(AND(B1 > A1; B1 < A2); B1; "")

Could you or h7rojas upload it as a sample document?

An unrelated, interesting observation:
Is it normal that copy-pasting between different Calc instances (eg. multiple different versions running), the formula is evaluated, and pasted as 150?
Only when it's the same Calc (different or same files, doesn't matter) the formula transferred as a formula.
Comment 4 Aron Budea 2016-06-06 15:16:13 UTC
Created attachment 125516 [details]
Schrödinger's cat

Got an e-mail from h7rojas with some details, thanks. My conclusion is a bit different, though (the information I got is that it occurs in 64-bit, but not in 32-bit).

Before I spoil the details, see attachment, and in particular formula/values C1 and C2.

Spolier:
C1 is formatted as Boolean value, and 150 is TRUE if it's displayed as boolean. However, I didn't format it as such. What happens is that if you first input a boolean formula in the field, it's displayed as Boolean value, if you later change it to a numerical formula, the display format doesn't change, and the result is displayed as boolean.

I'm leaning towards considering this a bug, but there are many different cases here with different display formats, and automatically adjusting the display format might not work in all cases.
Comment 5 Aron Budea 2016-06-10 00:22:38 UTC
Reopened bug 75650. Closing this as duplicate.

*** This bug has been marked as a duplicate of bug 75650 ***