Bug 100299 - Crash when update database in document with conditional texts
Summary: Crash when update database in document with conditional texts
Status: RESOLVED DUPLICATE of bug 96914
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.3.1 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-09 19:13 UTC by vincent.lefoulon
Modified: 2016-06-27 10:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
The original .odt file (8.69 KB, application/vnd.oasis.opendocument.text)
2016-06-09 19:13 UTC, vincent.lefoulon
Details
The database (7.63 KB, application/vnd.oasis.opendocument.spreadsheet)
2016-06-09 19:13 UTC, vincent.lefoulon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vincent.lefoulon 2016-06-09 19:13:22 UTC
Created attachment 125581 [details]
The original .odt file

Hi,

I work on Arch Linux x86_64 and LO 5.3.1 (https://www.archlinux.org/packages/?arch=any&arch=i686&arch=x86_64&q=libreoffice-fresh) crashes when I change the database of a document with conditional texts:

* Create a .ods file "test.ods"
* In A1, put "Var"
* In A2, put 0
* Create a .odt file "test.odt"
* Insert a conditional text based on the value of "Var" : Insert > Field > More > Hidden text > Condition : "a_stupid_db_name.Sheet1.Var == 0"
* Add "test.ods" as database : Edit > Exchange database > Browse
* Define test.Sheet1 as data source
* Close LO or print the document as form letter and see it crash

When I reopen the .odt file, "a_stupid_db_name" has been replaced by "test" in the field's condition, but LO tells me that the database "test" cannot be loaded when I try to print the document. If I browse the database again, LO crashes again.

Thank you
Comment 1 vincent.lefoulon 2016-06-09 19:13:41 UTC
Created attachment 125582 [details]
The database
Comment 2 vincent.lefoulon 2016-06-10 18:24:06 UTC
The bug can be easily reproduced by following these steps:

* Download the attachments
* Define the .ods file as a database in the .odt file (Edit > Exchange database > Browse > Define Sheet1)
* Save and quit

Moreover, LO does not offer recovery at restart.

Even if the database has the same name as the one used in the field's condition, LO crashes.
Comment 3 Buovjaga 2016-06-12 14:25:34 UTC
(In reply to vincent.lefoulon from comment #2)
> The bug can be easily reproduced by following these steps:
> 
> * Download the attachments
> * Define the .ods file as a database in the .odt file (Edit > Exchange
> database > Browse > Define Sheet1)
> * Save and quit

I did not get the crash.

Could you test with a fresh (debug) master build: http://dev-builds.libreoffice.org/daily/master/Linux-rpm_deb-x86_64@70-TDF-dbg/current/
If it still crashes, you can get a backtrace: https://wiki.documentfoundation.org/QA/BugReport/Debug_Information

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: e1ca24369142af3e721e789bf757be671e1905b7
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on June 10th 2016
Comment 4 Marco Filippozzi 2016-06-15 09:48:06 UTC
Confirmed the crash (in LO Fresh), but couldn't replicate the name change in the condition, and couldn't replicate the crash in 5.3.0.0

Steps:
Open the document
Edit -> Exchange database
Browse the file
Click on sheet1 and click on Define, then click the close button
File -> Wizard -> Address Data Source
Proceed to add the .ods file
View -> Data Sources
Drag a data field into the document
Print as a form letter

This should crash the program. 

Present on:
Version: 5.1.3.2
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
CPU Threads: 2; OS Version: Linux 4.1; UI Render: default; 
Locale: it-IT (it_IT.UTF-8)
OS: openSUSE Leap 42.1 (x86_64)
Comment 5 Buovjaga 2016-06-15 11:32:12 UTC
Thanks, Marco.

I'll set to NEW for now.

Vincent: maybe you could test with 5.1.4 release candidate to see, if the crash is gone? https://wiki.documentfoundation.org/Installing_in_parallel/Linux
Comment 6 Caolán McNamara 2016-06-15 14:17:58 UTC

*** This bug has been marked as a duplicate of bug 96914 ***