Download it now!
Bug 100375 - MAIL MERGE: Text kept as highlighted field values when printed as individual documents, whereas print to a single document contains unhighlighted field values
Summary: MAIL MERGE: Text kept as highlighted field values when printed as individual ...
Status: RESOLVED DUPLICATE of bug 89178
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.8.2 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-14 16:09 UTC by manuel.defranceschi
Modified: 2016-06-16 12:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description manuel.defranceschi 2016-06-14 16:09:11 UTC
Description:
When I print a document as file and use the option "Save as individual documents" with database's field in it Writer save the file replacing the database's field with their value, but maintaining them formatted as field instead of as text.

Steps:
-Open Writer
-Load a database(View>Data Source>Right click on the left>Registered Databases  and then select the path of the database)
-Insert field of the database in the document
-Go to File>Print and select File as output and select "Save as individual documents"

Expected behavior:
In the final documents the fields are converted in text

Current behavior:
In the final documents the fields remain fields


Affected version:
Version: 4.2.8.2
Build ID: 48d50dbfc06349262c9d50868e5c1f630a573ebd:present
OS:openSUSE Leap 42.1 (x86_64)

Version: 4.4.4.3
Build ID: 2c39ebcf046445232b798108aa8a7e7d89552ea8
OS:openSUSE Leap 42.1 (x86_64)

Versione: 5.1.3.2
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
OS:openSUSE Leap 42.1 (x86_64)
Comment 1 Alex Thurgood 2016-06-15 08:24:14 UTC
@Manuel
If I understand you correctly, you are complaining that your exported documents obtained via the Print to File option in mailmerge contain field values which show the field highlighting ?

In document edit mode, when such a document is opened, I can indeed see the grey background, indicating that the data is obtained from a database field. However, this is only a visual indicator.

If I look at print preview of the document, the grey background is not displayed, nor, I am assuming, is it printed. You can also change the font family, weight, style, etc of the data displayed, so what exactly is the problem ?

For me, this is not a bug.

Tested on 

Version: 5.3.0.0.alpha0+
Build ID: 4d49c9601c9b3e26a336e08e057d299895683480
Threads CPU : 2; Version de l'OS :Mac OS X 10.11.5; UI Render : par défaut; 
Locale : fr-FR (fr.UTF-8)

Am setting this needinfo pending your answers to my questions above, otherwise I will set to NOTABUG
Comment 2 manuel.defranceschi 2016-06-15 10:15:41 UTC
So it's normal that the field is highlight. But if so, it's a problem if when I print the document as a single document instead of as individual file the field are converted in text?
Comment 3 Alex Thurgood 2016-06-16 10:00:32 UTC
(In reply to manuel.defranceschi from comment #2)
> So it's normal that the field is highlight. But if so, it's a problem if
> when I print the document as a single document instead of as individual file
> the field are converted in text?

@Manuel : OK, I now understand the problem you are describing, and yes, the two are inconsistent, IMHO they should behave the same way. Your initial bug report did not mention this fact though, hence the questions on my side.

I will clean this report up and confirm.
Comment 4 Alex Thurgood 2016-06-16 10:02:56 UTC
Compare the two Print to File options in a mailmerge document.

The Print to Multiple Files produces Writer documents that contain values from the data fields that are highlighted with the default grey background.

The Print to Single File option produces a document with the field values and no highlighting.
Comment 5 Alex Thurgood 2016-06-16 10:04:35 UTC
The display behaviour in the end files should be consistent, therefore this is a bug.
Comment 6 Alex Thurgood 2016-06-16 12:39:41 UTC

*** This bug has been marked as a duplicate of bug 89178 ***