Download it now!
Bug 100392 - MAILMERGE: CRASH: Hidden paragraph insertion
Summary: MAILMERGE: CRASH: Hidden paragraph insertion
Status: RESOLVED DUPLICATE of bug 97501
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.3.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-15 08:41 UTC by massimo.zaffaina
Modified: 2016-06-15 12:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description massimo.zaffaina 2016-06-15 08:41:01 UTC
Description: 
While following the guide "Using Mail Merge" https://wiki.documentfoundation.org/images/3/3c/WG4211-UsingMailMerge.pdf paragraph "Creating a form letter", a crash occours on step 6d.

Steps:
1)open calc; 
2)insert the data;
3)open writer;
4)file->wizards->Adress data source;
5)select other external data source and then click on next button;
6)click the Settings button;
7)select Spreadsheet on the database type;
8)click Browse and navigate to the spreadsheet that contains the address 
9)information;
10)click on next button;
11)click finish;
12)View > Data sources;
13)find the data source that you wish to use for the form letter;
14)click in the field heading and drag it to the appropriate point in the letter;
15)Insert > Fields > Other;
16)select the Functions tab and then click on Hidden Paragraph in the Type column;
17)now click in the Condition box and enter the details of the condition that defines a blank address field. It has the general form of:![Database.Table.Database field];
18)and then click on insert button and close the dialog;
19)now save the document on the desktop;
20)close the document using the X button on the window and now writer will crash.

Affected versions:
Versione: 5.1.3.2
Build ID: 10m0(Build:2)
Thread CPU: 2; Versione SO: Linux 4.1; Resa interfaccia: predefinito; 
Versione locale: it-IT (it_IT.UTF-8)
OS: openSUSE Leap 42.1 (x86_64)

Versione: 5.1.3.2
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
Thread CPU: 2; Versione SO: Linux 4.1; Resa interfaccia: predefinito; 
Versione locale: it-IT (it_IT.UTF-8)
OS: openSUSE Leap 42.1 (x86_64)

Not affected 
Versione: 5.0.6.3
Build ID: 490fc03b25318460cfc54456516ea2519c11d1aa
Versione locale: it-IT (it_IT.UTF-8)
OS: openSUSE Leap 42.1 (x86_64)

Versione: 4.4.7.2
Build ID: f3153a8b245191196a4b6b9abd1d0da16eead600
Versione locale: it_IT.UTF-8
OS: openSUSE Leap 42.1 (x86_64)

Versione: 4.3.7.2
Build ID: 8a35821d8636a03b8bf4e15b48f59794652c68ba
OS: openSUSE Leap 42.1 (x86_64)

Expected behavior: 
The hidden paragraph is inserted and the user can closes the dialog, saves and close the document.

Current behavior:
The hidden paragraph is inserted, the user can closes the dialog and saves the document.When the user closes the document using the X button on the window LibreOffice crashes.
Comment 1 massimo.zaffaina 2016-06-15 09:48:30 UTC
Others not affected versions:
Version: 5.3.0.0.alpha0+
Build ID: a8bd44573b75d1399257d6f5d052611439607189
CPU Threads: 2; OS Version: Linux 4.1; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-06-13_23:46:49
Locale: it-IT (it_IT.UTF-8)
OS:openSUSE Leap 42.1 (x86_64)

Versione: 5.2.0.0.beta2
Build ID: ae12e6f168ba39f137fc110174a37c482ce68fa4
Thread CPU: 2; Versione SO: Linux 4.1; Resa interfaccia: predefinito; 
Versione locale: it-IT (it_IT.UTF-8)
OS:openSUSE Leap 42.1 (x86_64)
Comment 2 manuel.defranceschi 2016-06-15 10:59:25 UTC
I replicated the bug using the steps, so I change the status to new.
Comment 3 Caolán McNamara 2016-06-15 12:30:28 UTC
You just need...

15)Insert > Fields > Other;
16)select the Functions tab and then click on Hidden Paragraph in the Type column;
17)now click in the Condition box and enter the details of the condition that defines a blank address field. It has the general form of:![Database.Table.Database field];
18)and then click on insert button and close the dialog;
20)close the document using the X button on the window and now writer will crash.

to reproduce this.

Turns out its a duplicate of something that only got fixed in 5-2 and not backported to 5-1 which I will do now

*** This bug has been marked as a duplicate of bug 97501 ***
Comment 4 Caolán McNamara 2016-06-15 12:31:04 UTC
https://gerrit.libreoffice.org/26304 for 5-1 backport review