Download it now!
Bug 100395 - Crash in datasource tree view when expanding tree in Exchange Database dialog
Summary: Crash in datasource tree view when expanding tree in Exchange Database dialog
Status: RESOLVED DUPLICATE of bug 97501
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.3.2 release
Hardware: x86-64 (AMD64) All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2016-06-15 09:46 UTC by manuel.defranceschi
Modified: 2016-06-16 09:01 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
symbol > disappear (22.00 KB, image/png)
2016-06-15 09:46 UTC, manuel.defranceschi
Details
Apple stack trace from hung application (844.15 KB, text/plain)
2016-06-16 07:58 UTC, Alex Thurgood
Details

Note You need to log in before you can comment on or make changes to this bug.
Description manuel.defranceschi 2016-06-15 09:46:34 UTC
Created attachment 125666 [details]
symbol > disappear

Description:
I added some databases from Exchange Databases, and then restarted Writer. If I return in Exchange Databases and click on the ">" symbol it disappear and the voice doesn't expand. If I click all the voices from the bottom to the top and then close LO the program crash. I attached a screenshot of the ">" symbol disappearance.

Steps:
-Open Writer
-Go to Edit>Exchange Database
-Click Browser and add some databases(I added 3-4 over the 2 standards)
-Click "Close"
-Restart Writer
-Go to Edit>Exchange Database
-Expand all the voice clicking on the ">" symbol from the bottom to the top
-Click "Close"
-Close Writer
At this point the program crash.

Affected version:
Version: 5.1.3.2
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
OS: openSUSE Leap 42.1 (x86_64)
Comment 1 Alex Thurgood 2016-06-16 07:47:57 UTC
Confirming on

Version: 5.1.3.2
Build ID: 644e4637d1d8544fd9f56425bd6cec110e49301b
CPU Threads: 2; OS Version: Mac OS X 10.11.5; UI Render: default; 
Locale: fr-FR (fr.UTF-8)


regression
Comment 2 Alex Thurgood 2016-06-16 07:58:06 UTC
More info : 
No document recovery is initiated in an empty Writer document.
If the Writer document contains unsaved data, and the user closes the document, they are prompted to save. When I do this on the Mac, the Save dialog registers the file but does not save the document (the title of the document stays as Untitled 1), and LO hangs indefinitely, requiring force kill.

Enclosing stack trace from hung application.
Comment 3 Alex Thurgood 2016-06-16 07:58:43 UTC
Created attachment 125686 [details]
Apple stack trace from hung application
Comment 4 Caolán McNamara 2016-06-16 09:01:14 UTC
This all crashes for me in the same place as bug 97501 and alex's backtrace has that crashing frame in it too.

So this should get fixed by the pending review https://gerrit.libreoffice.org/#/c/22027/

*** This bug has been marked as a duplicate of bug 97501 ***