Bug 100444 - Crash reporter not working in Linux
Summary: Crash reporter not working in Linux
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
(earliest affected)
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
Depends on:
Blocks: Crash-Report
  Show dependency treegraph
Reported: 2016-06-17 04:41 UTC by Aron Budea
Modified: 2017-10-20 10:15 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2016-06-17 04:41:29 UTC
I finally encountered a nice crash when I was testing bug 100421.
Crash reporing worked in Windows as expected [1], but there's no popup and nothing is sent when I reproduce the crash in my Linux VM (Ubuntu 15.10).

Markus, since you told me the crash reporter should normally work with Linux, I decided to open this report. However, you also wrote there might be conflicts with Java (I had Java 8 installed) or with internal signal handlers, so I'm not sure.

Anyway, if I should try something differently, or if currently this is the expected behavior, please update this report accordingly. Thanks!

[1] http://crashreport.libreoffice.org/stats/signature/SwFrame::Shrink(long,bool,bool)+0x0
Comment 1 Christian Lohmaier 2016-06-17 11:17:39 UTC
can confirm that it is not triggered by trying to reproduce the linked bug, but can be triggered by manually killing LO - see cf7fb54f-e6b6-45b4-8d45-4d27f4dfeedc 
Of course would be more helpful if it also worked for real crashes :-)
Comment 2 Aron Budea 2016-06-17 19:15:32 UTC
I can't get a crash report/dump by killing LO. Tried with 'kill -s SIGABRT <pid>'.
I also tried increasing dump size by 'ulimit -c <size>', because it was set to 0, don't know if that matters.
Comment 3 Aron Budea 2016-06-24 02:45:42 UTC
Didn't get crash report in with this crash: bug 100574.

Christian, what's your method for deliberately crashing LO in Linux?
Comment 4 Christian Lohmaier 2016-06-24 12:01:19 UTC
I did send SIGILL
Comment 5 Aron Budea 2016-06-25 07:04:06 UTC
That doesn't work for me. I wonder why.
Comment 6 Aron Budea 2016-06-25 07:06:50 UTC
I mean SIGKILL, I noticed the typo.
Comment 7 Christian Lohmaier 2016-07-01 15:25:13 UTC
that was no typo though.  *ILL*egal instruction signal (numeric value would be 4)

SIGKILL = 9 (no mercy, for that you don't give the application a chance to react, so if LO would manage to show crashreporter for that case, I'd be very surprised :_9)
Comment 8 Aron Budea 2016-07-05 14:59:26 UTC
Indeed, I got a crash report after SIGILL. Thanks, Christian.
Comment 9 opensuse.lietuviu.kalba 2016-08-30 16:08:56 UTC
After executing
> pkill --signal SIGILL soffice.bin

I also can see crash report at next start of LO
Comment 10 Christian Lohmaier 2016-08-30 16:12:02 UTC
manually killing it with illegal instruction signal doesn't count as "working to report crashes"
Comment 11 opensuse.lietuviu.kalba 2016-08-30 16:13:23 UTC
But in LO

> pkill --signal SIGILL soffice.bin

will not not produce crash report at next start.

Thus seems fixed for 5.2
Comment 12 Christian Lohmaier 2016-08-30 16:14:25 UTC
the crashreporting is a new feature in 5.2, so 5.1.x didn't have that at all…
Comment 13 Xisco Faulí 2017-06-09 08:38:57 UTC
*** Bug 108422 has been marked as a duplicate of this bug. ***
Comment 14 Xisco Faulí 2017-09-01 18:03:01 UTC
I've just downloaded LibreOffice 5.4.1 from https://www.libreoffice.org/download/download/ and it works now: http://crashreport.libreoffice.org/stats/signature/SwNoTextNode::MakeFrame(SwFrame*)