Bug 100449 - Font size is wrong in pdf form for radio button group
Summary: Font size is wrong in pdf form for radio button group
Status: RESOLVED DUPLICATE of bug 97120
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.0.5.2 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2016-06-17 09:50 UTC by Luc Novales
Modified: 2016-08-11 19:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Form file and pdf generated with LO4 and LO5 (32.12 KB, application/x-compressed-tar)
2016-06-17 09:50 UTC, Luc Novales
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luc Novales 2016-06-17 09:50:08 UTC
Created attachment 125702 [details]
Form file and pdf generated with LO4 and LO5

This is a regression introduced by LO 5.

As you can see in joint files : form exported by LibreOffice 4.3.3.2 430m0(Build:2) is correct, but font size of group name is incorrect in file generated from LibreOffice 5.1.3.2 10m0(Build:2). Text is too big to be displayed on the line, only lower part of characters is visible.

Reducing font size in parameters control box does not solve this problem and downgrade LO seems the unique solution.

To reproduce this :

- open new file with writer
- open form bar
- open additionnal controls bar
- add a radio buttons area with buttons and à name
- export the form in pdf

result is correct with LO 4.3, not with LO 5.1. Using LO 4 or LO 5 to produce writer document doesn't change exported results.

Luc.
Comment 1 Ysabeau 2016-06-17 15:50:33 UTC
I too have this issue with 5.1.4.2 for Windows 32 bits.
Comment 2 Buovjaga 2016-06-17 18:43:23 UTC
NEW per comment 1.
Comment 3 Arnaud Versini 2016-06-19 13:28:59 UTC
Confirmed on Windows and version 5.0.5.
Comment 4 Caolán McNamara 2016-08-04 09:09:03 UTC
This is related to bug #97120 in that the same change that broke that broke this
Comment 5 Caolán McNamara 2016-08-04 13:00:48 UTC

*** This bug has been marked as a duplicate of bug 97120 ***
Comment 6 Luc Novales 2016-08-10 15:44:27 UTC
Solved in LibreOfficeDev 5.3.0.0.alpha0 a22328eea392aeeb0d0cbe7492ce185a36777da1
:-)
Comment 7 Buovjaga 2016-08-10 16:25:34 UTC
Thanks, Luc. Would you like to join the QA team? Info about it is here: https://wiki.documentfoundation.org/QA
Comment 8 Luc Novales 2016-08-11 19:06:15 UTC
(In reply to Buovjaga from comment #7)
> Thanks, Luc. Would you like to join the QA team? Info about it is here:
> https://wiki.documentfoundation.org/QA

Thanks, but missing time for that. ;-)
Comment 9 Luc Novales 2016-08-11 19:08:45 UTC
(In reply to LucN31 from comment #6)
> Solved in LibreOfficeDev 5.3.0.0.alpha0
> a22328eea392aeeb0d0cbe7492ce185a36777da1
> :-)

Fixed too in version 5.2 :
Build Info
tinderbox: administrator: lohmaier+tinderbox@gmail.com
tinderbox: buildname: Linux-rpm_deb-x86_64@70-TDF
tinderbox: tree: libreoffice-5-2
tinderbox: pull time 2016-08-11 08:34:56
tinderbox: git sha1s
core:a30281168c2bde2d618ec6ad79e1fb158b244e1f