Bug 100483 - Cell corruption on Thinkpad 450S
Summary: Cell corruption on Thinkpad 450S
Status: RESOLVED DUPLICATE of bug 100925
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected) release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
Depends on:
Reported: 2016-06-19 18:22 UTC by makitso
Modified: 2016-10-22 07:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

cell corruption (4.74 KB, image/png)
2016-06-24 16:33 UTC, makitso

Note You need to log in before you can comment on or make changes to this bug.
Description makitso 2016-06-19 18:22:39 UTC
When updating numeric or text cell, typing data into existing cell shows corruption on screen.  The cell is not being cleared prior to entry, new value appears on top of original text or numeric content.  

Intel Corporation Broadwell-U Integrated Graphics (rev 09)
Xubuntu 16.04
Comment 1 makitso 2016-06-24 16:16:59 UTC
Problem still exists with
Comment 2 makitso 2016-06-24 16:33:27 UTC
Created attachment 125887 [details]
cell corruption

See attached
Comment 3 Thomas Hackert 2016-06-25 10:38:32 UTC
Hello Makitso, *,
I cannot confirm it with

OS: Debian Testing AMD64
LO: Version:
Build-ID: 1:5.1.4~rc2-2
CPU Threads: 4;OS Version: Linux 4.5; UI Render: default; 
Locale: de-DE (de_DE.UTF-8)
(Debian's own version)

nor with

LO: Version:
Build ID: fcbcb4963bda8633ba72bd2108ca1e802aad557d
CPU Threads: 4; OS Version: Linux 4.5; UI Render: default; 
Locale: de-DE (de_DE.UTF-8)
(parallel installed, following the instructions from https://wiki.documentfoundation.org/Installing_in_parallel/Linux)


# hwinfo |grep Graphics
     str1: "Video Graphics Controller"
E: ID_MODEL_FROM_DATABASE=Haswell-ULT Integrated Graphics Controller
   Video: "Video Graphics Controller"
   Model: "Intel Haswell-ULT Integrated Graphics Controller"
   Device: pci 0x0a16 "Haswell-ULT Integrated Graphics Controller"

using xserver-xorg-video-intel 2:2.99.917+git20160522-1.

Just out of interest: is "Use OpenGL on all Rendering" or "Force OpenGL even if blacklisted" in "Tools - Options - LibreOffice - View" enabled on your system? If so: have you installed any glx, opengl, mesa, etc. packages? Do they work with other applications? What happens, if you disable them?
Comment 4 makitso 2016-06-25 14:59:47 UTC
Thanks Thomas.  Yes, I have glx, opengl, mesa packages installed, not sure why.  
Checking and unchecking the use OpenGL options does not help.  I will try with a clean system.
Comment 5 makitso 2016-06-25 17:01:59 UTC
OK, I have found a solution but really by accident. 

Tried a stock 16.04 xubuntu system and no sign of the problem.  Then install all the applications on the stock system and still no problem.  

Then back on my base system I noted that with the Intel Corporation Broadwell-U Integrated Graphics card I run the resolution at 1600x900 as opposed to the standard 1920x1080 resolution.  So, I change the resolution to 1920 and the problem went away!!  Then changed the desktop resolution back to the 1600x900 and the problem no longer exists!
Comment 6 makitso 2016-09-15 18:50:53 UTC
Well, the problem is back and the workaround I mentioned before is no longer any help.  Version is
Comment 7 makitso 2016-10-21 19:02:00 UTC
I understand that this is a video driver problem.  I tried a newer kernal and no change.  But i tried xubuntu 16.10 and that fixed the problem. For some reason the video driver (lspci) is different than 16.10, so i upgraded.

However, i never found any other application that failed except Calc.
Comment 8 Buovjaga 2016-10-22 07:31:21 UTC

*** This bug has been marked as a duplicate of bug 100925 ***