Bug 100499 - function AMORLINC - basis 2 result Err:502
Summary: function AMORLINC - basis 2 result Err:502
Status: RESOLVED DUPLICATE of bug 100496
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-20 09:14 UTC by raal
Modified: 2016-07-07 07:25 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description raal 2016-06-20 09:14:30 UTC
https://help.libreoffice.org/Calc/Financial_Functions_Part_One#AMORLINC

=AMORLINC(10000;DATE(2012;3;1);DATE(2012;12;31);1500;1;0,3;2))  result is
Err502

According to help and ODF specification basis 2 should work.

note: in excel basis 2 not exist:
https://support.office.com/en-US/article/AMORLINC-function-7D417B45-F7F5-4DBA-A0A5-3451A81079A8
Comment 1 Buovjaga 2016-06-26 10:27:59 UTC
Confirmed with =AMORLINC(10000;DATE(2012;3;1);DATE(2012;12;31);1500;1;0,3;2)
Removed the extra parenthesis.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: ff25ea3d5ccf3a990767cbb1ef99037d3f84b072
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on June 26th 2016
Comment 2 Winfried Donkers (retired) 2016-07-07 06:42:02 UTC
This is caused by the add-in function Yearfrac which does not fully comply with ODFF1.2

*** This bug has been marked as a duplicate of bug 100496 ***
Comment 3 Winfried Donkers (retired) 2016-07-07 07:25:14 UTC
(In reply to Winfried Donkers from comment #2)
> This is caused by the add-in function Yearfrac which does not fully comply
> with ODFF1.2

This is not entirely correct, but is further explained in bug 100496.