Bug 100500 - Default window size CALC UI
Summary: Default window size CALC UI
Status: RESOLVED DUPLICATE of bug 75644
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-20 09:38 UTC by Colin
Modified: 2016-06-20 17:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Colin 2016-06-20 09:38:43 UTC
Opening both new and existing Calc Documents produces a small centrally located window of proportions that are always going to require resizing to permit anything larger than a 10 x 17 grid with the current default calc/grid characteristics.
If I'm not mistaken, just about every windows program in existence (probably since windows 1) remembers the coordinates, window size and content of the last utilisation and reopens the application/file accordingly. Under those circumstances I consider it to be a bug as opposed to an enhancement request. Would you disagree?
It's not a major issue if individual files don't immediately have the last used default but the current global default size is about as much use as an ashtray on a motorcycle - to anybody wishing to use a spreadsheet as a spreadsheet rather than perhaps a small picture frame.
A similar bug report has existed since 2012 but that was set to solved by somebody, late last year, who claimed to have fixed it in a UBUNTU LINUX environment. In all honesty, I couldn't find that solution in his posts for either Windows or Linux so I suspect it was (mistakenly?) flagged as solved.
1. The initial window should be defaulted to at least 80% of the available desktop (check the user's monitor size).
2. The user should be able to modify this initial default size in Calc settings.'
3. The application should update it's own parameters - or the Window's registry if appropriate - when a user (customer) manually resizes the window - in order that the last used status is restored.
Comment 1 V Stuart Foote 2016-06-20 17:02:14 UTC
You're experiencing the interplay of the StartCenter and the other LO modules.
that is bug 75644 -- in essence the StartCenter acts as a master and launching from there resets the size location recorded with the components.

The componet modules all remember their settings per user as recorded in the user profile.

So with a default profile, you open Calc directly (program/scalc.exe) the frame will be full screen. You can resize/relocate close and reopen and the setting is persistent.

But if you open to StartCenter with an empty profile, and then launch Calc from that frame--Calc will open to match the size/location of the StartCenter

What has to be corrected is the linkage between the StartCenter as master overriding launch of the other modules.  With persistent customization available to each module now, the StartCenter needs to be demoted and handled just like the frames for the other modules.  Instead of overwriting profile settings.

*** This bug has been marked as a duplicate of bug 75644 ***