Download it now!
Bug 100575 - "Sort Ascending" forces "Range contains row labels" on text only range.
Summary: "Sort Ascending" forces "Range contains row labels" on text only range.
Status: RESOLVED DUPLICATE of bug 91305
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-24 03:58 UTC by mrelwood
Modified: 2016-06-26 12:52 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mrelwood 2016-06-24 03:58:10 UTC
If you select an area with text (no value) in all cells of first row, then "Range contains column labels" is automatically ticked. This means that the toolbar sort button behavior changes without notice, and may cause severe problems if the user doesn't notice.

This is unpredictable behavior that works wrong in many situations.

I ask for this to be a user selectable option, in settings or wherever seen best.


SITUATIONS where current behavior is wrong:

- A single column of names (or any other text).
- A list of text only items, that later gets a column for price. Sort behavior changing is unpredictable.
- A list of items that has single alphabets in a column to represent importance.
- Selecting a range and clicking "Sort" doesn't always sort.

I have used spreadsheets several times weekly for about two decades, and I have never done a sort that would benefit from skipping the first line. But this automatic guessing going wrong has bothered me for years.

Currently the only predictable way to do a sort is through menus or popup windows with tabs. It takes 4 clicks and typing a name for the range. It should only take one.
Comment 1 Buovjaga 2016-06-26 12:52:41 UTC

*** This bug has been marked as a duplicate of bug 91305 ***