Bug 100583 - EDITING. The "Current selection only" checkbox in the Find & Replace dialog sometimes unchecks itself
Summary: EDITING. The "Current selection only" checkbox in the Find & Replace dialog s...
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) Windows (All)
: low minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Find-Search
  Show dependency treegraph
 
Reported: 2016-06-24 10:40 UTC by smason
Modified: 2020-05-16 13:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description smason 2016-06-24 10:40:35 UTC
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build Identifier: fcbcb4963bda8633ba72bd2108ca1e802aad557d

When performing dozens of "Replace all" operations on a selection using the "Find and Replace" dialog box with the "Other options -> Current selection only" box checked, I noticed that occasionally the "Replace all" operation would be performed on the entire sheet, not just the current selection. 
Whenever this occurs the "Current selection only" checkbox becomes unchecked.
If I then use Edit->Undo and Edit->Redo, the error just repeats over and over. If I use Edit->Undo and then click on "Replace all" a second time, the "Replace all" operation is performed only on the current selection, as expected, and the "Current selection only" checkbox remains checked.
I estimate this occurs only around 2% of the time.

Reproducible: Sometimes

Steps to Reproduce:
1. Fill multiple rows and columns with various letters
2. Highlight a column
3. Open Edit->Find & Replace
4. It does not matter if "Match case" is checked or unchecked.
5. Confirm that Other options->"Current selection only" is checked
6. Enter letters in the "Find" and "Replace" text boxes
7. Click "Replace all"
8. Select a new column, enter new values in the "Find" and "Replace" text boxes, and click "Replace all"
9. Repeat step 8 dozens of times.
Actual Results:  
The behaviour is inconsistent. Eventually the "Replace all" operation will be performed on the entire sheet, not just the current selection, and the "Current selection only" box will uncheck itself.

Expected Results:  
The "Replace all" operation should only be performed within the current selection. The "Current selection only" box should remain checked.




Reset User Profile?Yes.
Comment 1 Buovjaga 2016-07-02 12:44:04 UTC
Could not reproduce. I tried it a dozen times, not using undo, but always copying and pasting from column A to B the replaced words.

What version are you using?

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: ef47ce2397d4ed453fe01d994d13a13f442ec3bb
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on July 2nd 2016
Comment 2 Zineta 2016-12-06 10:27:24 UTC
After more than ten replacement the "Current selection only" checkbox  unchecked itself, replacing all letters in whole sheets not only selected.
Then, I try again and again the same happened every time.
LO Version: 5.1.6.2 
OS Windows 7
Comment 3 Buovjaga 2016-12-06 10:28:46 UTC
(In reply to Zineta from comment #2)
> After more than ten replacement the "Current selection only" checkbox 
> unchecked itself, replacing all letters in whole sheets not only selected.
> Then, I try again and again the same happened every time.
> LO Version: 5.1.6.2 
> OS Windows 7

Can you reproduce this with version 5.2.3?
Comment 4 Zineta 2016-12-07 13:33:45 UTC
Reproduced on version:5.2.3; 5.2.4; 5.3.0 (Win 7) the same steps,
box  remained checked. It seems that the problem has been resolved in recent version.
Comment 5 Buovjaga 2016-12-07 13:51:15 UTC
Zineta: thanks for testing. Let's set this to WFM even though 5.3 is not officially out, as this is a "sometimes" issue.

If you want to help, we are always looking for testers: https://wiki.documentfoundation.org/QA/GetInvolved
Comment 6 romi Gupta 2020-05-16 12:47:19 UTC Comment hidden (spam)