Download it now!
Bug 100615 - Short-cut to closing a document has changed
Summary: Short-cut to closing a document has changed
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Locale
  Show dependency treegraph
 
Reported: 2016-06-26 09:32 UTC by hmnwwh
Modified: 2018-06-30 18:19 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hmnwwh 2016-06-26 09:32:07 UTC
In the german localization, the short-cut to close a document always used to be <ALT>D (to get into the "Datei", i.e. "File" pull-down menu), then hitting the letter "c" as the 2nd letter in "Schließen", i.e. "close".

In this version (and I believe in the previous version/release, too, which I haven´t installed), the letter "c" invokes a close-without-saving action;  in order to close with saving, one needs to hit the letter "ß" (szlig).

Would it be possible to return to the former behaviour so that <ALT>D, then "c" closes a document with saving ?  This would be consistent across english and german localizations.

Thanks and best regards

Hans-Joachim Münch
Comment 1 sophie 2016-06-27 12:54:10 UTC
Hi, I'm passing it to the German team - Sophie
Comment 2 k-j 2016-06-28 06:24:55 UTC
First German answer (we work on this problem):
"Es wurden in der 5.0 und  vor allem in der 5.1 viele Mnemoniks geändert,
um Mehrfachbelegungen aufzulösen. Dabei ließ es sich auch nicht immer
vermeiden, etablierte Mnemoniks zu ändern. Insofern wird es schwierig
werden, dieses Verhalten rückgängig zu machen, ohne neue Konflikte zu
erzeugen oder auf Zeichen auszuweichen, die vielleicht nicht auf jeder
Tastatur verfügbar sind.

Das Problem ist auch, dass viele Menüeinträge in mehreren Komponenten
identisch sind und dadurch weitere Konflikte entstehen. Dafür wurde eine ziemlich komplizierte und umfangreiche Tabelle erstellt, mit
der alle Mnemoniks in allen Komponenten gegenüberstellt werden können, um
Konflikte aufzufinden und geeignet korrigieren zu können.

Für die Version 5.2 haben sich wieder etliche Einträge geändert. Die neuen Menüeinträge wurden noch nicht geprüft und ggf. zu korrigieren."

Translation:
There were in the 5.0 and especially in the 5.1 amended many mnemonics,
to resolve multiple assignments. We couldn't always avoid changing established mnemonics. Therefore, it is difficult to make this behavior reversed without producing new conflicts and avoiding characters that may not be available at any
keyboard.

The problem is that many menu items in several components
are identical and thus more conflicts appear. For that a rather complicated and extensive table was created, within all mnemonics may be facing in all components to find conflicts and be able to correct suitable.

For version 5.2 to several items have changed again. The new menu items have not been checked and corrected if necessary.
Comment 3 Buovjaga 2016-07-02 19:31:52 UTC
So do we keep this report open or is it being tracked in Pootle/elsewhere somehow?
Comment 4 k-j 2016-07-02 20:22:41 UTC
We should keep it open (for the next two months) because the German team will do some work on the whole problem about mnemonics. I don't know if it will happen for 5.1.x.
Comment 5 Dieter 2017-06-28 06:53:14 UTC
I confirm it with LO 5.4.0.1

Shortcut ALT+D and c: nothing happens
Shortcut ALT+D and ß: it should execute "Schließen" but it highlights "Webdatei öffnen"
Comment 6 QA Administrators 2018-06-29 02:46:15 UTC Comment hidden (obsolete)
Comment 7 Dieter 2018-06-29 07:26:13 UTC
(In reply to Dieter Praas from comment #5)
> I confirm it with LO 5.4.0.1
> 
> Shortcut ALT+D and c: nothing happens
> Shortcut ALT+D and ß: it should execute "Schließen" but it highlights
> "Webdatei öffnen"

Testes with LO 6.0.5.2

Shortcut ALT+D and c: nothing happens
Shortcut ALT+D and ß: execute "Schließen"

So I think everything works as expected, but the proposal of the bug report wasn't accepted. So I think, we can close this bug, but I don't know if it should be closed with WORKSFORME or WONTFIX. I close it with WORKSFORME. If somebody wqants to change it - no problem.
Comment 8 hmnwwh 2018-06-30 18:19:17 UTC
I logged the bug initially.

Sorry, not familiar with the procedures;  just got email to test &
confirm the bug fix would "work for me";  went there, found that
it´s status has already been set to "works for me".

So, for sake of completeness, as the bug logger, can confirm the
fix works for me, currently on LibreOffice Portable 6.0.2.1 ...
reluctant to go to 6.0.5 after some 4 or 5 weeks of a mind-bogging
Linux adventure;  went back to Windoughs for the better or worse,
with all Portable Apps and Encrypted mobile disks, however

(No, Cortana, not now - shut up you .&/§%&/$/§(/% ....)

Best Regards