Bug 100635 - crash after switching on the bibliography 'number entries' option (steps in comment 8)
Summary: crash after switching on the bibliography 'number entries' option (steps in c...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3 all versions
Hardware: All All
: medium critical
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:6.1.0 target:6.0.0.1 target:5.4.5
Keywords: haveBacktrace
Depends on:
Blocks: Bibliography
  Show dependency treegraph
 
Reported: 2016-06-27 08:44 UTC by Yury
Modified: 2018-01-05 19:26 UTC (History)
5 users (show)

See Also:
Crash report or crash signature: ["SwRect::GetBottomDistance(long)"]


Attachments
obfuscated file exposing the problem (3.80 MB, application/vnd.oasis.opendocument.text)
2016-09-20 16:03 UTC, Yury
Details
backtrace (131.92 KB, text/plain)
2017-02-27 19:08 UTC, Xisco Faulí
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yury 2016-06-27 08:44:19 UTC
The fairly big document (~145 pages, ~280 bibliography entries) has bibliography index in which shortnames for entries are strings. When I try to switch on the 'number entries' option, LO crashes.

Totally can't spend the time now on obfuscation of the content, so there will be no actual 'proof'. Just be advised this definitely and reliably happens with versions starting with 5.1.3.2 (downloaded earlier) and later, including 5.1.4 and 5.2.0dev, all of which are offered on libreoffice.org. Does NOT happen in 5.0.6 from libreoffice.org.

I'm keeping the 'offending' document version, so if there'll be some special binary builds with fixes or something, I'd be able to test.
Comment 1 Buovjaga 2016-07-02 11:38:46 UTC
If you won't share the document, then at least try to get a bt: https://wiki.documentfoundation.org/QA/BugReport/Debug_Information

Set to NEEDINFO.
Change back to UNCONFIRMED after you have provided the document or bt (preferably both).
Comment 2 Yury 2016-07-02 14:20:29 UTC
It's not the document's content is all that sensitive -- the results are published, and the doc itself will go public in its time. Just that it shouldn't be accessible right now -- very bad form, that.

And working with the debugger right now is out of question -- have completely no time for that.

How about I share the doc with one specific person? You, possibly?
Comment 3 Buovjaga 2016-07-02 18:09:12 UTC
(In reply to Yury from comment #2)
> How about I share the doc with one specific person? You, possibly?

Well it has to be attached to the report for the report to make sense in the future as well.
Comment 4 Yury 2016-07-03 04:09:22 UTC
(In reply to Buovjaga from comment #3)
> (In reply to Yury from comment #2)
> > How about I share the doc with one specific person? You, possibly?
> 
> Well it has to be attached to the report for the report to make sense in the
> future as well.

No go, then.

Actually, there were some issues with biblio entries in 5.0.6, too, coming up intermittently, so I went back to 4.4.7.2. (I've lost nothing in experience and gained in speed and free hardware resources).
Comment 5 Yury 2016-08-08 05:00:33 UTC
Tried this file in 5.2.0.4/rpm64, had the same issue.

Version: 5.2.0.4
Build ID: 066b007f5ebcc236395c7d282ba488bca6720265
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; 

And I'd like to remind you, guys, in 4.3.7.2/rpm64 (as distributred from 'old releases' section) this operation on this file works perfectly every time. Talk about laugh.

I again offer to provide this file PERSONALLY to someone who'll look into the problem. You'll likely discover the cause and create the concise testcase quickly, and need not my file any more after that.
Comment 6 Buovjaga 2016-08-08 09:55:37 UTC
(In reply to Yury from comment #5)
> I again offer to provide this file PERSONALLY to someone who'll look into
> the problem. You'll likely discover the cause and create the concise
> testcase quickly, and need not my file any more after that.

I think sooner than that happens, you will have time to do the debugging steps.
Comment 7 Yury 2016-09-20 16:03:37 UTC
Created attachment 127475 [details]
obfuscated file exposing the problem

Here's an obfuscated proofdoc. The issue still shows itself with it in:
Version: 5.2.1.2
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; 
Locale: ru-RU (en_GB.UTF-8); Calc: group
Comment 8 Buovjaga 2016-09-20 18:02:53 UTC
(In reply to Yury from comment #7)
> Created attachment 127475 [details]
> obfuscated file exposing the problem
> 
> Here's an obfuscated proofdoc. The issue still shows itself with it in:
> Version: 5.2.1.2
> Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
> CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; 
> Locale: ru-RU (en_GB.UTF-8); Calc: group

No crash here.

Steps:
1. Open document and go to page 114.
2. Right-click index and Edit index.
3. In the Type tab, check the box Number entries.
4. Hit ok.

Note that working with a debugger just means installing the debug packages, running LibreOffice with --backtrace and then making it crash.

Version 5.2 has the crash reporter, which makes things even more simple, but it only works with TDF builds.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.3.0.0.alpha0+
Build ID: 5c8ad526447934a5eae94fa5f40584083a874d9f
CPU Threads: 8; OS Version: Linux 4.7; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8); Calc: group
Built on September 19th 2016

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.4
Build ID: 5.2.0-1
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Comment 9 Aron Budea 2016-09-20 19:55:13 UTC
Crash reproduced in 5.1.4.2 and 5.2.1.2 / Ubuntu 16.04; 5.2.1.2 and 5.2.2.1 / Windows 7.

Crash report available: http://crashreport.libreoffice.org/stats/crash_details/2014be9c-1198-4b39-a665-3614f6c92a81
Comment 10 Yury 2016-09-21 08:22:36 UTC
(In reply to Buovjaga from comment #8)
> (In reply to Yury from comment #7)
> > Created attachment 127475 [details]
> > obfuscated file exposing the problem
> > 
> > Here's an obfuscated proofdoc. The issue still shows itself with it in:
> > Version: 5.2.1.2
> > Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
> > CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; 
> > Locale: ru-RU (en_GB.UTF-8); Calc: group
> 
> No crash here.

Here it passes through sometimes, too. And sometimes it's crash on each attempt.
Comment 11 Xisco Faulí 2017-02-27 18:59:32 UTC
Issue still reproducible in

Version: 5.4.0.0.alpha0+
Build ID: bd8c68c99cce51a3368d8ddfd6e11dccb72d8f49
CPU threads: 4; OS: Linux 4.8; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group
Comment 12 Xisco Faulí 2017-02-27 19:08:16 UTC
Created attachment 131517 [details]
backtrace
Comment 13 Xisco Faulí 2017-04-06 23:34:52 UTC
Reproduced in

Version: 4.2.0.0.alpha1+
Build ID: fc8f44e82de4ebdd50ac5fbb9207cd1a59a927e3

In previous versions, LibreOffice freezes importing the document
Comment 14 Xisco Faulí 2017-04-06 23:56:37 UTC
Before bbd37f87b337f4b5c91fae02357a932de3eaa094, LibreOffice froze at import time...
Comment 15 Xisco Faulí 2017-12-14 09:37:49 UTC
Still reproducible in

Version: 6.1.0.0.alpha0+
Build ID: 45bbb07680b3d81aaf66ef2d11c95d4c48ab23de
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded

The assert in the backtrace was added in e07feb9457f2ffb373ae69b73dda290140e4005f.

@Michael, one for you ?
Comment 16 Michael Stahl (CIB) 2017-12-15 16:42:56 UTC
fixed 2 bugs on master.
Comment 17 Commit Notification 2017-12-15 16:44:10 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2993bb634dc9ea66af90671a55a4503843338746

tdf#100635 sw: fix crash in SwTOXMgr::UpdateOrInsertTOX()

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Commit Notification 2017-12-15 16:44:22 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b77881366b17230908f441dfa27afcafc4374708

tdf#100635 sw: fix layout crash caused by field expansion ...

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 19 Commit Notification 2017-12-18 12:47:38 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4d4dfeac7cf8cd14efa15a2c5204afc9af4f680c&h=libreoffice-6-0

tdf#100635 sw: fix crash in SwTOXMgr::UpdateOrInsertTOX()

It will be available in 6.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2017-12-18 12:47:50 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a1e377aff16ea7c4d434ab60d7ed946c82514684&h=libreoffice-6-0

tdf#100635 sw: fix layout crash caused by field expansion ...

It will be available in 6.0.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 21 Xisco Faulí 2018-01-04 14:43:59 UTC
@Michael Stahl, should it be backported to 5.4 branch as well ?
Comment 22 Xisco Faulí 2018-01-05 00:15:21 UTC
Verified in

Version: 6.1.0.0.alpha0+
Build ID: 2bf1cc7372088ec31ac5f0fb60de57feda59d3b7
CPU threads: 4; OS: Linux 4.10; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group threaded
Comment 23 Commit Notification 2018-01-05 19:25:25 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1a27d6d76d6ef3afa5def40314120cd313b7f6d5&h=libreoffice-5-4

tdf#100635 sw: fix crash in SwTOXMgr::UpdateOrInsertTOX()

It will be available in 5.4.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 24 Commit Notification 2018-01-05 19:26:46 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-5-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fdac745028c2616ca4c7d105471282fc431cabc5&h=libreoffice-5-4

tdf#100635 sw: fix layout crash caused by field expansion ...

It will be available in 5.4.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.