Download it now!
Bug 100647 - The "Bookmark" dialog is broken for modifying existing bookmarks
Summary: The "Bookmark" dialog is broken for modifying existing bookmarks
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.2.0.1 rc
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-27 23:44 UTC by Regina Henschel
Modified: 2016-10-27 10:07 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Dummy textdocument with some bookmarks (76.79 KB, application/vnd.oasis.opendocument.text)
2016-06-27 23:44 UTC, Regina Henschel
Details
a test ODT with four bookmarks (23.26 KB, application/vnd.oasis.opendocument.text)
2016-06-28 21:15 UTC, V Stuart Foote
Details
file shows bug with bookmark dialog (26.92 KB, application/vnd.oasis.opendocument.text)
2016-08-07 09:05 UTC, Patrik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2016-06-27 23:44:56 UTC
Created attachment 125952 [details]
Dummy textdocument with some bookmarks

Open the attached text document.

Click on "bookmark"-icon or use Insert > Link > Bookmark. The new bookmark dialog opens.

Click into the text field to enter the name of the bookmark. The default text vanishes, but you cannot enter any character.

Open the dialog. Try to select any bookmark from the list. Selection is not possible.

You can still use the navigator to rename and delete bookmarks.

I'm using Version: 5.2.0.0.beta2
Build ID: a83fc06803e11f27e95c809fdfacbbd0377ff7d0
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
Locale: de-DE (de_DE)
Comment 1 V Stuart Foote 2016-06-28 17:49:46 UTC
Confirming issues as described.

On Windows 10 Pro 64-bit en-US with
Version: 5.2.0.1 (x64)
Build ID: fcbcb4963bda8633ba72bd2108ca1e802aad557d
CPU Threads: 8; OS Version: Windows 6.19; UI Render: GL; 
Locale: en-US (en_US)
Comment 2 V Stuart Foote 2016-06-28 21:07:25 UTC
On Fedora 23 64-bit with LXDE and current master
Version: 5.3.0.0.alpha0+
Build ID: f07aa1136ee68329a2b5f7cb88d2a8b5c83f474b
CPU Threads: 1; OS Version: Linux 4.2; UI Render: default; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-06-28_01:15:53
Locale: en-US (en_US.UTF-8)

Could not reproduce. The Bookmark dialog allows selection and rename/delete of the Bookmarks as well as navigation with the Go to button action.

Only visual glitch is that if using the Status bar page field -> Right mouse context menu, edit cursor is directed to the bookmarks but cursor is not visible. Need to F10 to the main menu and F10 back into the document to expose the edit cursor.
Comment 3 V Stuart Foote 2016-06-28 21:13:22 UTC
(In reply to V Stuart Foote from comment #2)
> Only visual glitch is that if using the Status bar page field -> Right mouse
> context menu, edit cursor is directed to the bookmarks but cursor is not
> visible. Need to F10 to the main menu and F10 back into the document to
> expose the edit cursor.

That visual glitch in the Status bar page field is not present in
Version: 5.0.6.2
Build ID: 5.0.6.2-7.fc23
Locale: en-US (en_US.UTF-8)

Which has the old Bookmark dialog preceding bug 90855 enhancement, with no real indication they are related.
Comment 4 V Stuart Foote 2016-06-28 21:15:43 UTC
Created attachment 125972 [details]
a test ODT with four bookmarks

Another dummy text based document with four bookmarks set, bm1 - bm4
Comment 5 Jean-Baptiste Faure 2016-07-28 11:18:01 UTC
Not reproducible for me with Version: 5.2.1.0.0+
Build ID: a2890a3fcdfcbf2447871ebc23db47864dd5b215
Threads CPU : 4; Version de l'OS :Linux 4.4; UI Render : par défaut; 
Ubuntu_16.04_x86-64
Locale : fr-FR (fr_FR.UTF-8); Calc: single

built at home.

Best regards. JBF
Comment 6 Patrik 2016-08-07 08:44:31 UTC
Same here on Linux Mint 18, LO Version: 5.2.0.4
Build ID: 066b007f5ebcc236395c7d282ba488bca6720265
CPU Threads: 4; OS Version: Linux 4.4; UI Render: default; 
Locale: de-CH (de_DE.UTF-8)

Opening the bookmark dialog does not allow to select any of the existing bookmarks. Therefore modifying or even jumping (goto) an existing bookmark is impossible.

The *table* with the existing bookmarks always keeps the focus on the top left cell. Nothing in the table is selectable. All buttons are disabled. Selecting something in the dialog causes a short repaint of the table but nothing is selected.

The bookmark *list* in Version: 5.1.4.2 does allow to select individual bookmarks. It seems therefore to be connected with the improvement done in 5.2 in this dialog.

The bookmark-feature is prominently displayed as an improvement in LO 5.2 and was the reason for me to digress from the standard 5.1.X in Linux Mint to 5.2. It's a bit disappointing that it now does not work. I wanted something to jump around in a big document as the headings have become too plentiful to be useful for navigation.
Comment 7 Patrik 2016-08-07 09:05:50 UTC
Created attachment 126638 [details]
file shows bug with bookmark dialog

hmm, some more information:

- the attachment 125972 [details] file above works fine here
- a new document also works with the bookmark menu

I copied and pasted many parts of the original document that did not work and created an attachement in which the bug is reproducable. 

It seems to be a problem of focus and only happens if the table at the end is in the document. Deleting the table means that the bookmark dialog works, inserting it again breaks the bookmark dialog.
Comment 8 Alexander Z 2016-09-09 01:32:29 UTC
The same on version: 5.2.1.2 (x64)
Build ID: 31dd62db80d4e60af04904455ec9c9219178d620
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
Locale: ru-RU (ru_RU)

As for Regina Henschel's attachment 125952 [details]:
Bug reproduced.
But.. When "Vorwort" bookmark (and this only) is deleted, Bookmark dialog works again. Moreover, when deletion is canceled, Bookmark dialog remains editable, as well as with saved file. 

New files work fine with Bookmark dialog.
Unfortunately, I have a hundred of bookmarks with cross references in my current file, and I can't know where is the problem.
But I can still insert bookmarks with default names "Bookmark N", which is not good.

attachment 125972 [details] & attachment 126638 [details]
Not reproduced.
Comment 9 Jan-Marek Glogowski 2016-09-19 13:29:26 UTC
This is probably fixed with my patch for bug 101359.

Backport for 5.2.3 submitted, 5.2.2 pending in Gerrit.
Comment 10 Daniel Grigoras 2016-10-05 11:47:53 UTC
I confirm this issue in version 5.2.1.1
I have inserted 8 bookmarks and now I cannot insert any other bookmarks, nor to select and modify the existing ones.
Comment 11 Daniel Grigoras 2016-10-05 12:19:15 UTC
(In reply to Darius Daniel Grigoras from comment #10)

I also confirm this issue in version 5.2.2.2
Comment 12 Cor Nouws 2016-10-27 10:07:03 UTC
(In reply to Jan-Marek Glogowski from comment #9)
> This is probably fixed with my patch for bug 101359.
> 
> Backport for 5.2.3 submitted, 5.2.2 pending in Gerrit.

Works ok in Version: 5.3.0.0.alpha1+
Build ID: 9c34797cc98030614b384b6ea0f233d59ae82253
CPU Threads: 4; OS Version: Linux 4.8; UI Render: default; VCL: gtk2; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-10-26_03:59:14
Locale: nl-NL (nl_NL.UTF-8); Calc: group

Assuming backport to 5.2 will be done > fixed.
thanks!