Bug 100661 - 0x80010105 error when CreateObject('com.sun.star.ServiceManager')
Summary: 0x80010105 error when CreateObject('com.sun.star.ServiceManager')
Status: RESOLVED DUPLICATE of bug 99643
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
5.1.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-06-28 15:36 UTC by Sergey S. Betke
Modified: 2016-09-13 15:40 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey S. Betke 2016-06-28 15:36:27 UTC
LibreOffice x64 edition installed with group policy extension (for computer, not for user). All office application start successfully, but when I start OLE server with CreateObject('com.sun.star.ServiceManager') - error 0x80010105.
Comment 1 Takeshi Abe 2016-07-07 11:52:43 UTC
Found the same report on Ask LibreOffice: https://ask.libreoffice.org/en/question/56531/ole-automation-in-libreoffice-5/
Comment 2 V Stuart Foote 2016-07-07 13:48:44 UTC
Attach to WinDbg and capturing a stack trace would be helpful...
Comment 3 Buovjaga 2016-07-15 19:05:33 UTC
Sergey: https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg

Change back to UNCONFIRMED after you have provided the trace.
Comment 4 nstenz 2016-09-09 14:16:36 UTC
Same thing is happening to me here on Windows Server 2012 R2 with no extensions when trying to create the object in FoxPro.

I have a theory, though- does the ActiveX interface support calls to the 64-bit version from 32-bit programs?
Comment 5 nstenz 2016-09-12 18:52:30 UTC
Yep, that was my problem- had LibreOffice x64 installed, but was trying to call the ActiveX component from an x86 process, which does not work. Works fine when using LibreOffice x86 build instead.
Comment 6 Michael Stahl (allotropia) 2016-09-13 15:40:28 UTC
currently the ActiveX library is built for both 32-bit and 64-bit
in a 32-bit LO build, but only for 64-bit in a 64-bit LO build.

*however* i think the ActiveX library isn't actually required here,
CreateObject("com.sun.star.ServiceManager") should only require
the UNO<->OLE automation bridge library, which had a 64-bit bug in 5.1.

this runs in a separate soffice.bin process so architecture of the
client process shouldn't matter.

probably a duplicate, should be fixed in current releases.

*** This bug has been marked as a duplicate of bug 99643 ***