Bug Hunting Session
Bug 100713 - easy crash after having canceled plugin update and checked again for update
Summary: easy crash after having canceled plugin update and checked again for update
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All All
: medium major
Assignee: Caolán McNamara
URL:
Whiteboard: target:5.3.0 target:5.2.0 target:5.1.5
Keywords: haveBacktrace
Depends on:
Blocks:
 
Reported: 2016-07-01 07:03 UTC by jean-baptiste
Modified: 2016-10-25 18:41 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
gdb trace (26.21 KB, text/x-log)
2016-07-03 09:15 UTC, jean-baptiste
Details
more precise gdb trace (42.40 KB, text/x-log)
2016-07-03 18:16 UTC, jean-baptiste
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jean-baptiste 2016-07-01 07:03:05 UTC
hi,

When I go to Tools > Extension Manager
Then, I click on "Check for updates..."

I have one available update, LanguageTool (actual version is 3.1, available version is 3.4)

I click on "Install", then, decide to cancel it.

Again, I click on "Check for updates..."

It will take a long time for checking, then crash and try to restore my document.
Note : if I cancel the checking, there is no crash.

Let me know if I can try something.

Version: 5.1.4.2
Build ID: 5.1.4.2-3.fc24
Threads CPU : 4; Version de l'OS :Linux 4.5; UI Render : par défaut; 
Locale : fr-FR (fr_FR.UTF-8)
Comment 1 Buovjaga 2016-07-02 20:07:56 UTC
(In reply to jean-baptiste from comment #0)
> Let me know if I can try something.

You can install the debug package for your distro and get a backtrace: https://wiki.documentfoundation.org/QA/BugReport/Debug_Information
Comment 2 jean-baptiste 2016-07-03 09:15:49 UTC
Created attachment 126042 [details]
gdb trace

here is the trace :)
Comment 3 jean-baptiste 2016-07-03 18:16:15 UTC
Created attachment 126043 [details]
more precise gdb trace

I just noticed the command for Fedora system is "dnf debuginfo-install libreoffice-core". Here is a new gdb file.

About the bug itself, I assume there is some sort of background download wich does it work and the call something when done, but fail because I canceled the action.
Comment 4 Commit Notification 2016-07-08 08:24:06 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=467887d3c938b48d13f70e559e15ffd081de512d

Related: tdf#100713 fix more recent bug to try and see older bug...

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2016-07-08 12:02:59 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=17cb84338d6921d012af1e1245f434f90bc25142

Resolves: tdf#100713 on cancel curData points to deleted parents vector entry

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2016-07-08 17:00:01 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bfbb5906bf85f7e4134d19fbe80216c549185e69&h=libreoffice-5-1

Resolves: tdf#100713 on cancel curData points to deleted parents vector entry

It will be available in 5.1.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2016-07-08 17:01:24 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=66a5eba473214b6d820cd5a45c58417f232d68ab&h=libreoffice-5-2

Resolves: tdf#100713 on cancel curData points to deleted parents vector entry

It will be available in 5.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2016-07-15 13:00:20 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-5-2-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aa21d31c6350f996bdff46c9ef5f4376e8fd841c&h=libreoffice-5-2-0

Resolves: tdf#100713 on cancel curData points to deleted parents vector entry

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 jean-baptiste 2016-07-17 21:11:47 UTC
hi there, thanks for the fix, I followed the process as described in https://wiki.documentfoundation.org/Installing_in_parallel/Linux

but I don't know how to locally install an outdated extension to reproduce the bug