Bug Hunting Session
Bug 100728 - Crash when area dialog is opened
Summary: Crash when area dialog is opened
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: high normal
Assignee: Rishabh
URL:
Whiteboard: target:5.3.0
Keywords: haveBacktrace, regression
Depends on:
Blocks: Single-Fill-Tab
  Show dependency treegraph
 
Reported: 2016-07-01 13:47 UTC by Heiko Tietze
Modified: 2016-08-01 09:27 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
bt with symbols (14.00 KB, text/plain)
2016-07-02 12:42 UTC, Julien Nabet
Details
Screenshot with area dialog open. (84.71 KB, image/png)
2016-07-02 12:46 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2016-07-01 13:47:56 UTC
LibO Draw (compiled from source) crashes when I open the area style dialog. 
1. Start Draw
2. Create a rectangle
3. Try to open the area style dialog by either context menu or via sidebar

warn:configmgr:28453:1:configmgr/source/xcuparser.cxx:911: ignoring modify of unknown set member node "StarOffice XML (Base) Report" in "file:///mnt/hdd/Sourcen/libreoffice/instdir/program/../share/registry/res/fcfg_langpack_en-US.xcd"
warn:configmgr:28453:1:configmgr/source/xcuparser.cxx:911: ignoring modify of unknown set member node "StarOffice XML (Base) Report Chart" in "file:///mnt/hdd/Sourcen/libreoffice/instdir/program/../share/registry/res/fcfg_langpack_en-US.xcd"
warn:configmgr:28453:1:configmgr/source/xcuparser.cxx:299: unknown component "org.openoffice.Office.UI.DbReportWindowState" in "file:///mnt/hdd/Sourcen/libreoffice/instdir/program/../share/registry/res/registry_en-US.xcd"
warn:configmgr:28453:1:configmgr/source/xcuparser.cxx:299: unknown component "org.openoffice.Office.UI.ReportCommands" in "file:///mnt/hdd/Sourcen/libreoffice/instdir/program/../share/registry/res/registry_en-US.xcd"
warn:vcl:28453:1:vcl/unx/generic/window/salframe.cxx:2018: X11SalFrame::Restore on withdrawn window
warn:ucb.ucp.gio:28453:1:ucb/source/ucp/gio/gio_content.cxx:399: ignoring GError "Vorgang wird nicht unterstützt" for <.uno:NewDoc>
warn:legacy.tools:28453:1:sfx2/source/control/bindings.cxx:1981: No cache for OfficeDispatch!
warn:vcl:28453:1:vcl/source/outdev/map.cxx:1515: MAP_PIXEL approximated with 72dpi
warn:vcl:28453:1:vcl/source/outdev/map.cxx:1515: MAP_PIXEL approximated with 72dpi
warn:vcl:28453:1:vcl/source/outdev/map.cxx:1515: MAP_PIXEL approximated with 72dpi
warn:vcl:28453:1:vcl/source/outdev/map.cxx:1515: MAP_PIXEL approximated with 72dpi
warn:vcl:28453:1:vcl/source/outdev/map.cxx:1515: MAP_PIXEL approximated with 72dpi
warn:vcl:28453:1:vcl/source/outdev/map.cxx:1515: MAP_PIXEL approximated with 72dpi
warn:vcl:28453:1:vcl/source/outdev/map.cxx:1515: MAP_PIXEL approximated with 72dpi
warn:vcl:28453:1:vcl/source/outdev/map.cxx:1515: MAP_PIXEL approximated with 72dpi
warn:vcl:28453:1:vcl/source/outdev/map.cxx:1515: MAP_PIXEL approximated with 72dpi
warn:vcl:28453:1:vcl/source/outdev/map.cxx:1515: MAP_PIXEL approximated with 72dpi
warn:legacy.osl:28453:1:svx/source/dialog/rulritem.cxx:751: Wrong MemberId
warn:legacy.tools:28453:1:sfx2/source/control/statcach.cxx:407: setting state of dirty message
warn:legacy.osl:28453:1:basegfx/source/polygon/b2dtrapezoid.cxx:654: Trapezoid decomposer in illegal state (!)
warn:legacy.osl:28453:1:basegfx/source/polygon/b2dtrapezoid.cxx:654: Trapezoid decomposer in illegal state (!)
warn:vcl:28453:1:vcl/source/outdev/map.cxx:1515: MAP_PIXEL approximated with 72dpi
warn:vcl:28453:1:vcl/source/outdev/map.cxx:1515: MAP_PIXEL approximated with 72dpi
warn:vcl:28453:1:vcl/source/outdev/map.cxx:1515: MAP_PIXEL approximated with 72dpi
warn:vcl:28453:1:vcl/source/outdev/map.cxx:1515: MAP_PIXEL approximated with 72dpi
warn:vcl:28453:1:vcl/source/outdev/map.cxx:1515: MAP_PIXEL approximated with 72dpi
warn:vcl:28453:1:vcl/source/outdev/map.cxx:1515: MAP_PIXEL approximated with 72dpi
warn:vcl:28453:1:vcl/source/outdev/map.cxx:1515: MAP_PIXEL approximated with 72dpi
warn:vcl:28453:1:vcl/source/outdev/map.cxx:1515: MAP_PIXEL approximated with 72dpi
warn:vcl:28453:1:vcl/source/outdev/map.cxx:1515: MAP_PIXEL approximated with 72dpi
warn:vcl:28453:1:vcl/source/outdev/map.cxx:1515: MAP_PIXEL approximated with 72dpi
warn:vcl.layout:28453:1:include/vcl/builder.hxx:401: .ui widget "LB_PATTERN" needs to correspond to vcl type 9PatternLB
soffice.bin: /mnt/hdd/Sourcen/libreoffice/include/vcl/builder.hxx:403: T* VclBuilder::get(VclPtr<T1>&, const rtl::OString&) [with T = PatternLB]: Zusicherung »dynamic_cast<T*>(w)« nicht erfüllt.
warn:vcl:28453:1:vcl/source/window/dialog.cxx:836: Dialog::StartExecuteModal() - Parent not visible
warn:vcl:28453:1:vcl/source/window/dialog.cxx:840: Dialog::StartExecuteModal() - Parent already modally disabled, use another parent to ensure modality!

Version: 5.3.0.0.alpha0+
Build ID: 546c3469af49e4b21fcefd719e93437e4de14485
CPU Threads: 8; OS Version: Linux 4.6; UI Render: default; 
Locale: de-DE (de_DE.UTF8)
Comment 1 Julien Nabet 2016-07-02 12:42:18 UTC
Created attachment 126032 [details]
bt with symbols

On pc Debian x86-64 with master sources updated today, I could reproduce this.
Comment 2 m.a.riosv 2016-07-02 12:46:00 UTC
Created attachment 126033 [details]
Screenshot with area dialog open.

Not reproducible.
Win10x64
Version: 5.3.0.0.alpha0+
Build ID: 757f221bceb74ccc2af8a9d4de149076280f29fb
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2016-06-23_23:54:55
Locale: es-ES (es_ES)
Comment 3 Julien Nabet 2016-07-02 12:51:00 UTC
(In reply to m.a.riosv from comment #2)
> Created attachment 126033 [details]
> Screenshot with area dialog open.
> 
> Not reproducible.
> Win10x64
> Version: 5.3.0.0.alpha0+
> Build ID: 757f221bceb74ccc2af8a9d4de149076280f29fb
> CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
> TinderBox: Win-x86@39, Branch:master, Time: 2016-06-23_23:54:55
> Locale: es-ES (es_ES)

I think the problem began here:
https://cgit.freedesktop.org/libreoffice/core/commit/?id=76585ae33f3ca75c05c0ccbf6a621b6e2d42bc00
(2016-06-28)
that's why you can't reproduce this.
Comment 4 m.a.riosv 2016-07-02 13:31:54 UTC
There are not windows builds to test.
Last: libo-master~2016-06-24_23.12.13_LibreOfficeDev_5.3.0.0.alpha0_Win_x86.msi
Comment 5 Rishabh 2016-07-02 13:55:05 UTC
Hi. I hope this fixes the issue - https://gerrit.libreoffice.org/#/c/26875/ .
Comment 6 Julien Nabet 2016-07-02 14:51:15 UTC
(In reply to Rishabh from comment #5)
> Hi. I hope this fixes the issue - https://gerrit.libreoffice.org/#/c/26875/ .

With this patch, it still fails but with this:
warn:vcl.layout:28169:1:include/vcl/builder.hxx:399: widget "FT_BITMAPS_HIDDEN" not found in .ui
warn:vcl.layout:28169:1:include/vcl/builder.hxx:401: .ui widget "FT_BITMAPS_HIDDEN" needs to correspond to vcl type 9FixedText
soffice.bin: /home/julien/lo/libreoffice/include/vcl/builder.hxx:402: T* VclBuilder::get(VclPtr<T1>&, const rtl::OString&) [with T = FixedText]: Assertion `w' failed.
Do you need the complete bt?

BTW, there are still refs to BitmapLB, see http://opengrok.libreoffice.org/search?q=BitmapLB&project=core&defs=&refs=&path=&hist=
but perhaps it's expected.
Comment 7 Rishabh 2016-07-02 17:53:33 UTC
Updated the commit - https://gerrit.libreoffice.org/#/c/26875/ . +1 the commit if the issue is resolved.
Comment 8 Commit Notification 2016-07-02 20:35:08 UTC
Rishabh Kumar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=527b88efbd9175e4fe376aa3617533f75ef99393

tdf#100728: Crash when area dialog is opened

It will be available in 5.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 9 Heiko Tietze 2016-07-02 23:11:09 UTC
Dialog opens now
Comment 10 Heiko Tietze 2016-07-02 23:34:18 UTC
(In reply to Heiko Tietze from comment #9)
> Dialog opens now

But not after fetching https://gerrit.libreoffice.org/#/c/26402/
Reopen?
Comment 11 Julien Nabet 2016-07-03 08:33:56 UTC
(In reply to Heiko Tietze from comment #10)
> (In reply to Heiko Tietze from comment #9)
> > Dialog opens now
> 
> But not after fetching https://gerrit.libreoffice.org/#/c/26402/
> Reopen?

This link corresponds to the initial change.
Rishabh has fixed it with https://gerrit.libreoffice.org/#/c/26875/
Beware, there are 2 versions of this one:
- first one (which contains a change on 1 file) fixes a first pb
- second version (which contains changes on 3 files) fixes an additional pb.
Comment 12 Heiko Tietze 2016-07-03 17:26:05 UTC
Thought the patch implements the new bitmap section, which is not included in the bug fix. Will talk to Rishabh about this.