Bug 100743 - Color agnostic pattern style
Summary: Color agnostic pattern style
Status: RESOLVED DUPLICATE of bug 100731
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Rishabh
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Single-Fill-Tab
  Show dependency treegraph
 
Reported: 2016-07-03 20:17 UTC by Heiko Tietze
Modified: 2016-07-03 21:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2016-07-03 20:17:31 UTC
The new pattern section (previously called and implemented as tab) has full support for individual presets. However the pattern colors (foregound and background) are not stored.
Comment 1 Rishabh 2016-07-03 20:34:15 UTC
Currently, the colors(foreground and background) are loaded by parsing the .png file in standard.sop->Pictures so there is no need to store the pattern colors in the xml file. Any specific functionality request to change the current workflow ?
Comment 2 Heiko Tietze 2016-07-03 20:50:23 UTC
If there is a configuration for colors it has to be persistent. Right now it's neither stored in the presets nor applied to the shape.
Comment 3 Rishabh 2016-07-03 20:57:11 UTC
(In reply to Heiko Tietze from comment #2)
> If there is a configuration for colors it has to be persistent. Right now
> it's neither stored in the presets nor applied to the shape.

Its related to this bug - https://bugs.documentfoundation.org/show_bug.cgi?id=100731 . Once the preview (under the preset list) is updated with background and foreground colors , it can be applied to shapes and saved as presets. I have mentioned the steps to update the preview in the bug report. Confirm again ?
Comment 4 Heiko Tietze 2016-07-03 21:21:22 UTC

*** This bug has been marked as a duplicate of bug 100731 ***