Bug 100744 - Color dropdown in gradient section have no label
Summary: Color dropdown in gradient section have no label
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsUXEval
Depends on:
Blocks: Single-Fill-Tab
  Show dependency treegraph
 
Reported: 2016-07-03 20:54 UTC by Heiko Tietze
Modified: 2016-07-10 09:10 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Heiko Tietze 2016-07-03 20:54:06 UTC
The gradient section of the area style dialog has two color settings, both implemented as dropdown control. These controls show the color but not the label as in the solid colors section, for instance.

Running on Linux/KDE and compiled for KDE (--enable-kde4)
Comment 1 Heiko Tietze 2016-07-03 20:58:04 UTC
Selecting one of the predefined gradients (e.g. Tango Green) adds the color as user-defined to the palette. Not sure that the gradients aren't defined independent from the standard palette. In this case we should consider to use other colors.
Comment 2 Rishabh 2016-07-03 21:04:37 UTC
Most of the colors(From and To) used to create gradients are not available in LibreOffice standard palette. Hence it appears as undefined color without a label.
Comment 3 Heiko Tietze 2016-07-03 21:19:50 UTC
@UX: The color dropdowns at gradient (and hatching) do not show non-standard color names (like "Red" or "Tango Sky Blue"). And most of the gradients do not use standard colors, such as "Tango Green". It looks like a bug compared to "Sunset", for example. Shouldn't we change the colors so that the presets are defined by colors from the standard pallete?
Comment 4 Heiko Tietze 2016-07-10 09:10:01 UTC
No comment sounds like everybody is fine with the current state. Closing this as WFM.