Bug Hunting Session
Bug 100747 - Crash in: WinFontInstance::CacheGlyphToAtlas(bool,int,WinLayout const &,SalGraphics &)
Summary: Crash in: WinFontInstance::CacheGlyphToAtlas(bool,int,WinLayout const &,SalGr...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
5.2.0.1 rc
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-03 23:56 UTC by V Stuart Foote
Modified: 2016-07-06 20:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature: ["WinFontInstance::CacheGlyphToAtlas(bool,int,WinLayout const &,SalGraphics &)"]


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description V Stuart Foote 2016-07-03 23:56:21 UTC
This bug was filed from the crash reporting server and is br-c20fd7e2-f123-47b1-a5eb-d40399b96d96.
=========================================

STR

1. Open LibreOffice 5.2.0.1
2. attempt to open into draw PDF attachment 107364 [details] (bug 84690)
3. immediate crash with the WinFontInstance::CacheGlyphToAtlas(bool,int,WinLayout const &,SalGraphics &)
Comment 1 Tomaz Vajngerl 2016-07-04 01:33:26 UTC
Interesting.. I can't reproduce this.
Comment 2 V Stuart Foote 2016-07-06 20:19:36 UTC
Version: 5.3.0.0.alpha0+
Build ID: fc95bc132db20e7701088c76da6ec039031feadf
CPU Threads: 8; OS Version: Windows 6.2; UI Render: GL; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2016-07-06_12:20:17
Locale: en-US (en_US); Calc: group

Tomaž's commit for bug 98710 also took care of this. The string value using Symbol in the sample PDF comes up cleanly. 

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b5cd1220b849a9759dd4446032a7e1affbf151f2