Bug 100815 - exports all sheets in csv
Summary: exports all sheets in csv
Status: RESOLVED DUPLICATE of bug 92984
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: CSV-Export
  Show dependency treegraph
 
Reported: 2016-07-08 13:09 UTC by piviul
Modified: 2020-01-30 09:36 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description piviul 2016-07-08 13:09:17 UTC
Please, enhance libreoffice command line (--headless) to permit to know something about a document (for examples how many and/or the names list of sheets contained in a ods document) and add some options to choose the sheet or the sheets you want to convert to. I've found a lot of people that ask this feature on the web!!!

Thank you very much

Piviul
Comment 1 Joel Madero 2016-07-08 14:11:46 UTC
I'll confirm this.

FYI: Enhancements are tackled almost entirely by volunteers. I am only confirming that it's a valid request, not ensuring that it will ever be implemented. For it to be implemented a volunteer would have to find it interesting enough to do which may never happen. The fact that "a lot of people ask for it" is irrelevant as LibreOffice has a strong motto of "the doers decide what gets done." 

Thanks for the suggestion.
Comment 2 Timur 2020-01-30 09:36:51 UTC
This bug was confirmed too soon. 
Title says "exports all sheets in csv", which would be a new request (possibly WontFix), but comment is different,suggesting improvement for an existing headless export. 
I'll consider that comment is correct and add this as a duplicate of bug 92984, which asks for a warning in GUI.
Meaning that we should have warning both in GUI and headless mode.

*** This bug has been marked as a duplicate of bug 92984 ***