Bug 100854 - RTL: Persian and arabic diacritics are not accessible by using arrow keys to be read by screen reader
Summary: RTL: Persian and arabic diacritics are not accessible by using arrow keys to ...
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: accessibility
Depends on:
Blocks: 54494 a11y RTL-Arabic
  Show dependency treegraph
 
Reported: 2016-07-11 18:25 UTC by zahra
Modified: 2017-10-17 12:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zahra 2016-07-11 18:25:15 UTC
hi every one. 
i have a very critical problem in using libreoffice. 
i became familiar with your project two years ago. 
i am realy advocater of opensource projects, 
but i am blind, i can only use keyboard and unfortunately diacritics in persian and arabic is not accessible by using left and right arrow keys. 
this problem occurs with libreoffice, openoffice, mozilla firefox and also windows notepad. 
it does not happen with internet explorer, wordpad and also microsoft word. 
when i use the arrow keys to navigate letter by letter, unfortunately these opensource projects dont consider diacritics and my screen reader nvda only reads the letters, not diacritics. 
please for example copy this word and try to use the arrow keys with both libreoffice writer and also microsoft word to see the result. 
i cant buy microsoft office and i hate its ribon menus. 
for the sanctions in iran and some other countries, we cant buy microsoft office legally. 
and also, i love libreoffice and i dont want to use other programs. 
i invoke you and sincerely i request you the developers and programmers of libreoffice to guide me in this regard. 
i strove very hard trying to change settings and asked help from many peoples. 
but unfortunately without any result. 
it becomes a great desire and wish for me to read and write documents with diacritics without this problem and i dont know what should i do and how to achieve this goal.
i pray for you and request devine mercy and blessings for you. please help me for the solution!
here you are two words for example

شُكر

الْغَفورُ
Comment 1 Khaled Hosny 2016-08-01 19:45:56 UTC
The cursor movement uses Grapheme Clusters (http://unicode.org/reports/tr29/#Grapheme_Cluster_Boundaries) as a unit, a base character plus a combining mark are considered one grapheme cluster so moving the cursor forward will skip the whole cluster.

I can’t confirm the MS Office behavior, but treating the mark as a different unit here can be visually confusing since there will be no indication that the cursor has moved at all (since the mark has zero advance width), so it is a big change to do.

I’m not sure I understand the screen reader issue clearly, are you saying that the reader does not read the marks because the cursor skips them? I have no experience with screen readers, unfortunately, so I don’t understand why reading the marks would be tied to cursor movement?
Comment 2 Khaled Hosny 2016-08-01 22:49:26 UTC
Please see https://github.com/nvaccess/nvda/issues/4664 for a suggestion how to work around this issue.
Comment 3 zahra 2016-08-02 17:03:39 UTC
hi. 
thanks so much for your explane.
yes there are exactly two bug report which explane one problem and i mean that they are the same problem!
i realy need diacritics and i wish that this problem will be solved in a very near future in openoffice and libreoffice!
i think that the cursor skips the diacritics and nvda in this case skips from them too!
i suggest you copy the farsi word which i copied in libreoffice, openoffice and then compare them with microsoft office!
in that case, press control+home to go to the first character of the world, then use left and right arrow keys to navigate in the word.
i think that you observe that the cursor skips from diacritics and only considers the characters!
hope that help.
thanks for your time for solving these issues and God bless you.
Comment 4 Buovjaga 2016-10-07 17:41:16 UTC Comment hidden (obsolete)
Comment 5 Urmas 2016-10-08 06:17:56 UTC
Can't you use Alt+arrows to navigate to diacritics? I can select and delete them this way.
Comment 6 krishna [:kr1shna] 2017-06-13 09:16:34 UTC Comment hidden (obsolete)
Comment 7 zahra 2017-07-03 17:08:38 UTC
for example:
شُكر
except ُ
has only three characters and with ُ
which is one of diacritics has four characters!
but unfortunately libreoffice and openoffice ignore diacritics, both in navigating character by character with left and right arrow keys,
and in character count, also ignore the diacritics and it causes wrong number of characters in the books.
in mozilla firefox which i mentioned, this problem occures when writing something with diacritics in edit boxes and navigating letter by letter, but not occure when we read available books and articles and books with html format in our computer or in the internet sites.
Comment 8 zahra 2017-07-03 17:13:59 UTC
hello.
i realized that its not screen reader behaviour, but both libreoffice and openoffice ignore diacritics and dont behaviour about them like general letters.
could you please help me and tell me what setting should i change to libreoffice supports diacritics and considers them like general letters?
i dont know how should i read, write and edit my book, without supporting of diacritics!
God bless you.
Comment 9 zahra 2017-07-04 09:52:11 UTC
(In reply to Khaled Hosny from comment #1)
> The cursor movement uses Grapheme Clusters
> (http://unicode.org/reports/tr29/#Grapheme_Cluster_Boundaries) as a unit, a
> base character plus a combining mark are considered one grapheme cluster so
> moving the cursor forward will skip the whole cluster.
> 
> I can’t confirm the MS Office behavior, but treating the mark as a different
> unit here can be visually confusing since there will be no indication that
> the cursor has moved at all (since the mark has zero advance width), so it
> is a big change to do.
> 
> I’m not sure I understand the screen reader issue clearly, are you saying
> that the reader does not read the marks because the cursor skips them? I
> have no experience with screen readers, unfortunately, so I don’t understand
> why reading the marks would be tied to cursor movement?

hello.
thanks for your link.
but i confirm that i dont have this problem when i used microsoft office in previous years.
how should i set libreoffice to support diacritics both in character count and also when i navigate using right arrow keys?
i realy wish to use libreoffice, but i only have islamic books in word format which i need writer, and i could not use libreoffice because of this problem in these years!
i appreciate your help and God bless you.
Comment 10 zahra 2017-07-04 09:57:30 UTC
i read the bug and its clear, this behaviour is not related to the screen readers, its for libreoffice which should move cursor between both letters and diacritics, (not only between letters which does now by default)
libreoffice should does not ignore diacritics and behave with them like general letters.
Comment 11 zahra 2017-07-04 10:04:31 UTC
i read this bug and its not related to the screen reader.
libreoffice should does not ignore diacritics, behave with them like usual letters, allow us to navigate between both letters and diacritics using left and right arrow keys, and counts them in the characters!
Comment 12 Yousuf Philips (jay) (retired) 2017-10-13 20:17:37 UTC
Khaled mentioned in comment 1 and github[1], "Changing the behavior of LibreOffice (and tens of other applications) is very unlikely since this is the expected behavior by most users, also allowing the cursor movement to treat combining marks separately is visually confusing since the marks will have zero advance width so moving the cursor after them will not provide any visual feedback.

I’m not sure how screen readers should handle this, though, but the problem is not limited to Arabic (it affects any text where there are multi-character point grapheme clusters) and is not limited to LibreOffice either."

The solution to this is to press alt+cursor key, which will make diacritics accessible, as mentioned in comment 5 and bug 54494. But even with this movement NVDA and JAWS on Windows and Orca on Linux still dont read the character at the current cursor position.

https://github.com/nvaccess/nvda/issues/4664#issuecomment-236731312
Comment 13 zahra 2017-10-16 14:44:17 UTC
(In reply to Urmas from comment #5)
> Can't you use Alt+arrows to navigate to diacritics? I can select and delete
> them this way.

hello. i cant use alt with arrow keys for using diacritics.
it does not work for me and if it works, i dont know because my screen reader does not read diacritics for me even using this method!
Comment 14 zahra 2017-10-16 14:51:10 UTC
(In reply to Yousuf Philips (jay) from comment #12)
> Khaled mentioned in comment 1 and github[1], "Changing the behavior of
> LibreOffice (and tens of other applications) is very unlikely since this is
> the expected behavior by most users, also allowing the cursor movement to
> treat combining marks separately is visually confusing since the marks will
> have zero advance width so moving the cursor after them will not provide any
> visual feedback.
> 
> I’m not sure how screen readers should handle this, though, but the problem
> is not limited to Arabic (it affects any text where there are
> multi-character point grapheme clusters) and is not limited to LibreOffice
> either."
> 
> The solution to this is to press alt+cursor key, which will make diacritics
> accessible, as mentioned in comment 5 and bug 54494. But even with this
> movement NVDA and JAWS on Windows and Orca on Linux still dont read the
> character at the current cursor position.
> 
> https://github.com/nvaccess/nvda/issues/4664#issuecomment-236731312

hello.
ignoring diacritics is not expected behaviour for me!
i realy love libreoffice, wish to use it, appreciate your great work and sincerely pray for you every day.
but as i mentioned, i have hundreds of islamic books and need supporting diacritics to read and edit them easily!
i love the behaviour of microsoft word, notepad plus plus etc in this regard for supporting diacritics!
alt with arrow keys does not work for me or if it works, my screen reader does not read anything for me!
is there any setting that i should change in order to alt with arrow keys support diacritics?
Comment 15 zahra 2017-10-16 14:59:34 UTC
when i navigate letter by letter, nvda just reads letter and not diacritics!
i think because cursor skips diacritics and this problem make editing islamic books or any books which have contain diacritics very difficult.
why you set this problem NotABug?
its a very critical bug for me and i wish that someone suggest a solution to use my favorite version 5.3.4.1 forever without any problem!
its duplicate of tdf 91764 which i reported previously and the problem is the same, ignoring diacritics!
Comment 16 Yousuf Philips (jay) (retired) 2017-10-16 20:57:05 UTC
(In reply to zahra from comment #14)
> hello.
> ignoring diacritics is not expected behaviour for me!

Unfortunately it is the behaviour that LibreOffice has decided to have.

> i realy love libreoffice, wish to use it, appreciate your great work and
> sincerely pray for you every day.

We are all grateful for your praise.

> but as i mentioned, i have hundreds of islamic books and need supporting
> diacritics to read and edit them easily!

We wish you the best in your efforts.

> i love the behaviour of microsoft word, notepad plus plus etc in this regard
> for supporting diacritics!

It is unfortunate, but it seems you will have to use one of these apps to do the work you are doing.

> alt with arrow keys does not work for me or if it works, my screen reader
> does not read anything for me!

Yes it didnt work for me either unfortunately, which was sad, but is a bug in the screen readers i believe.

> is there any setting that i should change in order to alt with arrow keys
> support diacritics?

It is supported in LibreOffice, but not in the screen readers.
Comment 17 zahra 2017-10-17 12:41:23 UTC
> i love the behaviour of microsoft word, notepad plus plus etc in this regard
> for supporting diacritics!


It is unfortunate, but it seems you will have to use one of these apps to do the work you are doing.

i only love your program, promised to use the first version that support all of my books without any crash forever which is version 5.3.4.1 for me.
how can i do my work editing islamic books which have diacritics?

i am sure that one day i did something that libreoffice supported diacritics, but cant remember what i did!