Bug 100930 - The display order from Find All is confusing and inconsistent
Summary: The display order from Find All is confusing and inconsistent
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.1.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Find-Search
  Show dependency treegraph
 
Reported: 2016-07-15 10:02 UTC by B.J. Herbison
Modified: 2021-11-04 09:27 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
sort1: Example for cell truncation and initial order (76.36 KB, image/png)
2016-07-15 10:02 UTC, B.J. Herbison
Details
sort2: After sort by Cell (78.75 KB, image/png)
2016-07-15 10:03 UTC, B.J. Herbison
Details
sort3: Sort by Sheet then by Cell (77.84 KB, image/png)
2016-07-15 10:03 UTC, B.J. Herbison
Details
Initial sort with 6.3.3 (99.58 KB, image/png)
2019-11-02 11:17 UTC, B.J. Herbison
Details

Note You need to log in before you can comment on or make changes to this bug.
Description B.J. Herbison 2016-07-15 10:02:07 UTC
Created attachment 126220 [details]
sort1: Example for cell truncation and initial order

Observed:
1) The Cell column is truncated, even for fairly small documents. (See attachment sort1.)

2) The original sort for the Cell column isn't by row or column. (See attachment sort1.) And it doesn't appear consistent between searches of the same document (at least on Linux).

3) Running the same sort multiple times produced different initial display orders. (Observed on Linux, not Windows, but less testing was done on Windows.)

4) Clicking to sort the Cell column produces a sort which appears to be based on a character sort of the cell names, which isn't useful. (See attachment sort2.) A2 should come before A10.

5) Sorts aren't stable. Sorting by Content sometimes produces a different non-useful sort for Cell (even when the content of all cells is identical). Sorting by Cell produces strange orders for sheets. (Version 5.1.4.2 on Windows 7 appears to have stable sorts in some cases. Version 5.1.4.2 on Ubuntu doesn't have stable sorts.)

See attachment sort3 for an example of non-stable sorts on Windows 7. I sorted by Sheet then by Cell.

6) One search with results on Sheet1, Sheet2, and Sheet3 the initial order of the results was:
- Some on Sheet1
- Some on Sheet3
- All from Sheet2
- The rest from Sheet3
- The rest from Sheet1
A later search for the same content in the same document produced a different order. (I only saw this on Linux.)

6) Sorting by sheet displays the sheets alphabetically, not by order in document.

Expected:
1) When search results are displayed, adjust the Cell column width to prevent truncation.

2) The initial sort order should be by Sheet (order in document) primary, Cell (by row or by column, choose one) secondary.

3) If you want to take the focus in the document into account, use the focus to determine which entry in the search results is selected when the results are displayed.

4) Clicking to sort the Sheet column should cycle between ascending (by name of sheet), descending (by name of sheet), ascending (by order of sheets in document), descending (by order of sheets).

5) When switching between sorting sheets alphabetically and by order in document the shape/appearance of the search arrow should change. (Some applications use an outline around the sort arrow to indicate mode changes like this.)

6) Clicking sort for Cell should cycle between ascending by row, descending by row, ascending by column, descending by column.

7) When switching between sort by row and by column the shape/appearance of the search arrow should change.

8) All sort operations should be stable sorts.
Comment 1 B.J. Herbison 2016-07-15 10:03:08 UTC
Created attachment 126221 [details]
sort2: After sort by Cell
Comment 2 B.J. Herbison 2016-07-15 10:03:39 UTC
Created attachment 126222 [details]
sort3: Sort by Sheet then by Cell
Comment 3 Heiko Tietze 2016-10-11 13:19:22 UTC
Having a trustable sort is not questionable from the UX POV. 

Removing needsUXEval, component to Calc and NEW.
Comment 4 QA Administrators 2017-10-23 14:10:47 UTC Comment hidden (obsolete)
Comment 5 B.J. Herbison 2017-10-25 10:26:17 UTC
The problem still exists with LibreOffice Version 5.4.1.2 on Ubuntu.

I didn't test every case I initially reported, but:
* The initial display cell order is still confusing.
* The single column sort by cell still puts A10 before A9.
* The Cell column is still truncated when first displayed.
Comment 6 QA Administrators 2018-10-26 02:58:30 UTC Comment hidden (obsolete)
Comment 7 B.J. Herbison 2018-10-31 21:48:21 UTC
Many problems still exist with version 6.0.6.2. I will cover the state of each issue I originally raised.

1) The unnecessary and inappropriate truncation of the Cell column is still a problem.

2) The original sort situation seems to have fixed or improved as the sort order was reasonable for every test I ran.

3) This also seems to be fixed.

4) Still a problem.

5) Sorts still aren't stable on Ubuntu.

First 6) I no longer see this problem.

Second 6) (sorry) Still a problem.

And the overall behavior doesn't meet the expectations I outlined.
Comment 8 QA Administrators 2019-11-01 03:36:47 UTC Comment hidden (obsolete)
Comment 9 B.J. Herbison 2019-11-02 11:17:05 UTC
Created attachment 155459 [details]
Initial sort with 6.3.3

The situation has changed with 6.3.3, but problems still exist.

The cell column was wide enough in every case I tested.

The initial sort order is not by row or by column which makes the results hard to use for large result sets.

The ability to sort by column has gone away. This removes some of my reported problems but is a major feature loss.
Comment 10 Heiko Tietze 2019-11-04 09:22:11 UTC
How about "Sheet" (with Sheet4.$A$1, Sheet4.$A$2...), "Row" (1,2...), and "Col" (A,B...), "Content"?
Comment 11 B.J. Herbison 2019-11-04 10:07:42 UTC
I would find separate columns more useful for single-sheet search results if the sorting was added back to the search results.

For multiple sheets search results then sorting by the Sheet column wouldn't be stable on the row and column results--my position is 1) it should be possible to sort by sheet without otherwise changing row and column order in the search results, and 2) if you sort on a sheet column that says Sheet4.$A$1 it should sort on the full value of the column so the UI clearly reflects the sort order.

Just putting the index in the Col column would also be less readable if the Tools/Options.../LibreOffice Calc/Formula/Formula Syntax setting was changed to "Excel R1C1". There would be two columns with just number. I don't know whether that would be a minor or significant confusion (and I don't use that setting).
Comment 12 Heiko Tietze 2019-11-04 19:12:28 UTC
(In reply to B.J. Herbison from comment #11)
> sorting by the Sheet column wouldn't be stable on the row and column results

Sorting order is: S1.$A$1,S1.$A$2,S1.$B$1,S1.$B$2,S2.$A$1,S2.$A$2,S2.$B$1,S2.$B$2 - so it is "stable" on row/column.
Comment 13 B.J. Herbison 2019-11-04 19:21:36 UTC
What I meant is that the "Sheet" column wouldn't just change the sheet order, it would also change the row and column (and value) ordering within the sheet. A stable sort based on "sheet" wouldn't change the relative order of cells within the sheet.

Actually, a column containing Sheet4.$A$1 should be labeled "Reference" or "Identifier" since the value isn't just a sheet identifier.

Is there a plan to add sorting back to the result list?
Comment 14 Heiko Tietze 2019-11-04 19:32:20 UTC
(In reply to B.J. Herbison from comment #13)
> Is there a plan to add sorting back to the result list?

We do not plan the development. If a developer is interested s/he might pick this easy task.
Comment 15 QA Administrators 2021-11-04 04:10:04 UTC Comment hidden (obsolete)
Comment 16 B.J. Herbison 2021-11-04 09:27:06 UTC
Thank you. The truncation is back (at least for small sheets), and the sorting is back and useful.

Version: 7.2.2.2 / LibreOffice Community
Build ID: 02b2acce88a210515b4a5bb2e46cbfb63fe97d56
CPU threads: 4; OS: Linux 5.13; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded