Download it now!
Bug 100973 - Bidirectional complex text drawn from right to left does not show up correctly with certain fonts
Summary: Bidirectional complex text drawn from right to left does not show up correctl...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
5.3.0.0.alpha0+
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: HarfBuzz
Blocks:
  Show dependency treegraph
 
Reported: 2016-07-17 19:43 UTC by akash96j
Modified: 2017-04-11 08:23 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document (12.47 KB, application/vnd.oasis.opendocument.text)
2016-07-17 19:43 UTC, akash96j
Details
Sample Image (81.06 KB, image/png)
2016-07-17 19:44 UTC, akash96j
Details

Note You need to log in before you can comment on or make changes to this bug.
Description akash96j 2016-07-17 19:43:41 UTC
Created attachment 126254 [details]
Sample Document

Complex bidirectional text(ex. Arabic) does not render correctly for some fonts on Windows.

To recreate:
1. Open new doc.
2. Copy any paragraph from ar.lipsum.com containing bidirectional text i.e. lines with both english and arabic.
3. Copy and paste into LO.
4. Format->Paragraph->Alignment->Properties->Text-Direction->Right-to-Left

The text does not render correctly.
Sometimes the text will render correctly but as soon as "Show non printing characters" is selected, the rendering is changed and is not proper.
This only happens with some fonts(ex. Liberation Serif).
With non printing characters set to show, the rendering is almost never right.
Comment 1 akash96j 2016-07-17 19:44:49 UTC
Created attachment 126255 [details]
Sample Image
Comment 2 akash96j 2016-07-17 19:48:09 UTC
The rendering seems to be broken only for lines which contain bidirectional text.
This bug is most likely in the Uniscribe code path used for complex text layout on Windows.

Note: This bug does not occur in my feature branch. My feature branch does not use uniscribe on windows. So the text layout in RTL right-to-left text renders correctly.
Comment 3 Buovjaga 2016-08-02 11:44:05 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.3.0.0.alpha0+
Build ID: cf0fea5546c9b6b30d18deb084ddaa5e08aad41b
CPU Threads: 4; OS Version: Windows 6.1; UI Render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2016-07-30_23:31:05
Locale: fi-FI (fi_FI); Calc: CL